source: projects/specs/trunk/lib/libq/libqb/libqb-vl.spec @ 9394

Revision 9394, 26.2 KB checked in by inagaki, 9 years ago (diff)

2015-02-28 Ryoichi INAGAKI <ryo1@…>

  • corosync, pacemaker, resoure-agents: updated
  • libqb, perl-Net-IAMP-Simple-SSL: new


Line 
1Name:           libqb
2Version:        0.17.1
3Release:        2%{?_dist_release}
4Summary:        An IPC library for high performance servers
5Summary(ja):    高性能サーバー用のプロセス間通信ライブラリ
6
7Group:          System Environment/Libraries
8License:        LGPLv2+
9URL:            http://clusterlabs.github.io/libqb/
10Source0:        https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires:  libtool doxygen procps check-devel automake
14
15%description
16libqb provides high performance client server reusable features.
17Initially these are IPC and poll.
18
19%package        devel
20Summary:        Development files for %{name}
21Summary(ja):    %{name} の開発用ファイル
22Group:          Development/Libraries
23Requires:       %{name} = %{version}-%{release}
24Requires:       pkgconfig
25
26%description    devel
27The %{name}-devel package contains libraries and header files for
28developing applications that use %{name}.
29
30
31%prep
32%setup -q
33
34# Make sure the timestamps are correct
35find . -exec touch \{\} \;
36
37%build
38%configure --disable-static
39make %{?_smp_mflags}
40
41%check
42make -j1 check
43
44%install
45rm -rf $RPM_BUILD_ROOT
46make install DESTDIR=$RPM_BUILD_ROOT
47find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
48rm -rf $RPM_BUILD_ROOT/%{_docdir}/*
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post -p /sbin/ldconfig
54
55%postun -p /sbin/ldconfig
56
57%files
58%defattr(-,root,root,-)
59%doc COPYING
60%{_sbindir}/qb-blackbox
61%{_libdir}/libqb.so.*
62
63%files devel
64%defattr(-,root,root,-)
65%doc COPYING README.markdown
66%{_includedir}/qb/
67%{_libdir}/libqb.so
68%{_libdir}/pkgconfig/libqb.pc
69%{_mandir}/man3/qb*3*
70%{_mandir}/man8/qb-blackbox.8.gz
71
72%changelog
73* Thu Feb 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.17.1-2
74- Initial build for Vine Linux
75
76* Tue Aug 26 2014 David Vossel <dvossel@redhat.com> - 0.17.1-1
77Fix: ipcs: Correctly allocate receive buffer size
78Fix: ipc_socket: Signalhandler must be resetted to Default, use only cleanup_sigpipe to return from qb_ipc_dgram_sock_setup.
79Fix: trie: allow modifying the trie map during the notify callback
80Fix: fix invalid option when run 'ipcclient -h'
81Fix: epoll: don't miss poll events under high load
82Fix: ipc_shm: fix error handling in qb_ipcs_shm_connect()
83Fix: ringbuffer: fix size in qb_rb_create_from_file()
84Fix: ringbuffer: fix qb_rb_open_2() debug format string
85Fix: trie: fixes regression caused by ref count refactoring
86Fix: ipcc: Properly timeout during recv when timeout value is provided
87
88* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.17.0-4
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
90
91* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.17.0-3
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
93
94
95* Thu Feb 20 2014 David Vossel <dvossel@redhat.com> - 0.17.0-2
96Fix testsuite timing values
97
98* Wed Feb 19 2014 David Vossel <dvossel@redhat.com> - 0.17.0-1
99Fix: build: Allow 'make rpm' to work with lightweight tags for release candidates
100Fix: spec: reference correct url in spec file
101Doc: update broken doxygen link to something that exists
102Bump version to 0.17.0
103Low: ipc_socket: further optimize max msg size calculations for fbsd portability tests
104Low: ipc_socket: Allow socket max msg size to be calculated more accurately
105Fix: fixes travis compile time error
106Low: tests: Fixes compile time issue with make check
107High: ipcs: Prevent ipc server use after free.
108Low: ipc: Remove ipc connection reference given to dispatch functions
109High: ipc: Fixes memory leak in server connection accept when client partially connects
110IPC: Increase the listen backlog of IPC server
111Low: ipcs: Clarifications to the ipcs server callback documentation.
112Fix rb.test to avoid overwriting memory during reading.
113Low: example: Update client/server example to use server enforced buffer size
114Low: Client side buffer retrieval regression test
115Feature: New api function to retrieve client buffer size
116Low: check_ipc.c: Verify server enforced buffer sizes work
117Feature: Enforce buffer size limits on the server side
118Low: regession tests for regex log filters
119Feature: Filter logs using regex patter on function, format, or filename
120ipc_setup: Set SO_PASSCRED on listener socket
121Fix: log: Filtering by function and file must match exactly, no substring matches
122Low: blackbox: Abort blackbox logging on ringbuffer overwrite reclaim error
123High: ipcs: Api function allowing server to retrieve client connection's ipc buffer size
124Low: ringbuffer: Abort during chunk reclaim if OVERWRITE flag is set and reclaim fails.
125High: blackbox: unique blackbox ringbuffer files per pid
126Low: ipc_socket: Fixes fd leak in socket ipc client disconnection
127Use sizeof to get the correct size of the sockaddr_un sun_path member in a portable way. Fixes corosync on Mac OS X.
128Detect the max signal value that can be used using NSIG macro
129Avoid double-decrement of level->todo
130
131* Thu Aug 1 2013 David Vossel <dvossel@redhat.com> - 0.16.0-1
132Bump version to 0.16.0 ... do not use version 0.15.0
133Update release gpg sign key
134Bump the version to 0.15.0
135Merge pull request #83 from davidvossel/master
136Low: ipc_socket: Output send event failure as debug instead of error
137Low: ipcserver.c: Fix example server's glib mainloop implementation
138High: ipc_socket.c: Detect EOF connection on connection STREAM socket
139Merge pull request #81 from davidvossel/dgram_max_msg
140Low: tests: Add dgram max size detection test
141Low: ipc_socket.c: Handle the unlikely event of an EAGAIN or EINTR during dgram max size detection
142Merge pull request #82 from davidvossel/master
143Fixes detect disconnect on send for tcp example
144Fixes sem leak
145Fixes less-than-zero comparision of unsigned int
146fixes double close
147Fixes double close
148Fixes double fd close
149Fixes fd leak
150Prevent use after free in benchmark util
151Fixes use ater free in shm disconnect
152Fixes use after free during ipcs client disconnect
153Remove dead code
154Low: check_ipc.c: Verify dgram max size during tests
155High: ipcc: Add abilty to verify dgram kernel buffer size meets max msg value
156Fixes travis build error
157Merge pull request #80 from davidvossel/master
158Low: check_ipc.c: fix debug message to only display once.
159High: ringbuffer: Make max_size of ringbuffer accurate so shm ipc max msg size value is honored
160Low: ipcs: For shm ipc, always retry outstanding notifications when next event is sent
161Low: tests: Added test to verify sending ipc msg equal to max size succeeds
162Merge pull request #79 from davidvossel/master
163Merge pull request #78 from davidvossel/master
164Fix: ipcs: Fixes compile time issue reported by travis
165Merge pull request #77 from davidvossel/stress_tests_fixes
166Low: loop_pool_kqueue: remove potentially noisy dbug statement
167Low: tests: rework bulk event msg ipc test
168Account for fbsd ENOBUFS during stress test
169Low: tests: Adds ipc event stress test to testsuite
170Low: ipc_socket: In fbsd send() returns ENOBUFS when dgram queue is full, this should be treated similar to EAGAIN
171High: kqueue: Properly enable kqueue filter in poll loop
172Low: ipcs: Attempt to resend outstanding event notifications during event send
173Merge pull request #75 from davidvossel/ref_count_cleanup
174Low: qbipcs.h: update ipcs connection iterator documentation
175Merge pull request #74 from davidvossel/ref_count_cleanup
176Fix: ipcs: Disconnect shm ipc connection when poll socket returns error on msg receive
177Fix: ipcs: Properly disconnect client connection on POLLNVAL or any other error causing connection removal from mainloop.
178Simplify internal ipcs ref counting, add comments and document api behavior
179Simplifies connection ref counting without changing behavior
180Low remove ref-count error in example ipcserver.
181Merge pull request #73 from davidvossel/ref_count_cleanup
182Merge pull request #72 from davidvossel/master
183Low: tests: Verify reading valid blackbox file works
184Fix: refcount leak
185Fix: ringbuffer: Add file header version field and detect reading corrupted blackbox files using hash value
186Fix: tests: On some platforms -ECONNRESET is returned rather than -ENOTCONN after server failure
187Fix: tests: Make blackbox_segfault.sh not depend on bash
188Hopefully this is the last travis link fix
189Fix travis icon (travis is case sensitive)
190Fix the github links
191Merge pull request #70 from yuusuke/fix_logging
192fix a problem when the character string beyond the number of the maximum characters is passed
193Merge pull request #68 from r1mikey/upstream
194Add a IPC service context pointer and accessors from both the connection and service level.
195Enable distcheck on the travis tests
196Add atomic_int.h to noinst_HEADERS
197Use the new atomic ops in the ringbuffer
198Add internal support for the new __atomic gcc builtins
199Rename the configure macros from atomic to sync
200ringbuffer: use atomic ops on ringbuffer chunk magic
201Remove some test code mistakenly committed to the example program.
202IPC: make each connection ref the owning service
203Indicate when/why qb_rb_force_close() fails to remove share memory files
204Typo fixed in configure
205Fix "make srpm"
206Remove doxygen from travis deps to try and get the job working.
207Fix make distcheck
208Merge pull request #60 from t-matsuo/fix-makefile-of-tests
209add file_change_bytes into check_PROGRAMS and fix a typo
210Deal better with corrupt blackbox files.
211Merge pull request #58 from inouekazu/fix_connection_state_checking
212IPC: fix the connection state checking
213LOG: copy the function/filename for dynamic callsites
214Deal with /dev/shm issue on Travis builders
215Properly discover SO_NOSIGPIPE and MSG_SIGNAL
216IPC: fix call to QB_SUN_LEN
217list: don't splice empty lists onto the head.
218rpl_sem: make destroy more compliant
219test: fix unused-but-set-variable warning
220test: fix missing-format-attribute warning
221RB: make the "sem" abstraction into a notifier
222IPC: clean up the connection state checking
223Use dgram sockets for message oriented communications
224IPC: don't interpret EMSGSIZE and ENOMSG as a disconnect
225POLL: prevent a spin if the fd is not removed from the mainloop
226add TAGS and ~ files to .gitignore
227docs: install qb-blackbox.8 if doxygen is not available.
228IPC: seperate ipc_us.c into 2 files
229IPC: move utility functions to unix.c
230IPC: make sure we return a consistent error when the message is too big.
231
232* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.4-2
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
234
235* Thu Jan 17 2013 Angus Salkeld <asalkeld@redhat.com> - 0.14.4-1
236LOG: prevent the last char of the blackbox message from getting lost.
237Example: make the blackbox example more practical.
238Add the processing which remove notifier at skiplist_destroy function
239Add the processing which remove hash node and notifier at hashtable_destroy function
240Unify to QB_TRUE/QB_FALSE a boolean value
241Document the default prefix in INSTALL
242Unify the list processing with qb_list function
243Add travis link to the readme.
244Fix return code which is an error occurred at pthread function
245TEST: add a progam to compare the speed of vsnprintf and qb_vsnprintf_serialize
246LOG: add a test for a padded hex int.
247Fedora's splint has a strange syntax error, don't fail on it.
248LOG: fix truncation in some messages that get padded.
249Fix the blackbox formatter when specifing the string len/precision
250Fix strlcpy and strlcat functions
251IPC: don't over log on disconnect
252Make sure we don't use the format string whilst it is getting changed.
253ptrie: deref the current node in trie_iter_free()
254LOG: fix the format comparison to avoid generating multiple entries.
255LOG: set the return code when calloc fails
256IPC: call poll if we are mid message and get EAGAIN
257Remove extra ";"
258IPC: set the error more correctly when qb_sys_mmap_file_open() fails.
259Make sure that mmap'ed files smaller than a page size are written to.
260example/test: check for error in qb_ipc_run()
261example: check for error in qb_ipc_run()
262TEST: fix typo s/,/; in check_ipc.c
263
264* Mon Oct 29 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.3-2
265Fix test code highlighted by new check version
266Remove the call to autogen.sh - not needed anymore.
267
268* Mon Oct 29 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.3-1
269IPC: Pass the timeout to poll() if the recv function returns EAGAIN
270LOG: make the format comparison safe and sane
271LOG: don't break on empty callsites, just ignore them
272LOG: use the array callback to register new callsites
273array: add a mechanism to get a callback when a bin is allocated
274Solaris based operating systems don't define MSG_NOSIGNAL and SO_NOSIGPIPE.
275Make sure atomic's are initialized (for non-gcc atomic).
276
277* Wed Sep 12 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.2-2
278Fix a crash in ptrie if you iterate over the map in the deleted notifier.
279
280* Mon Sep 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.2-1
281Get libqb building on cygwin.
282ipc_us: slightly more robust cmsg handling
283ipc_us: on Linux, set SO_PASSCRED on the sending socket too
284ipc_us: clear request unused fields
285TEST: Include writing and reading the blackbox in the log_long_msg test
286LOG: fix qb_vsnprintf_deserialize()
287blackbox: fix 64-bit big-endian issues
288Remove IPC_NEEDS_RESPONSE_ACK and turn off shm ipc on solaris
289Define unix path max for openbsd
290Only turn on ipc_needs_response_ack=yes for solaris
291Some improvements to kqueue usage.
292kqueue: drop log message to trace.
293Fix splint warning
294openbsd requires netinet/in.h before arpa/inet.h
295Avoid strcpy() use strlcpy() instead.
296Fix kqueue complile warnings
297openbsd doesn't have EBADMSG
298openbsd has a different UNIX_PATH_MAX
299LOG: change qb_vsprintf_serialize() into qb_vsnprintf_serialize()
300TEST: increase timeout to 6 secs as the recv timeout is 5 secs
301TEST: get the logic right - grrr.
302Turn off attribute_section on netbsd
303Some missing pshared semaphore checks
304Cleanup the checks for pshared semaphores
305Add a config check for pthread_mutexattr_setpshared
306Remove uses of timersub and use qb_util_stopwatch
307RB: change the #error to ENOTSUP if no usable shared process sem
308LOOP-KQUEUE: fix reference before assignment.
309build: fix libqb.pc creation and make maintainer-clean
310LOG: Make sure the semaphores are initialized.
311build: remove bashism in cc support check
312Catch disconnected sockets on Solaris
313Don't free rb->shared_hdr in qb_rb_create_from_file()
314Check error return of qb_ipcs_uc_recv_and_auth()
315Fix removal of automatically installed doc files when building rpms
316Add the mailing list to the travis email notifications.
317Work around debian not setting the arch path in splint.
318Remove color-tests and parallel-tests automake options.
319Add travis continuous integration config
320LOG: Invoke custom log filter function if tag changes
321tests/rbwriter: don't ignore write failure
322ipcs: avoid use-after-free for size-0 || disconnect-request
323
324* Wed Jul 18 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.1-1
325RB: set the new read pointer after clearing the header (#839605).
326RB: improve the debug print outs
327RB: be more explicit about the word alignment
328RB: cleanup the macros for wrapping the index
329RB: use sem_getvalue as a tie breaker when read_pt == write_pt
330RB: if read or peek don't get the message then re-post to the semaphore
331RB: convert the rb_peek() status into a recv like status.
332RB: use internal reclaim function
333IPC: use calloc instead of malloc to fix valgrind warnings
334Upgrade the doxygen config.
335Fix a valgrind error.
336
337* Sun Jun 24 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.0-1
338LOG: fix threaded logging.
339Add user control of the permissions that are set on the shared mem files
340LOG: Restrict string trucation during serialization to when a precision is specified
341LOG: Gracefully fail when the caller exceeds QB_LOG_MAX_LEN
342LOG: Observe field widths when serializing string arguments
343RB: use the same mechanism in reclaim as read/peek to detect end-of-ring
344Add needs_response_ack option to ./check
345RB: fix wrong sem_flg IPC_NOWAIT option
346TESTS: fix warning about unused functions
347Remove D_FORTIFY_SOURCE from check.
348Open shared mem file in /dev/shm only for linux
349Don't use msg_flags on solaris (recvmsg).
350Turn off attribute_section on solaris
351ipc example: add -e (events) option
352IPC: if the server returns EAGAIN or ETIMEOUT the check the connection
353LOG: make it possible to fsync() on each file log.
354IPC: make sure that the created callback happens before dispatches
355LOG: fix the printing of %p in the blackbox
356IPC: On bsd's use the notifier for responses
357IPC: interpret ECONNRESET and EPIPE as ENOTCONN
358cleanup some warnings
359config: use newer AC_COMPILE_IFELSE()
360blackbox: fix %p formatting
361LOG: put all fields in the blackbox (added priority and tags)
362example: make the priority uint8_t
363Remove strerror out of check_funcs
364RB: fix compiler warning.
365Add replacement function stpcpy
366Add missing AC_TYPE_UINT16_T to configure.ac
367Use AC_FUNC_STRERROR_R and STRERROR_R_CHAR_P
368Add stpcpy strcasecmp to the check_funcs
369Move some conditional defines into code (from the configure script)
370Remove some unused configure checks
371Remove message queues
372Check for union semun properly
373Blackbox: provide more space for log messages when reading from the blackbox.
374Add the blackbox reader manpage to the spec file
375Enable error logging for the blackbox reader
376RB: Read the file size into an initialized variable of the correct size
377Add a tool to dump the blackbox.
378RB: to be safer save the read and write pointers at the top of the blackbox
379avoid unwarranted use of strncpy: use memcpy instead
380blackbox: fix the print_from_file()
381RB: add an option to not use any semaphores
382LOG: tweak the blackbox format string
383LOG: accept NULL strings into the blackbox
384LOG: protect close and reload from calling log
385Add benchmark option (-b) to examples/ipcclient
386TEST: make rbreader/writer more like the other benchmarking apps
387IPC: log the connection description in all logs
388TEST: re-organise the ipc test suites
389IPC: only modify the dispatch if we get EAGAIN
390Correctly display timestamp in blackbox
391
392* Thu May 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.13.0-1
393- Remove unneccessary __attribute__ ((aligned(8))) from internal headers
394- IPC: add a new function to get (and alloc) the extended stats.
395- Revert "Add the event queue length to the connection stats."
396- IPC: cleanup better on a failed client connect.
397- IPC(soc): be more consistent with control struct size
398- IPC: kill a compiler warning
399- IPC(soc): pass in the correct size into munmap()
400- TEST: Use /bin/sh not /bin/bash
401- TEST: check for lost shared mem on bsd too
402- rb: cleanup the semaphores
403- Fix some small issues in ./check
404- Cleanup the .gitignore files
405- configure.ac tweaks
406- Remove HZ and use sysconf instead.
407- SUN_LEN() macro is present if __EXTENSIONS__ is defined on Illumos
408- PF_UNIX is a POSIX standard name
409- Test for log facility names
410- IPC: drop log message to debug.
411- IPC: fix retrying of partial recv's and sends.
412- IPC: initialize enough shared mem for all 3 one way connections.
413- IPC: keep retrying to recv the socket message if partially recv'ed (part 2)
414- IPC: keep retrying to recv the socket message if partially recv'ed
415- IPC: handle the server shutdown better
416- IPC: handle a connection disconnect from the server better
417- IPC: make it possible to send events in the connected callback.
418- Add the event queue length to the connection stats.
419- IPC: add a is_connected client side function.
420- Fix typo in ./check
421- docs: clarify the need to use request/response headers
422- Remove unused local variable
423- IPC: change the socket recv function to read the response header.
424- Add some special commands into the ipc example
425- TEST: improve the tracing in the ipc tests.
426- Make "make (s)rpm" work more reliably
427- TEST: add a test to confirm we get the events we send.
428- TEST: reuse send_and_check for events.
429- IPC: make it possible for a root client to talk to a non-root server.
430- Run ./Lindent in the examples directory
431- Add some debug code to the ipcclient example
432- IPC: make sure ipc (socket) clients can connect to a server running as root.
433- IPC: allow qb to bump the max_message_size
434- IPC: check for a sane minimum max_message_size
435- add rpl_sem.h loop_poll_int.h to noinst_headers
436- Handle errors more consistently
437- call recv_ready on socket types
438- Handle a recv of size 0
439- make bsd shm path better by default.
440- Fix kqueue on freebsd.
441- Get the example socket includes right.
442- Fix kqueue compiling.
443- POLL: seperate out the poll/epoll and add kqueue
444- Test existence of getpeer* functions
445- Add inet header to tcpclient example
446- Don't link with setpshared if unavailable
447- NetBSD doesn't have semun defined
448- Use MADV_NOSYNC only on systems where available
449- Use SCHED_BATCH only on platforms where available
450- Fix a bug introduced by the bsd patch.
451- Cleanup the selection of semaphores to use
452- Fix some leaks in the logging.
453- Try and improve the portability on bsd variants.
454
455* Sun Mar 11 2012  Angus Salkeld <asalkeld@redhat.com> - 0.11.1-1
456- configue libqb to not use epoll as it seems broken (#800865)
457- LOOP: remove some old timerfd code.
458- TEST: add a test to check the order of the jobs
459- LOOP: when new jobs are added they are added to the head instead of the tail.
460- LOG: Now the array is self locking we can make the lookup array dynamic
461- Add locking to the array when growing.
462- IPC: make the _request_q_len_get() function more obvious.
463- IPC: fix multiple receives from qb_ipc_us_recv()
464- IPC: make sure that the wrong union member is not written to.
465- TIMER: check for null timer handle
466
467Wed Mar 7 2012  Angus Salkeld <asalkeld@redhat.com> - 0.11.0-1
468- ARRAY: cleanup the pointer sizeof()
469- LOG: turn off __attribute__(section) for powerpc (not working)
470- TESTS: move the util tests into "slow-tests" (i.e. optional)
471- TEST: make the test_priority the same type as in the callsite
472- LOG: make the log arrays manually grow-able since we need to lock the calls.
473- RB: fix test failure on ppc
474- RB: change the name of the size to word_size to be more clear
475- TEST: add some more signal tests.
476- LOOP: fix deletion of signal handlers when they are pending
477- LOOP: signal handlers were always added as high priority.
478- TEST: deal with mac's limited sed
479- check: add debugging to the configure options and remove unused options
480- TEST: properly clear the filters
481- LOG: expose the mechanism to get a dynamic callsite.
482- Revert part of my COARSE grained timer commit
483- Remove timerfd usage and go back to timelist.
484- UTIL: if possible use COARSE resolution clocks - they are much faster.
485- ARRAY: save memory (in the bins array) and allow holes in the array
486- LOOP: add qb_loop_timer_is_running()
487- LOOP: allow stop() and run() to be called with NULL loop instance.
488- LOOP: fix doxygen parameter comment
489- LOG: add stdout target
490- LOOP: add a function to delete jobs
491- LOG: remove debug printf's
492- LOG: remove an old/incorrect doxygen comment.
493- LOG: add a hostname %H format specifier.
494- LOG: Add qb_log_filter_fn_set()
495
496* Tue Feb 14 2012 Angus Salkeld <asalkeld@redhat.com> - 0.10.1-1
497- Fix "make distcheck" add include path to AM_CPPFLAGS
498- Bump the version to 0.10.1
499- clang: Remove unused code
500- TEST: make the ipc failure test closer to corosync's case.
501- RB: add a debug message if trying to read a message of the wrong size
502- IPC: split up the recv into chuncks of 2 seconds. (#788742)
503- Be more consistent with the internal logs.
504- LOOP: make it possible to pass in NULL as the default loop instance
505- RB: use the proper struct not the typedef in the implementation.
506- RB: Fix potential mem leak
507- Don't mix enums (QB_TRUE/TRUE)
508- use random() not rand()
509- Remove dead code
510- set umask before calling mkstemp()
511- Use safer versions of string functions (strcpy -> strlcpy)
512- Increase the coverity aggressiveness
513- TEST: make the loop ratelimit test more forgiving.
514
515* Tue Feb 07 2012 Angus Salkeld <asalkeld@redhat.com> - 0.10.0-1
516- LOOP: handle errors from the poll function
517- LOOP: make the item type applicable to jobs too.
518- LOOP: fix the todo calculations.
519- TEST: check for a single job causing a cpu spin
520- LOOP: prevent jobs from consuming too much cpu.
521- Get coverity to ignore this warning.
522- Change example code to use fgets instead of gets
523- LOG: pass the result of qb_log_thread_start() back to the user
524- Fix some issues found by clang
525- Add clang-analyzer check
526- Add a split timer to the stopwatch.
527- IPC: merge common code into new function
528- IPC: better handle a disconnect been called from within connection_created()
529- IPC: fix scary typo
530- IPC: fix server error handling
531
532* Mon Feb 06 2012 Angus Salkeld <asalkeld@redhat.com> - 0.9.0-2
533- Fix a spin in the mainloop when a timer or poll gets removed
534  When in the job queue (#787196).
535
536* Fri Jan 27 2012  Angus Salkeld <asalkeld@redhat.com> - 0.9.0-1
537- Rebased to 0.9.0
538
539* Tue Jan 10 2012  Angus Salkeld <asalkeld@redhat.com> - 0.8.1-2
540- fix qb_timespec_add_ms()
541
542* Thu Jan 5 2012  Angus Salkeld <asalkeld@redhat.com> - 0.8.1-1
543- Rebased to 0.8.1 (#771914)
544
545* Wed Nov 17 2011 Angus Salkeld <asalkeld@redhat.com> - 0.7.0-1
546- Rebased to 0.7.0 (#754610)
547
548* Thu Sep 1 2011 Angus Salkeld <asalkeld@redhat.com> - 0.6.0-2
549- LOG: fix the default syslog filter
550
551* Tue Aug 30 2011 Angus Salkeld <asalkeld@redhat.com> - 0.6.0-1
552- Rebased to 0.6.0 which includes (#734457):
553- Add a stop watch
554- LOG: serialize the va_list, don't snprintf
555- LOG: change active list into array access
556- atomic: fix qb_atomic_pointer macros
557- LOG: allow the thread priority to be set.
558- Fix splint warning on ubuntu 11.04
559
560* Mon Jul 18 2011 Angus Salkeld <asalkeld@redhat.com> - 0.5.1-1
561- Rebased to 0.5.1 which includes:
562- LOOP: make the return more consistent in qb_loop_timer_expire_time_get()
563- LOG: add string.h to qblog.h
564- Add a qb_strerror_r wrapper.
565- don't let an invalid time stamp provoke a NULL dereference
566- LOG: move priority check up to prevent unnecessary format.
567- rename README to README.markdown
568
569* Wed Jun 8 2011 Angus Salkeld <asalkeld@redhat.com> - 0.5.0-1
570- Rebased to 0.5.0 which includes:
571- new logging API
572- support for sparc
573- coverity fixes
574
575* Tue Feb 8 2011 Angus Salkeld <asalkeld@redhat.com> - 0.4.1-2
576- SPEC: improve devel files section
577- SPEC: remove global variables
578
579* Mon Jan 31 2011 Angus Salkeld <asalkeld@redhat.com> - 0.4.1-1
580- SPEC: add procps to BuildRequire
581- SPEC: remove automake and autoconf from BuildRequire
582- SPEC: remove call to ./autogen.sh
583- SPEC: update to new upstream version 0.4.1
584- LOOP: check read() return value
585- DOCS: add missing @param on new timeout argument
586- BUILD: only set -g and -O options if explicitly requested.
587- BUILD: Remove unneccessary check for library "dl"
588- BUILD: improve the release build system
589
590* Fri Jan 14 2011 Angus Salkeld <asalkeld@redhat.com> - 0.4.0-2
591- remove "." from Summary
592- Add "check-devel to BuildRequires
593- Add "make check" to check section
594- Changed a buildroot to RPM_BUILD_ROOT
595- Document alphatag, numcomm and dirty variables.
596
597* Sun Jan 09 2011 Angus Salkeld <asalkeld@redhat.com> - 0.4.0-1
598- Initial release
Note: See TracBrowser for help on using the repository browser.