source: projects/specs/trunk/lib/libp/libpwquality/libpwquality-vl.spec @ 12474

Revision 12474, 5.9 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

brotli-1.0.7-5

graphviz-2.44.1-1

llvm-10.0.1-1

libplist-2.2.0-2

libpwquality-1.4.2-2

python-nose-1.3.7-2

Line 
1Summary: A library for password generation and password quality checking
2Name: libpwquality
3Version: 1.4.2
4Release: 2%{?_dist_release}
5Group: system
6Vendor: Project Vine
7Distribution: Vine Linux
8
9# The package is BSD licensed with option to relicense as GPLv2+
10# - this option is redundant as the BSD license allows that anyway.
11License: BSD or GPLv2+
12URL: https://fedorahosted.org/libpwquality/
13Source0: https://github.com/libpwquality/libpwquality/releases/download/libpwquality-%{version}/libpwquality-%{version}.tar.bz2
14
15%global _moduledir /%{_lib}/security
16%global _secconfdir %{_sysconfdir}/security
17
18Requires: cracklib-dicts >= 2.8
19Requires: pam
20BuildRequires: cracklib
21BuildRequires: gettext
22BuildRequires: pam-devel
23BuildRequires: python-rpm-macros
24
25BuildRequires: python-devel
26BuildRequires: python2-rpm-macros
27
28BuildRequires: python3-devel
29BuildRequires: python3-rpm-macros
30
31# we don't want to provide private python extension libs
32%define __provides_exclude_from ^(%{python_sitearch}|%{python3_sitearch})/.*\.so$.
33
34%description
35This is a library for password quality checks and generation
36of random passwords that pass the checks.
37This library uses the cracklib and cracklib dictionaries
38to perform some of the checks.
39
40
41%package devel
42Summary: Files needed for developing PAM-aware applications and modules for PAM
43Group: programming
44Requires: libpwquality = %{version}-%{release}
45Requires: pkgconfig
46
47%description devel
48Files needed for development of applications using the libpwquality
49library.
50See the pwquality.h header file for the API.
51
52
53%package -n python-pwquality
54Summary: Python bindings for the libpwquality library
55Group: programming
56Requires: libpwquality = %{version}-%{release}
57
58%description -n python-pwquality
59This is pwquality Python module that provides Python bindings
60for the libpwquality library. These bindings can be used
61for easy password quality checking and generation of random
62pronounceable passwords from Python applications.
63
64
65%package -n python3-pwquality
66Summary: Python bindings for the libpwquality library
67Group: programming
68Requires: libpwquality = %{version}-%{release}
69
70%description -n python3-pwquality
71This is pwquality Python module that provides Python bindings
72for the libpwquality library. These bindings can be used
73for easy password quality checking and generation of random
74pronounceable passwords from Python applications.
75
76
77%prep
78%setup -q
79rm -rf %{py3dir}
80cp -a . %{py3dir}
81
82
83%build
84%configure \
85        --with-securedir=%{_moduledir} \
86        --with-pythonsitedir=%{python2_sitearch} \
87        --with-python-binary=%{__python2} \
88        --disable-static
89
90make %{?_smp_mflags}
91
92pushd %{py3dir}
93%configure \
94        --with-securedir=%{_moduledir} \
95        --with-pythonsitedir=%{python3_sitearch} \
96        --with-python-binary=%{__python3} \
97        --disable-static
98
99make %{?_smp_mflags}
100popd
101
102
103%install
104make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
105
106pushd %{py3dir}
107make -C python install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
108popd
109
110pushd $RPM_BUILD_ROOT%{_libdir}
111mv libpwquality.so.* $RPM_BUILD_ROOT/%{_lib}/
112ln -sf ../../%{_lib}/libpwquality.so.*.* libpwquality.so
113popd
114rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
115rm -f $RPM_BUILD_ROOT%{_moduledir}/*.la
116
117mkdir $RPM_BUILD_ROOT%{_secconfdir}/pwquality.conf.d
118
119%find_lang libpwquality
120
121
122%check
123# Nothing yet
124
125
126%post -p /sbin/ldconfig
127%postun -p /sbin/ldconfig
128
129
130%files -f libpwquality.lang
131%defattr(-,root,root,-)
132%{!?_licensedir:%global license %%doc}
133%license COPYING
134%doc README NEWS AUTHORS
135%{_bindir}/pwmake
136%{_bindir}/pwscore
137%{_moduledir}/pam_pwquality.so
138/%{_lib}/libpwquality.so.*
139%config(noreplace) %{_secconfdir}/pwquality.conf
140%{_mandir}/man1/*
141%{_mandir}/man5/*
142%{_mandir}/man8/*
143
144%files devel
145%defattr(-,root,root,-)
146%{_includedir}/pwquality.h
147%{_libdir}/libpwquality.so
148%{_libdir}/pkgconfig/*.pc
149%{_mandir}/man3/*
150
151%files -n python-pwquality
152%defattr(-,root,root,-)
153%{python2_sitearch}/pwquality.so
154%{python2_sitearch}/*.egg-info
155
156%files -n python3-pwquality
157%defattr(-,root,root,-)
158%{python3_sitearch}/*.so
159%{python3_sitearch}/*.egg-info
160
161
162%changelog
163* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-2
164- rebuilt with python-3.8.
165
166* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-1
167- new upstream release.
168- dropped Patch1: fixed in upstream.
169
170* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.0-1
171- new upstream release.
172- added python3 support.
173
174* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
175- new upstream release
176
177* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
178- new upstream release
179
180* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-2
181- rebuild with VineSeed environment
182
183* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
184- new upstream release
185
186* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
187- initial build for Vine Linux
188
189
190* Thu Aug 16 2012 Tomas Mraz <tmraz@redhat.com> 1.2.0-1
191- add maxsequence check for too long monotonic character sequence.
192- clarified alternative licensing to GPLv2+.
193- add local_users_only option to skip the pwquality checks for
194  non-locals. (thanks to Stef Walter)
195
196* Wed Jun 13 2012 Tomas Mraz <tmraz@redhat.com> 1.1.1-1
197- use rpm built-in filtering of provides (rhbz#830153)
198- remove strain debug fprintf() (rhbz#831567)
199
200* Thu May 24 2012 Tomas Mraz <tmraz@redhat.com> 1.1.0-1
201- fix leak when throwing PWQError exception
202- added pkgconfig file
203- call the simplicity checks before the cracklib check
204- add enforce_for_root option to the PAM module
205- updated translations from Transifex
206
207* Thu Dec  8 2011 Tomas Mraz <tmraz@redhat.com> 1.0.0-1
208- added a few additional password quality checks
209- bugfix in configuration file parsing
210
211* Fri Nov 11 2011 Tomas Mraz <tmraz@redhat.com> 0.9.9-1
212- added python bindings and documentation
213
214* Mon Oct 10 2011 Tomas Mraz <tmraz@redhat.com> 0.9-2
215- fixes for problems found in review (missing BR on pam-devel,
216  License field, Source URL, Require pam, other cleanups)
217
218* Mon Oct  3 2011 Tomas Mraz <tmraz@redhat.com> 0.9-1
219- first spec file for libpwquality
Note: See TracBrowser for help on using the repository browser.