source: projects/specs/trunk/lib/libp/libpsl/libpsl-vl.spec @ 12402

Revision 12402, 9.8 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

amtk-5.0.2-3

libpsl-0.21.0-5

publicsuffix-list-20200509-1

Line 
1Name:           libpsl
2Version:        0.21.0
3Release:        5%{?_dist_release}
4Summary:        C library for the Publix Suffix List
5Vendor:         Project Vine
6Distribution:   Vine Linux
7
8License:        MIT
9URL:            https://rockdaboot.github.io/libpsl
10Source0:        https://github.com/rockdaboot/libpsl/releases/download/libpsl-%{version}/libpsl-%{version}.tar.gz
11# fix unnecessary build failure due to missing tree_index.sgml in gtk-doc output
12Patch1:         0001-libpsl-0.21.0-gtk-doc.patch
13
14BuildRequires:  gcc
15BuildRequires:  gettext-devel
16BuildRequires:  glib2-devel
17BuildRequires:  gtk-doc
18BuildRequires:  libicu-devel
19BuildRequires:  libidn2-devel
20BuildRequires:  libunistring-devel
21BuildRequires:  libxslt
22BuildRequires:  publicsuffix-list
23BuildRequires:  python3-devel
24BuildRequires:  python3-rpm-macros
25Requires:       publicsuffix-list-dafsa
26
27%description
28libpsl is a C library to handle the Public Suffix List. A "public suffix" is a
29domain name under which Internet users can directly register own names.
30
31Browsers and other web clients can use it to
32
33- Avoid privacy-leaking "supercookies";
34- Avoid privacy-leaking "super domain" certificates;
35- Domain highlighting parts of the domain in a user interface;
36- Sorting domain lists by site;
37
38Libpsl...
39
40- has built-in PSL data for fast access;
41- allows to load PSL data from files;
42- checks if a given domain is a "public suffix";
43- provides immediate cookie domain verification;
44- finds the longest public part of a given domain;
45- finds the shortest private part of a given domain;
46- works with international domains (UTF-8 and IDNA2008 Punycode);
47- is thread-safe;
48- handles IDNA2008 UTS#46;
49
50%package        devel
51Summary:        Development files for %{name}
52Requires:       %{name}%{?_isa} = %{version}-%{release}
53Requires:       publicsuffix-list
54
55%description    devel
56This package contains libraries and header files for
57developing applications that use %{name}.
58
59%package -n     psl
60Summary:        Commandline utility to explore the Public Suffix List
61
62%description -n psl
63This package contains a commandline utility to explore the Public Suffix List,
64for example it checks if domains are public suffixes, checks if cookie-domain
65is acceptable for domains and so on.
66
67%package -n     psl-make-dafsa
68Summary:        Compiles the Public Suffix List into DAFSA form
69
70%description -n psl-make-dafsa
71This script produces C/C++ code or an architecture-independent binary object
72which represents a Deterministic Acyclic Finite State Automaton (DAFSA)
73from a plain text Public Suffix List.
74
75
76%prep
77%autosetup -p1
78rm -frv list
79ln -sv %{_datadir}/publicsuffix list
80sed -i -e "1s|#!.*|#!%{__python3}|" src/psl-make-dafsa
81
82
83%build
84# Tarballs from github have 2 versions, one is raw files from repo, and
85# the other one from CDN contains pre-generated autotools files.
86# But makefile hack is not upstreamed yet so we continue reconfiguring these.
87# [ -f configure ] || autoreconf -fiv
88# autoreconf -fiv
89
90# libicu does allow support for a newer IDN specification (IDN 2008) than
91# libidn 1.x (IDN 2003). However, libpsl mostly relies on an internally
92# compiled list, which is generated at buildtime and the testsuite thereof
93# requires either libidn or libicu only at buildtime; the runtime
94# requirement is only for loading external lists, which IIUC neither curl
95# nor wget support. libidn2 supports IDN 2008 as well, and is *much* smaller
96# than libicu.
97#
98# curl (as of 7.51.0-1.fc25) and wget (as of 1.19-1.fc26) now depend on libidn2.
99# Therefore, we use libidn2 at runtime to help minimize core dependencies.
100%configure --disable-silent-rules \
101           --disable-static       \
102           --enable-man           \
103           --enable-gtk-doc       \
104           --enable-builtin=libicu \
105           --enable-runtime=libidn2 \
106           --with-psl-distfile=%{_datadir}/publicsuffix/public_suffix_list.dafsa  \
107           --with-psl-file=%{_datadir}/publicsuffix/effective_tld_names.dat       \
108           --with-psl-testfile=%{_datadir}/publicsuffix/test_psl.txt
109
110# avoid using rpath
111sed -i libtool \
112    -e 's|^\(runpath_var=\).*$|\1|' \
113    -e 's|^\(hardcode_libdir_flag_spec=\).*$|\1|'
114
115%make_build
116
117
118%install
119%make_install
120
121# the script is noinst but the manpage is installed
122install -m0755 src/psl-make-dafsa %{buildroot}%{_bindir}/
123
124find %{buildroot} -name '*.la' -delete -print
125
126
127%check
128export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
129make check || cat tests/test-suite.log
130
131
132%post -p /sbin/ldconfig
133
134%postun -p /sbin/ldconfig
135
136
137%files
138%license COPYING
139%{_libdir}/libpsl.so.5
140%{_libdir}/libpsl.so.5.*
141
142%files devel
143%doc AUTHORS NEWS
144%{_datadir}/gtk-doc/html/libpsl/
145%{_includedir}/libpsl.h
146%{_libdir}/libpsl.so
147%{_libdir}/pkgconfig/libpsl.pc
148%{_mandir}/man3/libpsl.3*
149
150%files -n psl
151%doc AUTHORS NEWS
152%license COPYING
153%{_bindir}/psl
154%{_mandir}/man1/psl.1*
155
156%files -n psl-make-dafsa
157%license COPYING
158%{_bindir}/psl-make-dafsa
159%{_mandir}/man1/psl-make-dafsa.1*
160
161%changelog
162* Sat May 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.21.0-5
163- initial build for Vine Linux.
164
165* Thu Jan 30 2020 Kamil Dudka <kdudka@redhat.com> - 0.21.0-4
166- fix unnecessary build failure due to missing tree_index.sgml in gtk-doc output
167
168* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-3
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
170
171* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
173
174* Wed Apr 17 2019 Kamil Dudka <kdudka@redhat.com> - 0.21.0-1
175- update to 0.21.0 (#1700444)
176
177* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.20.2-6
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
179
180* Fri Jul 27 2018 Kamil Dudka <kdudka@redhat.com> - 0.20.2-5
181- avoid using rpath in the psl executable (#1533448)
182
183* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.20.2-4
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
185
186* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.20.2-3
187- Rebuilt for Python 3.7
188
189* Tue May 22 2018 Yaakov Selkowitz <yselkowi@redhat.com> - 0.20.2-2
190- Rebuilt for publicsuffix-list 20180514
191
192* Tue May 01 2018 Yaakov Selkowitz <yselkowi@redhat.com> - 0.20.2-1
193- Update to 0.20.2 (#1572887)
194
195* Wed Feb 28 2018 Yaakov Selkowitz <yselkowi@redhat.com> - 0.20.1-1
196- Update to 0.20.1 (#1548604)
197
198* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.19.1-3
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
200
201* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.19.1-2
202- Switch to %%ldconfig_scriptlets
203
204* Tue Nov 14 2017 Yaakov Selkowitz <yselkowi@redhat.com> - 0.19.1-1
205- new version (#1511463)
206
207* Fri Aug 11 2017 Yaakov Selkowitz <yselkowi@redhat.com> - 0.18.0-1
208- new version (#1473465)
209
210* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-4
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
212
213* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-3
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
215
216* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-2
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
218
219* Tue Jan 17 2017 Yaakov Selkowitz <yselkowi@redhat.com> - 0.17.0-1
220- new version (#1413791)
221
222* Thu Jan  5 2017 Yaakov Selkowitz <yselkowi@redhat.com> - 0.16.1-1
223- new version (#1403620)
224
225* Tue Nov 15 2016 Yaakov Selkowitz <yselkowi@redhat.com> - 0.15.0-1
226- new version (#1394761)
227
228* Fri Nov 04 2016 Yaakov Selkowitz <yselkowi@redhat.com> - 0.14.0-2
229- Switch to libidn2 at runtime
230- Rebuilt with publicsuffix-list-20161028
231
232* Mon Aug 15 2016 Yaakov Selkowitz <yselkowi@redhat.com> - 0.14.0-1
233- new version (#1361781)
234
235* Thu Mar 31 2016 Yaakov Selkowitz <yselkowi@redhat.com> - 0.13.0-1
236- new version (#1313825)
237- Use libidn at runtime, libicu only at buildtime (#1305701)
238
239* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-2
240- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
241
242* Fri Jan 22 2016 Christopher Meng <rpm@cicku.me> - 0.12.0-1
243- Update to 0.12.0
244
245* Wed Oct 28 2015 David Tardon <dtardon@redhat.com> - 0.7.0-7
246- rebuild for ICU 56.1
247
248* Tue Aug 04 2015 Christopher Meng <rpm@cicku.me> - 0.7.0-6
249- Rebuild for publicsuffix-list-20150731
250
251* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-5
252- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
253
254* Sat Feb 28 2015 Christopher Meng <rpm@cicku.me> - 0.7.0-4
255- Rebuild for publicsuffix-list-20150226
256
257* Fri Feb 20 2015 Christopher Meng <rpm@cicku.me> - 0.7.0-3
258- Rebuild for publicsuffix-list-20150217
259
260* Sun Feb 15 2015 Christopher Meng <rpm@cicku.me> - 0.7.0-2
261- Correct the dependency
262
263* Mon Feb 02 2015 Christopher Meng <rpm@cicku.me> - 0.7.0-1
264- Update to 0.7.0
265
266* Mon Jan 26 2015 David Tardon <dtardon@redhat.com> - 0.6.2-2
267- rebuild for ICU 54.1
268
269* Thu Nov 20 2014 Christopher Meng <rpm@cicku.me> - 0.6.2-1
270- Update to 0.6.2
271
272* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 0.5.1-3
273- rebuild for ICU 53.1
274
275* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
276- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
277
278* Mon Aug 04 2014 Christopher Meng <rpm@cicku.me> - 0.5.1-1
279- Update to 0.5.1
280- Drop patch merged upstream
281
282* Sat Aug 02 2014 Christopher Meng <rpm@cicku.me> - 0.5.0-3
283- Add a patch from Jakub Čajka to complete the tests on non-x86 arch.
284
285* Thu Jul 24 2014 Christopher Meng <rpm@cicku.me> - 0.5.0-2
286- Drop useless test data
287- Add missing gettext-devel
288- psl is now separately packaged recommended by the upstream
289
290* Fri Jul 04 2014 Christopher Meng <rpm@cicku.me> - 0.5.0-1
291- Update to 0.5.0
292
293* Tue Jul 01 2014 Christopher Meng <rpm@cicku.me> - 0.4.0-1
294- Update to 0.4.0
295
296* Tue Apr 08 2014 Christopher Meng <rpm@cicku.me> - 0.2-1
297- Initial Package.
Note: See TracBrowser for help on using the repository browser.