source: projects/specs/trunk/lib/libp/libproxy/libproxy-vl.spec @ 5701

Revision 5701, 7.9 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:        A library handling all the details of proxy configuration
4Name:           libproxy
5Version:        0.4.7
6Release:        2%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://code.google.com/p/libproxy/
11Source0:        http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
12Patch0:         libproxy-0.4.7-cmake-modules.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15BuildRequires:  python-devel
16#Virtual Provides - We need either mozjs or WebKit
17Requires: %{name}-pac >= %{version}
18#
19Requires: libproxy-python = %{version}-%{release}
20Requires: libproxy-bin = %{version}-%{release}
21
22BuildRequires:  cmake
23# gnome
24BuildRequires:  GConf2-devel
25# mozjs
26BuildRequires:  js-devel
27# NetworkManager
28BuildRequires:  NetworkManager-devel
29BuildRequires:  dbus-devel
30# webkit (gtk)
31BuildRequires:  WebKit3-gtk-devel
32# kde
33BuildRequires:  kdelibs-devel
34BuildRequires:  libXmu-devel
35BuildRequires:  libX11-devel
36
37
38Provides: %{name}-webkit = %{version}-%{release}
39Obsoletes: %{name}-webkit < %{version}-%{release}
40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45libproxy offers the following features:
46
47    * extremely small core footprint (< 35K)
48    * no external dependencies within libproxy core
49      (libproxy plugins may have dependencies)
50    * only 3 functions in the stable external API
51    * dynamic adjustment to changing network topology
52    * a standard way of dealing with proxy settings across all scenarios
53    * a sublime sense of joy and accomplishment
54
55Non-default rpmbuild options:
56--with webkit:           Enable WebKit-gtk support
57
58
59%package        bin
60Summary:        Binary to test %{name}
61Group:          Applications/System
62Requires:       %{name} = %{version}-%{release}
63
64%description    bin
65The %{name}-bin package contains the proxy binary for %{name}
66
67%package        python
68Summary:        Binding for %{name} and python
69Group:          System Environment/Libraries
70Requires:       %{name} = %{version}-%{release}
71
72%description    python
73The %{name}-python package contains the python binding for %{name}
74
75%package        gnome
76Summary:        Plugin for %{name} and gnome
77Group:          System Environment/Libraries
78Requires:       %{name} = %{version}-%{release}
79
80%description    gnome
81The %{name}-gnome package contains the %{name} plugin for gnome.
82
83%package        kde
84Summary:        Plugin for %{name} and kde
85Group:          System Environment/Libraries
86Requires:       %{name} = %{version}-%{release}
87
88%description    kde
89The %{name}-kde package contains the %{name} plugin for kde.
90
91%package        mozjs
92Summary:        Plugin for %{name} and mozjs
93Group:          System Environment/Libraries
94Requires:       %{name} = %{version}
95#Tweak this according to the current gecko-libs version
96Requires:       js
97Provides:       %{name}-pac = %{version}-%{release}
98
99%description    mozjs
100The %{name}-mozjs package contains the %{name} plugin for mozjs.
101
102%package        webkitgtk3
103Summary:        Plugin for %{name} and webkitgtk3
104Group:          System Environment/Libraries
105Requires:       %{name} = %{version}
106Provides:       %{name}-pac = %{version}-%{release}
107
108%description    webkitgtk3
109The %{name}-webkitgtk3 package contains the %{name} plugin for
110webkitgtk3.
111
112%package        devel
113Summary:        Development files for %{name}
114Group:          Development/Libraries
115Requires:       %{name} = %{version}-%{release}
116Requires:       pkgconfig
117
118%description    devel
119The %{name}-devel package contains libraries and header files for
120developing applications that use %{name}.
121
122
123%prep
124%setup -q
125%patch0 -p1 -b .old_cmake
126
127
128%build
129%cmake \
130        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
131        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
132        -DWITH_PERL=OFF \
133        -DWITH_WEBKIT3=ON \
134   .
135make VERBOSE=1 %{?_smp_mflags}
136
137
138%install
139rm -rf $RPM_BUILD_ROOT
140make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
141find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
142
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147
148%post -p /sbin/ldconfig
149
150%postun -p /sbin/ldconfig
151
152
153%files
154%defattr(-,root,root,-)
155%doc AUTHORS COPYING README
156%{_libdir}/*.so.*
157%dir %{_libdir}/%{name}
158%dir %{_libdir}/%{name}/%{version}
159%dir %{_libdir}/%{name}/%{version}/modules
160%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
161
162%files bin
163%defattr(-,root,root,-)
164%{_bindir}/proxy
165
166%files python
167%defattr(-,root,root,-)
168%{python_sitelib}/libproxy.py
169
170%files gnome
171%defattr(-,root,root,-)
172%{_libdir}/%{name}/%{version}/modules/config_gnome3.so
173%{_libexecdir}/pxgsettings
174
175%files kde
176%defattr(-,root,root,-)
177%{_libdir}/%{name}/%{version}/modules/config_kde4.so
178
179%files mozjs
180%defattr(-,root,root,-)
181%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
182
183%files webkitgtk3
184%defattr(-,root,root,-)
185%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
186
187%files devel
188%defattr(-,root,root,-)
189%{_includedir}/proxy.h
190%{_libdir}/*.so
191%{_libdir}/pkgconfig/libproxy-1.0.pc
192%{_datadir}/cmake/Modules/Findlibproxy.cmake
193
194
195%changelog
196* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
197- rebuild with python-2.7.2
198
199* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
200- new upstream release
201- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
202- change BuildRequires: js-devel instead of gecko-devel
203- replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
204- detele -webkit sub package
205- create -webkitgtk3 sub package
206
207* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
208- new upstream release
209- drop Patch0
210- add BuildRequires: cmake, kdelibs-devel
211- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
212
213* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
214- rebuild with rpm-4.8.1 for pkg-config file
215
216* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
217- rebuild with python-2.6
218
219* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
220- rebuild with gecko-1.9.1
221
222* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
223- rebuild with WebKit-gtk-1.0.0-8.svn41944
224
225* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
226- initial build for Vine Linux
227
228* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
229- Rebuild for webkit
230- Raise requirement for xulrunner to 1.9.1
231
232* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
234
235* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
236- Merge NetworkManager module into the main libproxy package
237- Main Requires the -python and -bin subpackage
238 (splitted for multilibs compliance).
239
240* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
241- Disable Gnome/KDE default support via builtin modules.
242 (it needs to be integrated via Gconf2/neon instead).
243
244* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
245- Disable Obsoletes.
246- Requires ev instead of evr for optionnals sub-packages.
247
248* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
249- Use conditionals build.
250
251* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
252- Remove plugin- in the name of the packages
253
254* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
255- Move proxy.h to libproxy/proxy.h
256  This will prevent it to be included in the default include path
257- Split main to libs and util and use libproxy to install all
258
259* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
260- Rename binding-python to python
261- Add Requires: gecko-libs >= %%{gecko_version}
262- Fix some descriptions
263- Add plugin-webkit package
264 
265* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
266- Convert to Fedora spec
267
268* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
269- Updated to version 0.2.3
270* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
271- Extended spec file to build all available plugins
272* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
273- Initial spec file for Version 0.2.2
274
Note: See TracBrowser for help on using the repository browser.