source: projects/specs/trunk/lib/libp/libproxy/libproxy-vl.spec @ 521

Revision 521, 7.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%define gecko_version 1.9.1
4
5Summary:        A library handling all the details of proxy configuration
6Name:           libproxy
7Version:        0.2.3
8Release:        4%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://code.google.com/p/libproxy/
13Source0:        http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
14Patch0:         libproxy-0.2.3-dbus.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  python-devel
18#Virtual Provides - We need either mozjs or WebKit
19Requires: %{name}-pac >= %{version}
20#
21Requires: libproxy-python = %{version}-%{release}
22Requires: libproxy-bin = %{version}-%{release}
23
24# gnome
25BuildRequires:  GConf2-devel
26# mozjs
27BuildRequires:  gecko-devel >= %{gecko_version}
28# NetworkManager
29BuildRequires:  NetworkManager-devel
30BuildRequires:  dbus-devel
31# webkit (gtk)
32BuildRequires:  WebKit-gtk-devel
33# kde
34BuildRequires:  libXmu-devel
35BuildRequires:  libX11-devel
36
37
38%description
39libproxy offers the following features:
40
41    * extremely small core footprint (< 35K)
42    * no external dependencies within libproxy core
43      (libproxy plugins may have dependencies)
44    * only 3 functions in the stable external API
45    * dynamic adjustment to changing network topology
46    * a standard way of dealing with proxy settings across all scenarios
47    * a sublime sense of joy and accomplishment
48
49Non-default rpmbuild options:
50--with webkit:           Enable WebKit-gtk support
51
52
53%package        bin
54Summary:        Binary to test %{name}
55Group:          Applications/System
56Requires:       %{name} = %{version}-%{release}
57
58%description    bin
59The %{name}-bin package contains the proxy binary for %{name}
60
61%package        python
62Summary:        Binding for %{name} and python
63Group:          System Environment/Libraries
64Requires:       %{name} = %{version}-%{release}
65
66%description    python
67The %{name}-python package contains the python binding for %{name}
68
69%package        gnome
70Summary:        Plugin for %{name} and gnome
71Group:          System Environment/Libraries
72Requires:       %{name} = %{version}-%{release}
73
74%description    gnome
75The %{name}-gnome package contains the %{name} plugin for gnome.
76
77%package        kde
78Summary:        Plugin for %{name} and kde
79Group:          System Environment/Libraries
80Requires:       %{name} = %{version}-%{release}
81
82%description    kde
83The %{name}-kde package contains the %{name} plugin for kde.
84
85%package        mozjs
86Summary:        Plugin for %{name} and mozjs
87Group:          System Environment/Libraries
88Requires:       %{name} = %{version}
89#Tweak this according to the current gecko-libs version
90Requires:       gecko-libs >= %{gecko_version}
91Provides:       %{name}-pac = %{version}-%{release}
92
93%description    mozjs
94The %{name}-mozjs package contains the %{name} plugin for mozjs.
95
96%package        webkit
97Summary:        Plugin for %{name} and webkit
98Group:          System Environment/Libraries
99Requires:       %{name} = %{version}
100Provides:       %{name}-pac = %{version}-%{release}
101
102%description    webkit
103The %{name}-webkit package contains the %{name} plugin for
104webkit.
105
106%package        devel
107Summary:        Development files for %{name}
108Group:          Development/Libraries
109Requires:       %{name} = %{version}-%{release}
110Requires:       pkgconfig
111
112%description    devel
113The %{name}-devel package contains libraries and header files for
114developing applications that use %{name}.
115
116
117%prep
118%setup -q
119%patch0 -p1 -b .dbus
120touch -r configure.dbus configure
121touch -r configure.ac.dbus configure.ac
122
123
124%build
125%configure --includedir=%{_includedir}/libproxy --disable-static --with-python
126make %{?_smp_mflags}
127
128
129%install
130rm -rf $RPM_BUILD_ROOT
131make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
132find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
133
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138
139%post -p /sbin/ldconfig
140
141%postun -p /sbin/ldconfig
142
143
144%files
145%defattr(-,root,root,-)
146%doc AUTHORS COPYING README
147%{_libdir}/*.so.*
148%dir %{_libdir}/%{name}
149%dir %{_libdir}/%{name}/%{version}
150%dir %{_libdir}/%{name}/%{version}/plugins
151%{_libdir}/%{name}/%{version}/plugins/envvar.so
152%{_libdir}/%{name}/%{version}/plugins/file.so
153%{_libdir}/%{name}/%{version}/plugins/networkmanager.so
154
155%files bin
156%defattr(-,root,root,-)
157%{_bindir}/proxy
158
159%files python
160%defattr(-,root,root,-)
161%{python_sitelib}/*
162
163%files gnome
164%defattr(-,root,root,-)
165%{_libdir}/%{name}/%{version}/plugins/gnome.so
166
167%files kde
168%defattr(-,root,root,-)
169%{_libdir}/%{name}/%{version}/plugins/kde.so
170
171%files mozjs
172%defattr(-,root,root,-)
173%{_libdir}/%{name}/%{version}/plugins/mozjs.so
174
175%files webkit
176%defattr(-,root,root,-)
177%{_libdir}/%{name}/%{version}/plugins/webkit.so
178
179%files devel
180%defattr(-,root,root,-)
181%{_includedir}/libproxy/
182%{_libdir}/*.so
183%{_libdir}/pkgconfig/libproxy-1.0.pc
184
185
186%changelog
187* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
188- rebuild with python-2.6
189
190* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
191- rebuild with gecko-1.9.1
192
193* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
194- rebuild with WebKit-gtk-1.0.0-8.svn41944
195
196* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
197- initial build for Vine Linux
198
199* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
200- Rebuild for webkit
201- Raise requirement for xulrunner to 1.9.1
202
203* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
204- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
205
206* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
207- Merge NetworkManager module into the main libproxy package
208- Main Requires the -python and -bin subpackage
209 (splitted for multilibs compliance).
210
211* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
212- Disable Gnome/KDE default support via builtin modules.
213 (it needs to be integrated via Gconf2/neon instead).
214
215* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
216- Disable Obsoletes.
217- Requires ev instead of evr for optionnals sub-packages.
218
219* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
220- Use conditionals build.
221
222* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
223- Remove plugin- in the name of the packages
224
225* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
226- Move proxy.h to libproxy/proxy.h
227  This will prevent it to be included in the default include path
228- Split main to libs and util and use libproxy to install all
229
230* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
231- Rename binding-python to python
232- Add Requires: gecko-libs >= %%{gecko_version}
233- Fix some descriptions
234- Add plugin-webkit package
235 
236* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
237- Convert to Fedora spec
238
239* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
240- Updated to version 0.2.3
241* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
242- Extended spec file to build all available plugins
243* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
244- Initial spec file for Version 0.2.2
245
Note: See TracBrowser for help on using the repository browser.