source: projects/specs/trunk/lib/libp/libproxy/libproxy-vl.spec @ 12372

Revision 12372, 9.1 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

acpica-tools-20190509-1

ethtool-5.4-1

flac-1.3.3-1

iproute-5.6.0-1

libcap-ng-0.7.10-1

libestr-0.1.11-2

libfastjson-0.99.8-4

libproxy-0.4.15-2

libpwquality-1.4.2-1

libunistring-0.9.10-2

mdadm-4.1-1

python-six-1.14.0-1

rsyslog-8.2002.0-1

speexdsp-1.2-0.16.rc3

Line 
1%bcond_with mozjs
2
3%define _unpackaged_files_terminate_build 1
4
5Summary:        A library handling all the details of proxy configuration
6Name:           libproxy
7Version:        0.4.15
8Release:        2%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://libproxy.github.io/libproxy
13Source0:        https://github.com/libproxy/libproxy/releases/download/%{version}/libproxy-%{version}.tar.xz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15
16BuildRequires:  python-devel
17BuildRequires:  python3-devel
18#Virtual Provides - We need either mozjs or WebKit
19%if %{with mozjs}
20Requires: %{name}-pac >= %{version}
21%endif
22#
23Requires: libproxy-python = %{version}-%{release}
24Requires: libproxy-bin = %{version}-%{release}
25
26Obsoletes: %{name}-mozjs < 1.4.15
27Obsoletes: %{name}-webkitgtk3 < 1.4.15
28
29BuildRequires:  cmake
30# gnome
31BuildRequires:  GConf2-devel
32%if %{with mozjs}
33# mozjs
34BuildRequires:  mozjs >= 38
35%endif
36# NetworkManager
37BuildRequires:  NetworkManager-libnm-devel
38BuildRequires:  dbus-devel
39BuildRequires:  glib2
40# webkit (gtk)
41BuildRequires:  webkitgtk4-devel
42# kde
43BuildRequires:  libXmu-devel
44BuildRequires:  libX11-devel
45
46BuildRequires:  python-rpm-macros
47BuildRequires:  python3-rpm-macros
48
49Provides: %{name}-webkit = %{version}-%{release}
50Obsoletes: %{name}-webkit < %{version}-%{release}
51
52Vendor: Project Vine
53Distribution: Vine Linux
54
55%description
56libproxy offers the following features:
57
58    * extremely small core footprint (< 35K)
59    * no external dependencies within libproxy core
60      (libproxy plugins may have dependencies)
61    * only 3 functions in the stable external API
62    * dynamic adjustment to changing network topology
63    * a standard way of dealing with proxy settings across all scenarios
64    * a sublime sense of joy and accomplishment
65
66Non-default rpmbuild options:
67--with webkit:           Enable WebKit-gtk support
68
69
70%package        bin
71Summary:        Binary to test %{name}
72Group:          Applications/System
73Requires:       %{name} = %{version}-%{release}
74
75%description    bin
76The %{name}-bin package contains the proxy binary for %{name}
77
78%package        python
79Summary:        Binding for %{name} and python
80Group:          System Environment/Libraries
81Requires:       %{name} = %{version}-%{release}
82
83%description    python
84The %{name}-python package contains the python binding for %{name}
85
86%package        python3
87Summary:        Binding for %{name} and python
88Group:          System Environment/Libraries
89Requires:       %{name} = %{version}-%{release}
90
91%description    python3
92The %{name}-python package contains the python binding for %{name}
93
94%package        gnome
95Summary:        Plugin for %{name} and gnome
96Group:          System Environment/Libraries
97Requires:       %{name} = %{version}-%{release}
98
99%description    gnome
100The %{name}-gnome package contains the %{name} plugin for gnome.
101
102%package        kde
103Summary:        Plugin for %{name} and kde
104Group:          System Environment/Libraries
105Requires:       %{name} = %{version}-%{release}
106
107%description    kde
108The %{name}-kde package contains the %{name} plugin for kde.
109
110%if %{with mozjs}
111%package        mozjs
112Summary:        Plugin for %{name} and mozjs
113Group:          System Environment/Libraries
114Requires:       %{name} = %{version}
115#Tweak this according to the current gecko-libs version
116Requires:       js
117Provides:       %{name}-pac = %{version}-%{release}
118
119%description    mozjs
120The %{name}-mozjs package contains the %{name} plugin for mozjs.
121
122%package        webkitgtk4
123Summary:        Plugin for %{name} and webkitgtk4
124Group:          System Environment/Libraries
125Requires:       %{name} = %{version}
126Provides:       %{name}-pac = %{version}-%{release}
127
128%description    webkitgtk4
129The %{name}-webkitgtk3 package contains the %{name} plugin for
130webkitgtk3.
131
132%endif
133
134%package        devel
135Summary:        Development files for %{name}
136Group:          Development/Libraries
137Requires:       %{name} = %{version}-%{release}
138Requires:       pkgconfig
139
140%description    devel
141The %{name}-devel package contains libraries and header files for
142developing applications that use %{name}.
143
144
145%prep
146%setup -q
147#sed -i "s|mozjs185>=1.8.5|mozjs185|" libproxy/cmake/modules/pacrunner_mozjs.cmk
148
149%build
150%cmake \
151        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
152        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
153        -DWITH_PERL=OFF \
154        -DWITH_WEBKIT3=ON \
155        -DWITH_KDE=ON \
156   .
157make VERBOSE=1 %{?_smp_mflags}
158
159
160%install
161rm -rf $RPM_BUILD_ROOT
162make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
163find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
164
165
166%clean
167rm -rf $RPM_BUILD_ROOT
168
169
170%post -p /sbin/ldconfig
171
172%postun -p /sbin/ldconfig
173
174
175%files
176%defattr(-,root,root,-)
177%license COPYING
178%doc AUTHORS README
179%{_libdir}/*.so.*
180%dir %{_libdir}/%{name}
181%dir %{_libdir}/%{name}/%{version}
182%dir %{_libdir}/%{name}/%{version}/modules
183%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
184
185%files bin
186%defattr(-,root,root,-)
187%{_bindir}/proxy
188
189%files python
190%defattr(-,root,root,-)
191%{python_sitelib}/libproxy.py
192
193%files python3
194%defattr(-,root,root,-)
195%{python3_sitelib}/libproxy.py
196
197%files gnome
198%defattr(-,root,root,-)
199%{_libdir}/%{name}/%{version}/modules/config_gnome3.so
200%{_libexecdir}/pxgsettings
201
202%files kde
203%defattr(-,root,root,-)
204%{_libdir}/%{name}/%{version}/modules/config_kde.so
205
206# Build the pacrunner into libproxy unless we are building for multiple engines
207%if %{with mozjs}
208%files mozjs
209%defattr(-,root,root,-)
210%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
211
212%files webkitgtk4
213%defattr(-,root,root,-)
214%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
215%endif
216
217%files devel
218%defattr(-,root,root,-)
219%{_includedir}/proxy.h
220%{_libdir}/*.so
221%{_libdir}/pkgconfig/libproxy-1.0.pc
222%{_datadir}/cmake/Modules/Findlibproxy.cmake
223
224
225%changelog
226* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-2
227- rebuilt with current environment.
228
229* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-1
230- updated to 0.4.15.
231- enabled python3 support.
232- disabled mozjs as default.
233- switched to webkitgtk4.
234
235* Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-2
236- rebuild with gcc-5.4.0
237
238* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
239- update to 0.4.11
240- remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
241
242* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
243- rebuild with python-2.7.2
244
245* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
246- new upstream release
247- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
248- change BuildRequires: js-devel instead of gecko-devel
249- replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
250- detele -webkit sub package
251- create -webkitgtk3 sub package
252
253* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
254- new upstream release
255- drop Patch0
256- add BuildRequires: cmake, kdelibs-devel
257- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
258
259* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
260- rebuild with rpm-4.8.1 for pkg-config file
261
262* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
263- rebuild with python-2.6
264
265* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
266- rebuild with gecko-1.9.1
267
268* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
269- rebuild with WebKit-gtk-1.0.0-8.svn41944
270
271* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
272- initial build for Vine Linux
273
274* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
275- Rebuild for webkit
276- Raise requirement for xulrunner to 1.9.1
277
278* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
279- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
280
281* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
282- Merge NetworkManager module into the main libproxy package
283- Main Requires the -python and -bin subpackage
284 (splitted for multilibs compliance).
285
286* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
287- Disable Gnome/KDE default support via builtin modules.
288 (it needs to be integrated via Gconf2/neon instead).
289
290* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
291- Disable Obsoletes.
292- Requires ev instead of evr for optionnals sub-packages.
293
294* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
295- Use conditionals build.
296
297* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
298- Remove plugin- in the name of the packages
299
300* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
301- Move proxy.h to libproxy/proxy.h
302  This will prevent it to be included in the default include path
303- Split main to libs and util and use libproxy to install all
304
305* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
306- Rename binding-python to python
307- Add Requires: gecko-libs >= %%{gecko_version}
308- Fix some descriptions
309- Add plugin-webkit package
310 
311* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
312- Convert to Fedora spec
313
314* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
315- Updated to version 0.2.3
316* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
317- Extended spec file to build all available plugins
318* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
319- Initial spec file for Version 0.2.2
320
Note: See TracBrowser for help on using the repository browser.