source: projects/specs/trunk/lib/libp/libproxy/libproxy-vl.spec @ 8085

Revision 8085, 8.0 KB checked in by Takemikaduchi, 10 years ago (diff)

libproxy: new upstream release
others: rebuild

Line 
1%{!?python_sitelib: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:        A library handling all the details of proxy configuration
4Name:           libproxy
5Version:        0.4.11
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://code.google.com/p/libproxy/
11Source0:        http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildRequires:  python-devel
15#Virtual Provides - We need either mozjs or WebKit
16Requires: %{name}-pac >= %{version}
17#
18Requires: libproxy-python = %{version}-%{release}
19Requires: libproxy-bin = %{version}-%{release}
20
21BuildRequires:  cmake
22# gnome
23BuildRequires:  GConf2-devel
24# mozjs
25BuildRequires:  js-devel
26# NetworkManager
27BuildRequires:  NetworkManager-devel
28BuildRequires:  dbus-devel
29# webkit (gtk)
30BuildRequires:  WebKit3-gtk-devel
31# kde
32BuildRequires:  kdelibs-devel
33BuildRequires:  libXmu-devel
34BuildRequires:  libX11-devel
35
36
37Provides: %{name}-webkit = %{version}-%{release}
38Obsoletes: %{name}-webkit < %{version}-%{release}
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44libproxy offers the following features:
45
46    * extremely small core footprint (< 35K)
47    * no external dependencies within libproxy core
48      (libproxy plugins may have dependencies)
49    * only 3 functions in the stable external API
50    * dynamic adjustment to changing network topology
51    * a standard way of dealing with proxy settings across all scenarios
52    * a sublime sense of joy and accomplishment
53
54Non-default rpmbuild options:
55--with webkit:           Enable WebKit-gtk support
56
57
58%package        bin
59Summary:        Binary to test %{name}
60Group:          Applications/System
61Requires:       %{name} = %{version}-%{release}
62
63%description    bin
64The %{name}-bin package contains the proxy binary for %{name}
65
66%package        python
67Summary:        Binding for %{name} and python
68Group:          System Environment/Libraries
69Requires:       %{name} = %{version}-%{release}
70
71%description    python
72The %{name}-python package contains the python binding for %{name}
73
74%package        gnome
75Summary:        Plugin for %{name} and gnome
76Group:          System Environment/Libraries
77Requires:       %{name} = %{version}-%{release}
78
79%description    gnome
80The %{name}-gnome package contains the %{name} plugin for gnome.
81
82%package        kde
83Summary:        Plugin for %{name} and kde
84Group:          System Environment/Libraries
85Requires:       %{name} = %{version}-%{release}
86
87%description    kde
88The %{name}-kde package contains the %{name} plugin for kde.
89
90%package        mozjs
91Summary:        Plugin for %{name} and mozjs
92Group:          System Environment/Libraries
93Requires:       %{name} = %{version}
94#Tweak this according to the current gecko-libs version
95Requires:       js
96Provides:       %{name}-pac = %{version}-%{release}
97
98%description    mozjs
99The %{name}-mozjs package contains the %{name} plugin for mozjs.
100
101%package        webkitgtk3
102Summary:        Plugin for %{name} and webkitgtk3
103Group:          System Environment/Libraries
104Requires:       %{name} = %{version}
105Provides:       %{name}-pac = %{version}-%{release}
106
107%description    webkitgtk3
108The %{name}-webkitgtk3 package contains the %{name} plugin for
109webkitgtk3.
110
111%package        devel
112Summary:        Development files for %{name}
113Group:          Development/Libraries
114Requires:       %{name} = %{version}-%{release}
115Requires:       pkgconfig
116
117%description    devel
118The %{name}-devel package contains libraries and header files for
119developing applications that use %{name}.
120
121
122%prep
123%setup -q
124
125%build
126%cmake \
127        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
128        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
129        -DWITH_PERL=OFF \
130        -DWITH_WEBKIT3=ON \
131   .
132make VERBOSE=1 %{?_smp_mflags}
133
134
135%install
136rm -rf $RPM_BUILD_ROOT
137make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
138find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144
145%post -p /sbin/ldconfig
146
147%postun -p /sbin/ldconfig
148
149
150%files
151%defattr(-,root,root,-)
152%doc AUTHORS COPYING README
153%{_libdir}/*.so.*
154%dir %{_libdir}/%{name}
155%dir %{_libdir}/%{name}/%{version}
156%dir %{_libdir}/%{name}/%{version}/modules
157%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
158
159%files bin
160%defattr(-,root,root,-)
161%{_bindir}/proxy
162
163%files python
164%defattr(-,root,root,-)
165%{python_sitelib}/libproxy.py
166
167%files gnome
168%defattr(-,root,root,-)
169%{_libdir}/%{name}/%{version}/modules/config_gnome3.so
170%{_libexecdir}/pxgsettings
171
172%files kde
173%defattr(-,root,root,-)
174%{_libdir}/%{name}/%{version}/modules/config_kde4.so
175
176%files mozjs
177%defattr(-,root,root,-)
178%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
179
180%files webkitgtk3
181%defattr(-,root,root,-)
182%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
183
184%files devel
185%defattr(-,root,root,-)
186%{_includedir}/proxy.h
187%{_libdir}/*.so
188%{_libdir}/pkgconfig/libproxy-1.0.pc
189%{_datadir}/cmake/Modules/Findlibproxy.cmake
190
191
192%changelog
193* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
194- update to 0.4.11
195- remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
196
197* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
198- rebuild with python-2.7.2
199
200* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
201- new upstream release
202- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
203- change BuildRequires: js-devel instead of gecko-devel
204- replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
205- detele -webkit sub package
206- create -webkitgtk3 sub package
207
208* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
209- new upstream release
210- drop Patch0
211- add BuildRequires: cmake, kdelibs-devel
212- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
213
214* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
215- rebuild with rpm-4.8.1 for pkg-config file
216
217* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
218- rebuild with python-2.6
219
220* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
221- rebuild with gecko-1.9.1
222
223* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
224- rebuild with WebKit-gtk-1.0.0-8.svn41944
225
226* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
227- initial build for Vine Linux
228
229* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
230- Rebuild for webkit
231- Raise requirement for xulrunner to 1.9.1
232
233* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
235
236* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
237- Merge NetworkManager module into the main libproxy package
238- Main Requires the -python and -bin subpackage
239 (splitted for multilibs compliance).
240
241* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
242- Disable Gnome/KDE default support via builtin modules.
243 (it needs to be integrated via Gconf2/neon instead).
244
245* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
246- Disable Obsoletes.
247- Requires ev instead of evr for optionnals sub-packages.
248
249* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
250- Use conditionals build.
251
252* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
253- Remove plugin- in the name of the packages
254
255* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
256- Move proxy.h to libproxy/proxy.h
257  This will prevent it to be included in the default include path
258- Split main to libs and util and use libproxy to install all
259
260* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
261- Rename binding-python to python
262- Add Requires: gecko-libs >= %%{gecko_version}
263- Fix some descriptions
264- Add plugin-webkit package
265 
266* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
267- Convert to Fedora spec
268
269* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
270- Updated to version 0.2.3
271* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
272- Extended spec file to build all available plugins
273* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
274- Initial spec file for Version 0.2.2
275
Note: See TracBrowser for help on using the repository browser.