source: projects/specs/trunk/lib/libp/libproxy/libproxy-vl.spec @ 12495

Revision 12495, 9.2 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

cifs-utils-6.11-1

libproxy-0.4.15-3

netpbm-10.86.16-1

squashfs-tools-4.4-1

xorg-x11-server-1.20.9-1

RevLine 
[11377]1%bcond_with mozjs
[521]2
[11377]3%define _unpackaged_files_terminate_build 1
4
[521]5Summary:        A library handling all the details of proxy configuration
6Name:           libproxy
[11377]7Version:        0.4.15
[12495]8Release:        3%{?_dist_release}
9Group:          system
10Vendor:         Project Vine
11Distribution:   Vine Linux
[521]12
13License:        LGPLv2+
[11377]14URL:            http://libproxy.github.io/libproxy
15Source0:        https://github.com/libproxy/libproxy/releases/download/%{version}/libproxy-%{version}.tar.xz
[12495]16Patch0:         libproxy-0.4.15-python38.patch
17Patch1000:      CVE-2020-25219.patch
18
[521]19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21BuildRequires:  python-devel
[11377]22BuildRequires:  python3-devel
[521]23#Virtual Provides - We need either mozjs or WebKit
[11377]24%if %{with mozjs}
[521]25Requires: %{name}-pac >= %{version}
[11377]26%endif
[521]27#
28Requires: libproxy-python = %{version}-%{release}
29Requires: libproxy-bin = %{version}-%{release}
30
[11377]31Obsoletes: %{name}-mozjs < 1.4.15
32Obsoletes: %{name}-webkitgtk3 < 1.4.15
33
[2041]34BuildRequires:  cmake
[521]35# gnome
36BuildRequires:  GConf2-devel
[11377]37%if %{with mozjs}
[521]38# mozjs
[11377]39BuildRequires:  mozjs >= 38
40%endif
[521]41# NetworkManager
[12372]42BuildRequires:  NetworkManager-libnm-devel
[521]43BuildRequires:  dbus-devel
[11377]44BuildRequires:  glib2
[521]45# webkit (gtk)
[11377]46BuildRequires:  webkitgtk4-devel
[521]47# kde
48BuildRequires:  libXmu-devel
49BuildRequires:  libX11-devel
50
[11377]51BuildRequires:  python-rpm-macros
52BuildRequires:  python3-rpm-macros
[521]53
[4616]54Provides: %{name}-webkit = %{version}-%{release}
55Obsoletes: %{name}-webkit < %{version}-%{release}
56
[521]57%description
58libproxy offers the following features:
59
60    * extremely small core footprint (< 35K)
61    * no external dependencies within libproxy core
62      (libproxy plugins may have dependencies)
63    * only 3 functions in the stable external API
64    * dynamic adjustment to changing network topology
65    * a standard way of dealing with proxy settings across all scenarios
66    * a sublime sense of joy and accomplishment
67
68Non-default rpmbuild options:
69--with webkit:           Enable WebKit-gtk support
70
71
72%package        bin
73Summary:        Binary to test %{name}
[12495]74Group:          network
[521]75Requires:       %{name} = %{version}-%{release}
76
77%description    bin
78The %{name}-bin package contains the proxy binary for %{name}
79
[12495]80
[521]81%package        python
82Summary:        Binding for %{name} and python
[12495]83Group:          programming
[521]84Requires:       %{name} = %{version}-%{release}
85
86%description    python
87The %{name}-python package contains the python binding for %{name}
88
[11377]89%package        python3
90Summary:        Binding for %{name} and python
[12495]91Group:          programming
[11377]92Requires:       %{name} = %{version}-%{release}
93
[12495]94
[11377]95%description    python3
96The %{name}-python package contains the python binding for %{name}
97
[521]98%package        gnome
99Summary:        Plugin for %{name} and gnome
[12495]100Group:          system
[521]101Requires:       %{name} = %{version}-%{release}
102
103%description    gnome
104The %{name}-gnome package contains the %{name} plugin for gnome.
105
[12495]106
[521]107%package        kde
108Summary:        Plugin for %{name} and kde
[12495]109Group:          system
[521]110Requires:       %{name} = %{version}-%{release}
111
112%description    kde
113The %{name}-kde package contains the %{name} plugin for kde.
114
[12495]115
[11377]116%if %{with mozjs}
[521]117%package        mozjs
118Summary:        Plugin for %{name} and mozjs
[12495]119Group:          system
[521]120Requires:       %{name} = %{version}
121#Tweak this according to the current gecko-libs version
[4616]122Requires:       js
[521]123Provides:       %{name}-pac = %{version}-%{release}
124
125%description    mozjs
126The %{name}-mozjs package contains the %{name} plugin for mozjs.
127
[12495]128
[11377]129%package        webkitgtk4
130Summary:        Plugin for %{name} and webkitgtk4
[12495]131Group:          system
[521]132Requires:       %{name} = %{version}
133Provides:       %{name}-pac = %{version}-%{release}
134
[11377]135%description    webkitgtk4
[4616]136The %{name}-webkitgtk3 package contains the %{name} plugin for
137webkitgtk3.
[11377]138%endif
139
[12495]140
[521]141%package        devel
142Summary:        Development files for %{name}
[12495]143Group:          programming
[521]144Requires:       %{name} = %{version}-%{release}
145Requires:       pkgconfig
146
147%description    devel
148The %{name}-devel package contains libraries and header files for
149developing applications that use %{name}.
150
151
[12495]152%debug_package
153
154
[521]155%prep
156%setup -q
[12495]157%patch0 -p1
158%patch1000 -p1
[11377]159#sed -i "s|mozjs185>=1.8.5|mozjs185|" libproxy/cmake/modules/pacrunner_mozjs.cmk
[521]160
161%build
[2041]162%cmake \
163        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
164        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
165        -DWITH_PERL=OFF \
[4616]166        -DWITH_WEBKIT3=ON \
[11377]167        -DWITH_KDE=ON \
[2041]168   .
169make VERBOSE=1 %{?_smp_mflags}
[521]170
171
172%install
173rm -rf $RPM_BUILD_ROOT
174make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
175find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
176
177
178%clean
179rm -rf $RPM_BUILD_ROOT
180
181
182%post -p /sbin/ldconfig
183%postun -p /sbin/ldconfig
184
185
186%files
187%defattr(-,root,root,-)
[12372]188%license COPYING
189%doc AUTHORS README
[521]190%{_libdir}/*.so.*
191%dir %{_libdir}/%{name}
192%dir %{_libdir}/%{name}/%{version}
[2041]193%dir %{_libdir}/%{name}/%{version}/modules
194%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
[521]195
196%files bin
197%defattr(-,root,root,-)
198%{_bindir}/proxy
199
200%files python
201%defattr(-,root,root,-)
[4616]202%{python_sitelib}/libproxy.py
[521]203
[11377]204%files python3
205%defattr(-,root,root,-)
206%{python3_sitelib}/libproxy.py
207
[521]208%files gnome
209%defattr(-,root,root,-)
[4616]210%{_libdir}/%{name}/%{version}/modules/config_gnome3.so
211%{_libexecdir}/pxgsettings
[521]212
213%files kde
214%defattr(-,root,root,-)
[11377]215%{_libdir}/%{name}/%{version}/modules/config_kde.so
[521]216
[11377]217# Build the pacrunner into libproxy unless we are building for multiple engines
218%if %{with mozjs}
[521]219%files mozjs
220%defattr(-,root,root,-)
[2041]221%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
[521]222
[11377]223%files webkitgtk4
[521]224%defattr(-,root,root,-)
[2041]225%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
[11377]226%endif
[521]227
228%files devel
229%defattr(-,root,root,-)
[2041]230%{_includedir}/proxy.h
[521]231%{_libdir}/*.so
232%{_libdir}/pkgconfig/libproxy-1.0.pc
[2041]233%{_datadir}/cmake/Modules/Findlibproxy.cmake
[521]234
235
236%changelog
[12495]237* Tue Sep 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-3
238- imported Patch1000 to fix CVE-2020-25219 from debian.
239- imported Patch0 to support python-3.8 from upstream.
240
[12372]241* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-2
242- rebuilt with current environment.
243
[11377]244* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-1
245- updated to 0.4.15.
246- enabled python3 support.
247- disabled mozjs as default.
248- switched to webkitgtk4.
249
[10549]250* Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-2
251- rebuild with gcc-5.4.0
252
[8085]253* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
254- update to 0.4.11
255- remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
256
[5701]257* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
258- rebuild with python-2.7.2
259
[4616]260* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
261- new upstream release
262- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
263- change BuildRequires: js-devel instead of gecko-devel
264- replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
265- detele -webkit sub package
266- create -webkitgtk3 sub package
267
[2041]268* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
269- new upstream release
270- drop Patch0
271- add BuildRequires: cmake, kdelibs-devel
272- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
273
[1901]274* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
275- rebuild with rpm-4.8.1 for pkg-config file
276
[521]277* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
278- rebuild with python-2.6
279
280* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
281- rebuild with gecko-1.9.1
282
283* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
284- rebuild with WebKit-gtk-1.0.0-8.svn41944
285
286* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
287- initial build for Vine Linux
288
289* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
290- Rebuild for webkit
291- Raise requirement for xulrunner to 1.9.1
292
293* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
294- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
295
296* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
297- Merge NetworkManager module into the main libproxy package
298- Main Requires the -python and -bin subpackage
299 (splitted for multilibs compliance).
300
301* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
302- Disable Gnome/KDE default support via builtin modules.
303 (it needs to be integrated via Gconf2/neon instead).
304
305* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
306- Disable Obsoletes.
307- Requires ev instead of evr for optionnals sub-packages.
308
309* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
310- Use conditionals build.
311
312* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
313- Remove plugin- in the name of the packages
314
315* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
316- Move proxy.h to libproxy/proxy.h
317  This will prevent it to be included in the default include path
318- Split main to libs and util and use libproxy to install all
319
320* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
321- Rename binding-python to python
322- Add Requires: gecko-libs >= %%{gecko_version}
323- Fix some descriptions
324- Add plugin-webkit package
325 
326* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
327- Convert to Fedora spec
328
329* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
330- Updated to version 0.2.3
331* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
332- Extended spec file to build all available plugins
333* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
334- Initial spec file for Version 0.2.2
335
Note: See TracBrowser for help on using the repository browser.