source: projects/specs/trunk/lib/libp/libproxy/libproxy-vl.spec @ 12505

Revision 12505, 9.5 KB checked in by tomop, 3 years ago (diff)

updated 6 packages

alsa-lib-1.2.3.2-1

alsa-oss-1.1.8-1

alsa-plugins-1.2.2-1

libproxy-0.4.15-4

python3-3.8.6-1

samba-4.13.0-2

RevLine 
[11377]1%bcond_with mozjs
[521]2
[11377]3%define _unpackaged_files_terminate_build 1
4
[521]5Summary:        A library handling all the details of proxy configuration
6Name:           libproxy
[11377]7Version:        0.4.15
[12505]8Release:        4%{?_dist_release}
[12495]9Group:          system
10Vendor:         Project Vine
11Distribution:   Vine Linux
[521]12
13License:        LGPLv2+
[11377]14URL:            http://libproxy.github.io/libproxy
15Source0:        https://github.com/libproxy/libproxy/releases/download/%{version}/libproxy-%{version}.tar.xz
[12495]16Patch0:         libproxy-0.4.15-python38.patch
17Patch1000:      CVE-2020-25219.patch
[12505]18# CVE-2020-26154
19Patch1001:      libproxy-0.4.15-fix-pac-buffer-overflow.patch
[12495]20
[521]21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22
23BuildRequires:  python-devel
[11377]24BuildRequires:  python3-devel
[521]25#Virtual Provides - We need either mozjs or WebKit
[11377]26%if %{with mozjs}
[521]27Requires: %{name}-pac >= %{version}
[11377]28%endif
[521]29#
30Requires: libproxy-python = %{version}-%{release}
31Requires: libproxy-bin = %{version}-%{release}
32
[11377]33Obsoletes: %{name}-mozjs < 1.4.15
34Obsoletes: %{name}-webkitgtk3 < 1.4.15
35
[2041]36BuildRequires:  cmake
[521]37# gnome
38BuildRequires:  GConf2-devel
[11377]39%if %{with mozjs}
[521]40# mozjs
[11377]41BuildRequires:  mozjs >= 38
42%endif
[521]43# NetworkManager
[12372]44BuildRequires:  NetworkManager-libnm-devel
[521]45BuildRequires:  dbus-devel
[11377]46BuildRequires:  glib2
[521]47# webkit (gtk)
[11377]48BuildRequires:  webkitgtk4-devel
[521]49# kde
50BuildRequires:  libXmu-devel
51BuildRequires:  libX11-devel
52
[11377]53BuildRequires:  python-rpm-macros
54BuildRequires:  python3-rpm-macros
[521]55
[4616]56Provides: %{name}-webkit = %{version}-%{release}
57Obsoletes: %{name}-webkit < %{version}-%{release}
58
[521]59%description
60libproxy offers the following features:
61
62    * extremely small core footprint (< 35K)
63    * no external dependencies within libproxy core
64      (libproxy plugins may have dependencies)
65    * only 3 functions in the stable external API
66    * dynamic adjustment to changing network topology
67    * a standard way of dealing with proxy settings across all scenarios
68    * a sublime sense of joy and accomplishment
69
70Non-default rpmbuild options:
71--with webkit:           Enable WebKit-gtk support
72
73
74%package        bin
75Summary:        Binary to test %{name}
[12495]76Group:          network
[521]77Requires:       %{name} = %{version}-%{release}
78
79%description    bin
80The %{name}-bin package contains the proxy binary for %{name}
81
[12495]82
[521]83%package        python
84Summary:        Binding for %{name} and python
[12495]85Group:          programming
[521]86Requires:       %{name} = %{version}-%{release}
87
88%description    python
89The %{name}-python package contains the python binding for %{name}
90
[11377]91%package        python3
92Summary:        Binding for %{name} and python
[12495]93Group:          programming
[11377]94Requires:       %{name} = %{version}-%{release}
95
[12495]96
[11377]97%description    python3
98The %{name}-python package contains the python binding for %{name}
99
[521]100%package        gnome
101Summary:        Plugin for %{name} and gnome
[12495]102Group:          system
[521]103Requires:       %{name} = %{version}-%{release}
104
105%description    gnome
106The %{name}-gnome package contains the %{name} plugin for gnome.
107
[12495]108
[521]109%package        kde
110Summary:        Plugin for %{name} and kde
[12495]111Group:          system
[521]112Requires:       %{name} = %{version}-%{release}
113
114%description    kde
115The %{name}-kde package contains the %{name} plugin for kde.
116
[12495]117
[11377]118%if %{with mozjs}
[521]119%package        mozjs
120Summary:        Plugin for %{name} and mozjs
[12495]121Group:          system
[521]122Requires:       %{name} = %{version}
123#Tweak this according to the current gecko-libs version
[4616]124Requires:       js
[521]125Provides:       %{name}-pac = %{version}-%{release}
126
127%description    mozjs
128The %{name}-mozjs package contains the %{name} plugin for mozjs.
129
[12495]130
[11377]131%package        webkitgtk4
132Summary:        Plugin for %{name} and webkitgtk4
[12495]133Group:          system
[521]134Requires:       %{name} = %{version}
135Provides:       %{name}-pac = %{version}-%{release}
136
[11377]137%description    webkitgtk4
[4616]138The %{name}-webkitgtk3 package contains the %{name} plugin for
139webkitgtk3.
[11377]140%endif
141
[12495]142
[521]143%package        devel
144Summary:        Development files for %{name}
[12495]145Group:          programming
[521]146Requires:       %{name} = %{version}-%{release}
147Requires:       pkgconfig
148
149%description    devel
150The %{name}-devel package contains libraries and header files for
151developing applications that use %{name}.
152
153
[12495]154%debug_package
155
156
[521]157%prep
[12505]158%autosetup -p1
[11377]159#sed -i "s|mozjs185>=1.8.5|mozjs185|" libproxy/cmake/modules/pacrunner_mozjs.cmk
[521]160
[12505]161
[521]162%build
[12505]163export CXXFLAGS="-std=c++14 $RPM_OPT_FLAGS"
[2041]164%cmake \
165        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
166        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
167        -DWITH_PERL=OFF \
[4616]168        -DWITH_WEBKIT3=ON \
[12505]169        -DWITH_GNOME3=ON \
[11377]170        -DWITH_KDE=ON \
[2041]171   .
172make VERBOSE=1 %{?_smp_mflags}
[521]173
174
175%install
176rm -rf $RPM_BUILD_ROOT
177make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
178find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
179
180
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184
185%post -p /sbin/ldconfig
186%postun -p /sbin/ldconfig
187
188
189%files
190%defattr(-,root,root,-)
[12372]191%license COPYING
192%doc AUTHORS README
[521]193%{_libdir}/*.so.*
194%dir %{_libdir}/%{name}
195%dir %{_libdir}/%{name}/%{version}
[2041]196%dir %{_libdir}/%{name}/%{version}/modules
197%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
[521]198
199%files bin
200%defattr(-,root,root,-)
201%{_bindir}/proxy
202
203%files python
204%defattr(-,root,root,-)
[4616]205%{python_sitelib}/libproxy.py
[521]206
[11377]207%files python3
208%defattr(-,root,root,-)
209%{python3_sitelib}/libproxy.py
210
[521]211%files gnome
212%defattr(-,root,root,-)
[4616]213%{_libdir}/%{name}/%{version}/modules/config_gnome3.so
214%{_libexecdir}/pxgsettings
[521]215
216%files kde
217%defattr(-,root,root,-)
[11377]218%{_libdir}/%{name}/%{version}/modules/config_kde.so
[521]219
[11377]220# Build the pacrunner into libproxy unless we are building for multiple engines
221%if %{with mozjs}
[521]222%files mozjs
223%defattr(-,root,root,-)
[2041]224%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
[521]225
[11377]226%files webkitgtk4
[521]227%defattr(-,root,root,-)
[2041]228%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
[11377]229%endif
[521]230
231%files devel
232%defattr(-,root,root,-)
[2041]233%{_includedir}/proxy.h
[521]234%{_libdir}/*.so
235%{_libdir}/pkgconfig/libproxy-1.0.pc
[2041]236%{_datadir}/cmake/Modules/Findlibproxy.cmake
[521]237
238
239%changelog
[12505]240* Sat Oct 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-4
241- imported Patch1001 to fix CVE-2020-26154 from rawhide.
242
[12495]243* Tue Sep 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-3
244- imported Patch1000 to fix CVE-2020-25219 from debian.
245- imported Patch0 to support python-3.8 from upstream.
246
[12372]247* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-2
248- rebuilt with current environment.
249
[11377]250* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-1
251- updated to 0.4.15.
252- enabled python3 support.
253- disabled mozjs as default.
254- switched to webkitgtk4.
255
[10549]256* Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-2
257- rebuild with gcc-5.4.0
258
[8085]259* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
260- update to 0.4.11
261- remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
262
[5701]263* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
264- rebuild with python-2.7.2
265
[4616]266* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
267- new upstream release
268- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
269- change BuildRequires: js-devel instead of gecko-devel
270- replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
271- detele -webkit sub package
272- create -webkitgtk3 sub package
273
[2041]274* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
275- new upstream release
276- drop Patch0
277- add BuildRequires: cmake, kdelibs-devel
278- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
279
[1901]280* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
281- rebuild with rpm-4.8.1 for pkg-config file
282
[521]283* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
284- rebuild with python-2.6
285
286* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
287- rebuild with gecko-1.9.1
288
289* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
290- rebuild with WebKit-gtk-1.0.0-8.svn41944
291
292* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
293- initial build for Vine Linux
294
295* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
296- Rebuild for webkit
297- Raise requirement for xulrunner to 1.9.1
298
299* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
300- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
301
302* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
303- Merge NetworkManager module into the main libproxy package
304- Main Requires the -python and -bin subpackage
305 (splitted for multilibs compliance).
306
307* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
308- Disable Gnome/KDE default support via builtin modules.
309 (it needs to be integrated via Gconf2/neon instead).
310
311* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
312- Disable Obsoletes.
313- Requires ev instead of evr for optionnals sub-packages.
314
315* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
316- Use conditionals build.
317
318* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
319- Remove plugin- in the name of the packages
320
321* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
322- Move proxy.h to libproxy/proxy.h
323  This will prevent it to be included in the default include path
324- Split main to libs and util and use libproxy to install all
325
326* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
327- Rename binding-python to python
328- Add Requires: gecko-libs >= %%{gecko_version}
329- Fix some descriptions
330- Add plugin-webkit package
331 
332* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
333- Convert to Fedora spec
334
335* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
336- Updated to version 0.2.3
337* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
338- Extended spec file to build all available plugins
339* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
340- Initial spec file for Version 0.2.2
341
Note: See TracBrowser for help on using the repository browser.