source: projects/specs/trunk/lib/libp/libpqxx/libpqxx-vl.spec @ 521

Revision 521, 2.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A C++ API to the PostgreSQL database management system.
2Summary(ja): PostgreSQL の C++ API
3Name: libpqxx
4Version: 2.6.9
5Release: 2%{?_dist_release}
6License: LGPL
7Group: Development/Libraries
8Source: ftp://gborg.postgresql.org/pub/libpqxx/stable/libpqxx-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10URL: http://pqxx.tk/
11BuildPrereq: postgresql-devel
12Requires: postgresql-libs
13
14%description
15What libpqxx brings you is effective use of templates to reduce the
16inconvenience of dealing with type conversions; of standard C++ strings
17to keep you from having to worry about buffer allocation and overflow
18attacks; of exceptions to take the tedious and error-prone plumbing around
19error handling out of your hands; of constructors and destructors to bring
20resource management under control; and even basic object-orientation
21to give you some extra reliability features that would be hard to get
22with most other database interfaces.
23
24%package devel
25Summary: Libraries, includes, etc. to develop PostgreSQL applications in C++.
26Summary(ja): C++ で PostgreSQL アプリケーションを開発ためのライブラリ/ヘッダファイル等
27Group: Development/Libraries
28Requires: libpqxx = %{version}
29
30%description devel
31Libraries, include files, etc you can use to develop PostgreSQL applications
32in C++.
33
34%prep
35%setup -q
36
37%build
38CFLAGS="$RPM_OPT_FLAGS" \
39./configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-shared
40make %{?_smp_mflags}
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make DESTDIR=$RPM_BUILD_ROOT install
45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49%post -p /sbin/ldconfig
50
51%postun -p /sbin/ldconfig
52
53%files
54%defattr(-,root,root)
55%doc AUTHORS ChangeLog NEWS README COPYING TODO
56%{_libdir}/*.so
57
58%files devel
59%defattr(-,root,root)
60%doc doc/html/Reference doc/html/Tutorial
61%{_bindir}/*
62%{_includedir}/pqxx/*
63%{_libdir}/*.a
64%{_libdir}/*.la
65%{_libdir}/pkgconfig/*.pc
66
67%changelog
68* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
69- rebuilt with postgresql-8.4.0
70
71* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.9-1vl5
72- rebuilt with postgresql-8.3.3
73- applied new versioning policy, and spec in utf-8
74
75* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.9-0vl3
76- rebuilt with postgresql-8.2.6
77
78* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.9-0vl2
79- rebuilt with postgresql-8.2.5
80
81* Tue May 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.9-0vl1
82- new upstream release
83- build with new toolchain
84
85* Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.5-0vl2
86- added --libdir=%%{_libdir} configure option
87
88* Thu Jul  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.5.5-0vl1
89- new upstream release
90- add Japanese summary
91
92* Wed Jun  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.5.3-0vl1
93- new upstream release
94
95* Wed Apr 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.5.0-0vl1
96- new upstream release
97- clean up this file
98
99* Thu Jan 29 2004 Arjen Baart <arjen@andromeda.nl>
100- Built release 2.1.3
Note: See TracBrowser for help on using the repository browser.