source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 10115

Revision 10115, 27.5 KB checked in by tomop, 8 years ago (diff)

libpq-9.5.2-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 9.5
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.2
19Release: 1%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: libedit-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160cp -f ./src/backend/utils/fmgroids.h ./src/include/utils/
161make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
162
163# copy over Makefile.global to the include dir....
164install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
165install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
166
167# install missing header
168mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
171install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
176
177# Fix some more documentation
178##gzip doc/internals.ps
179cp %{SOURCE6} README.rpm-dist
180##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
181##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
182
183mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
184install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
185
186
187%find_lang libpq5-%{pgver}
188%find_lang ecpg-%{pgver}
189%find_lang ecpglib%{ecpg_soname}-%{pgver}
190#%find_lang pg_config-%{pgver}
191
192cat libpq5-%{pgver}.lang > libpq.lst
193cat ecpg-%{pgver}.lang >> libpq.lst
194cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
195#cat pg_config-%{pgver}.lang > devel.lst
196
197rm -rf %{buildroot}%{_libdir}/lib*.a
198rm -rf %{buildroot}%{_datadir}/pgsql
199find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
200
201rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
202find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
203
204%post
205/sbin/ldconfig
206
207%postun
208/sbin/ldconfig
209
210
211%clean
212rm -rf $RPM_BUILD_ROOT
213
214
215%files -n libpq%{pq_soname} -f libpq.lst
216%defattr(-,root,root)
217%doc COPYRIGHT HISTORY INSTALL README*
218%{_libdir}/libecpg.so.*
219%{_libdir}/libecpg_compat.so.*
220%{_libdir}/libpgtypes.so.*
221%{_libdir}/libpq.so.*
222
223%files devel -f devel.lst
224%defattr(-,root,root)
225%{_bindir}/ecpg
226%{_bindir}/pg_config
227%{_libdir}/libecpg.so
228%{_libdir}/libecpg_compat.so
229%{_libdir}/libpgtypes.so
230%{_libdir}/libpq.so
231%{_libdir}/pkgconfig/*
232%{_datadir}/locale/*/LC_MESSAGES/*.mo
233%{_mandir}/man1/ecpg.*
234#%{_mandir}/man1/pg_config.*
235
236
237%changelog
238* Fri Apr  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.2-1
239- new upstream release.
240
241* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.1-1
242- new upstream release.
243
244* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
245- new upstream release.
246
247* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
248- new upstream release.
249
250* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
251- new upstream release.
252
253* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
254- new upstream release.
255
256* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
257- added all headers for a strange client.
258
259* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
260- add pgconfig
261- add pg_config*.h and libpq/libpq-fs.h
262
263* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
264- add postgres_ext.h and pg_config_ext.h
265
266* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
267- new upstream release
268
269* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
270- made to build client libraries only.
271
272* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
273- new upstream release
274
275* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
276- new upstream release
277- add Vendor and Distribution tags
278
279* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
280- build with Tcl/Tk 8.5.7-1
281- fix init script (Source3): fix su(1) paramaters.
282
283* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
284- new upstream release
285- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
286- remove *_and_*.so from -contrib (included in -server)
287
288* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
289- updated postgresql to 9.0.4
290
291* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
292- updated postgresql to 9.0.3
293- separated postgresql-jdbc package
294
295* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
296- updated postgresql to 8.4.7 (contains a variety of fixes)
297
298* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
299- updated postgresql to 8.4.6
300- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
301- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
302- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
303
304* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
305- rebuilt with openssl-1.0.0c
306
307* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
308- updated postgresql to 8.4.5
309
310* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
311- updated postgresql to 8.4.4
312
313* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
314- updated postgresql to 8.4.3
315- s/BuildPrereq/Buildrequires/
316
317* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
318- updated postgresql to 8.4.2
319- rebuilt with new environment
320
321* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
322- updated postgresql to 8.4.1
323
324* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
325- moved dict_snowball.so from conrib to server
326
327* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
328- updated postgresql to 8.4.0
329- updated jdbc3,4 to 701
330- dropt postgresql-8.3.3-nls.patch (fixed)
331- dropt postgresql-7.4-ecpg-patch (no effect)
332
333* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
334- changed libs Group to System Environment/Libraries
335
336* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
337- updated postgresql to 8.3.7
338
339* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
340- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
341
342* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
343- new upstream release (postgresql to 8.3.5, jdbc to 604)
344
345* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
346- applied new versioning policy, and spec in utf-8
347- updated postgresql to 8.3.3
348- updated jdbcver to 603
349- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
350- added a script to replace PGVERSION in postgresql.init
351
352* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
353- rebuild with tcl/tk-8.4.18
354
355* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
356- updated postgresql to 8.2.6
357- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
358
359* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
360- updated PGVERSION to 8.2 in postgresql.init (sorry;)
361
362* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
363- rebuild with tcl/tk-8.4.16
364
365* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
366- updated postgresql to 8.2.5
367- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
368- updated nls-patch to 8-2-0
369- dropt postgresql-8.1.4-Pg.patch.gz
370
371* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
372- for VineSeed
373- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
374- JDBC driver updated to 410
375
376* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
377- rebuilt for VineSeed
378- fixed install script
379
380* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
381- upstream release
382- fix missing %defattr in %files server
383
384* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
385- fix version number in postgresql.init
386
387* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
388- upstream release
389- drop rpm-pgsql-8.0.0.patch
390- add Requires: perl-DBD-Pg for contrib
391- add postgresql-8.1.4-Pg.patch.gz
392- update nls patches
393- new JDBC driver
394
395* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
396- added build options --without perl, --without python
397- rebuilt for x86_64 architecture support
398
399* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
400- drop Provides: on postgresql-libs
401- drop Requires: libpq.so on postgresql-server
402
403* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
404- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
405
406* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
407- upstream release
408- update nls patches
409
410* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
411- upstream release
412- update nls patches
413
414* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
415- rebuilded with python-2.4.1-0vl1
416
417* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
418- Dropped PyGreSQL-3.4.tgz.
419- Dropped PyGreSQL-3.4-setup-2.patch.
420- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
421- Dropped pyver and pynextver macros.
422- Changed macro name "python" to "plpython" like plperl.
423- Added "Obsoletes: postgresql-python"
424
425* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
426- Major version up
427- Obsoletes: postgresql7
428- update nls patch(es)
429- modify %postun not to delete postgres account on upgrade
430
431* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
432- upstream release (release as a new package)
433- Conflicts: postgresql
434- update nls patch(es)
435- (this package revision was rejected by Vine Project)
436
437* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
438- upstream release
439- new JDBC driver
440- add BuildRequires: bison, flex, pam-devel
441- drop postgresql-7.4.5-tempfile.patch (repaired)
442
443* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
444- Added a security fix patch postgresql-7.4.5-tempfile.patch
445  from Gentoo Linux (CAN-2004-0977).
446- Changed Patch4:
447  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
448  It is possible to compile this package without pre-installed postgresql.
449- Removed Patch5 because Patch4 was changed.
450
451* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
452- upstream release
453
454* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
455- upstream release
456- new jdbc driver
457
458* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
459- rebuild with python-2.3.3-0vl1
460
461* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
462- changed mode to 644 at Makefile.global, Makefile.shlib
463
464* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
465- updated python install section
466
467* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
468- added PyGreSQL-3.4.tgz and set python flag
469- added PyGreSQL-3.4-setup.patch
470- added PyGreSQL-3.4-pgmodule.patch
471- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
472
473* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
474- rebuild with new openssl
475
476* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
477- upstream release
478- change all of %{?foo:%define foo 0} -like descriptions to simple
479  %define format for latest rpm to build.
480
481* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
482- rebuild on latest tcl package environment.
483
484* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
485- fixed lacking files at server's %files
486
487* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
488- include JDBC driver for 7.4
489- fix typo in postgresql-7.4-psql-patch
490
491* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
492- upstream release
493- change '--includedir=' option to avoid conflicting with unixODBC
494- add postgresql-7.4-ecpg-patch
495
496* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
497- upstream release
498
499* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
500- drop previous version of libpq's trash
501
502* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
503- upstream release with new nls patch
504- fix postgresql-bashprofile (value of PGDATA)
505- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
506
507* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
508- rebuild with tcltk8.4 and readline-4.3
509
510* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
511- upstream release
512
513* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
514- upstream release
515- remove garbage changelog
516
517* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
518- upstream release based on 7.3-2PGDG
519- add nls patch
520
521* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
522- 7.3-2PGDG
523- Fix typo in initscript.  Argh!!
524
525* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
526- 7.3-0.5PGDG
527- Jerk out all perl client stuff and kludgage
528- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
529- Eliminate locale and multibyte explicit enables -- they are both defaults now
530- Eliminate pgaccess code; it's not a part of the main tarball anymore
531- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
532- Eliminated separate tk client package -- rolled the tk client into the tcl client.
533- Moved pltcl into the pl subpackage.
534- Added plpython to the pl subpackage.
535- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
536
537* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
538- 7.3-0.1PGDG (not released)
539- Integrate 7.3 jar's courtesy Joe Conway
540- Integrate multi-postmaster initscript courtesy Karl DeBisschop
541- Some renames and restructures.
542- Stripped out the last dregs of the postgresql-dump migration script.
543- Conflicts with less than 7.3.
544
545- (See below for old changelogs from VineSeed)
546
547* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
548- updated to 7.2.3.
549
550* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
551- absorbed previous patch8 into original nlspatch
552- fixed configure options (--enable-nls and --enable-locale to be antinomy)
553
554* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
555- add patch8 (ja.po for psql was invalid)
556
557* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
558- updated to 7.2.2.
559- improved nlspatch to enable japanese SQL help in psql.
560
561* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
562- fixed garbage chars in description(ja).
563
564* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
565- imported & replaced changelog (following VineSeed's).
566  add some stuff to '%%files'.
567
568* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
569- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
570  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
571
572* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
573- replace nls patch.
574- add *.mo to '%%files'.
575
576* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
577- fix initscript
578
579* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
580- add /usr/bin/pg_id to the package (fix)
581
582* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
583- updated 7.2
584- added nls.patch
585- fixed spec file
586- added New JDBC
587-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
588
589* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
590- updated 7.1.3
591
592* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
593- 7.1.2-7vl3
594- merge 7.1.2-7vl2 and 7.1.2-7
595
596* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
597- 7.1.2-7vl2
598- fixed spec typo (%%{_includesir} -> %%{_includedir})
599
600* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
601- updated 7.1.2 (used postgresql-7.1.2-7)
602- used psqlj patch for 7.1.2
603- used jumbo-20010801.patch.gz
604
605* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
606- Add patches from 7.1-stable branch. This should fix #50799 and #50797
607- Enable kerberos authentication (#50644)
608- handle stop with stale pid file (#50499)
609- make the test subpackage (not built by default) own /usr/lib/pgsql/test
610
611* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
612- Make the -devel subpackage depend on -libs, not the main package
613
614* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
615- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
616
617* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
618- add changes for s390x
619
620* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
621- Many path fixes for contrib packages
622- Newer intarray
623- Don't use nested ifs for tkpkg/pgaccess
624- Turn off test package for Red Hat Linux - it makes most sense just to use
625  this during development
626- One "pgacess" -> "pgaccess"
627
628* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
629- -4PGDG
630- patchset update for pg_regress.sh
631- can the dot in the release -- confused too many people and some programs.
632- -3.PGDG
633- updated README.rpm-dist
634- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
635  was still being used where /usr/lib/pgsql was intended.
636- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
637
638* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
639- sync
640- Run chkconfig --add on server install
641- Move the prereqs on useradd on chkconfig to the server package
642- don't disable the %%clean section
643
644* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
645- Sync up with Trond Eivind's set.
646
647* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
648- Don't create postgres' .bashrc from the server post script: include it instead
649- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
650- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
651  libs
652- Source the i18n data from the .bashrc instead of in the initscript
653
654* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
655- Handle i18n for database startup - backend needs to have the same locale everytime,
656  but this certainly can't be hardcoded to C either
657- Fix stop, restart in initscript (#42217)
658- Make database init _much_ less verbose
659- other minor fixes to the initscript
660
661* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
662- 7.1.2
663
664* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
665- 7.1.2-0.1.1.PGDG PRERELEASE
666- Changed versioning and release numbering a little for better flexibility,
667-- particularly for distribution packagers.
668- Release numbering comment at top of spec, where it's more useful.
669- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
670  changlog, and the last 6.5.3's specfile for the changelog prior to
671  7.0.
672
673* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
674- 7.1.1-4.PGDG
675- _really_ got Python version agnosticism working.
676
677* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
678- 7.1.1-3.PGDG Release
679- Python version agnosticism.....
680
681* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
682- Use openssl
683- Make it obsolete subpackages if they aren't built
684
685* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
686- 7.1.1-2.PGDG Release.
687- Appended .PGDG to release string to differentiate our RPM set from the others.
688- /bin/sh fix in initscript
689- README.rpm-dist updates.
690
691* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
692- Rebuild with new readline
693
694* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
695- Initial 7.1.1
696
697* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
698- Specify shell when running commands through su in the initscript, to avoid problems
699  when people switch the postgres user to use tcsh
700
701* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
702- JDBC driver for Postgresql 7.1
703
704* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
705- slightly different versioning scheming, will go back to the official
706  later when I'm sure the package is ready to use
707
708* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
709- 7.1 RELEASE
710- 7.1-1 RPM RELEASE
711- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
712- Back to old versioning scheme, kept teg's other fixes.
713- README.rpm-dist updated.
714- PGVERSION updated all-around (hopefully!)
715- Couple of fixes from Peter E.
716- Rearrange dependencies -- only the -libs subpackage is required for most stuff
717- Removed broken and confusing logrotate script.
718
719* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
720- chown considered harmful - removed
721- fix dangling symlimks (pg_crc.c)
722- libpq.so changes for maximum compatiblity
723- different versioning scheme, to avoid trouble later
724- remove temporary perl file from the file list
725- fix spelling error in tcl description
726- mark odbcinst.ini as a config file
727- use %%defattr on packages which didn't have it
728
729* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
730- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
731- Packaging reorg: added contrib and docs subpackages.
732- Removed sgml source docs from main package --> docs subpackage.
733- Removed contrib tree from main package --> contrib subpackage.
734- Contrib tree is now prebuilt -- HOWEVER, very little install work is
735  currently done with this.
736
737* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
738- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
739
740* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
741- RC2
742- eliminate versioning information for ancilliary files in prep for CVS.
743- Fix docs mixup.
744
745* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
746- RC1 quickie.
747
748* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
749- Beta 6 initial build.
750- Use make install-all-headers instead of cpio hack for devel headers.
751- Split out the libs into the libs subpackage.
752- Updated initscript to use pg_ctl to stop
753- Updated initscript to initdb and start postmaster with LC_ALL=C to
754  prevent index corruption.
755
756
757* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
758- Beta4
759- Return to 'pgsql' directories instead of 'postgresql'
760- Better perl patches.
761
762* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
763- Edit patches to get rid of some cruft.
764- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
765- Moved pg_id to server
766- added Makefile.global and pg_config to devel
767- Corrected /usr/include/pgsql to /usr/include/postgresql
768- Fixed some configure options.  Will be trying the configure macro next release
769- Since it is terminally ill in this version pg_upgrade is _gone_.
770- Thanks to Peter E for a good review.
771
772* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
773- Running regression. 1 on the release-o-meter.
774- Minor patches to get regression running right. 
775- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
776
777* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
778- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
779- The 7.1 build is different from the 7.0 build -- see the configure line.
780- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
781- by request, conditional packages are now supported. See the top of the spec.
782- Fixed the server postinstall problems.
783
784* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
785- First 7.1 beta test-build
786
Note: See TracBrowser for help on using the repository browser.