source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 10083

Revision 10083, 27.4 KB checked in by tomop, 8 years ago (diff)

libpq-9.5.1-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 9.5
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.1
19Release: 1%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: libedit-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160cp -f ./src/backend/utils/fmgroids.h ./src/include/utils/
161make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
162
163# copy over Makefile.global to the include dir....
164install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
165install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
166
167# install missing header
168mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
171install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
176
177# Fix some more documentation
178##gzip doc/internals.ps
179cp %{SOURCE6} README.rpm-dist
180##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
181##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
182
183mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
184install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
185
186
187%find_lang libpq5-%{pgver}
188%find_lang ecpg-%{pgver}
189%find_lang ecpglib%{ecpg_soname}-%{pgver}
190#%find_lang pg_config-%{pgver}
191
192cat libpq5-%{pgver}.lang > libpq.lst
193cat ecpg-%{pgver}.lang >> libpq.lst
194cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
195#cat pg_config-%{pgver}.lang > devel.lst
196
197rm -rf %{buildroot}%{_libdir}/lib*.a
198rm -rf %{buildroot}%{_datadir}/pgsql
199find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
200
201rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
202find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
203
204%post
205/sbin/ldconfig
206
207%postun
208/sbin/ldconfig
209
210
211%clean
212rm -rf $RPM_BUILD_ROOT
213
214
215%files -n libpq%{pq_soname} -f libpq.lst
216%defattr(-,root,root)
217%doc COPYRIGHT HISTORY INSTALL README*
218%{_libdir}/libecpg.so.*
219%{_libdir}/libecpg_compat.so.*
220%{_libdir}/libpgtypes.so.*
221%{_libdir}/libpq.so.*
222
223%files devel -f devel.lst
224%defattr(-,root,root)
225%{_bindir}/ecpg
226%{_bindir}/pg_config
227%{_libdir}/libecpg.so
228%{_libdir}/libecpg_compat.so
229%{_libdir}/libpgtypes.so
230%{_libdir}/libpq.so
231%{_libdir}/pkgconfig/*
232%{_datadir}/locale/*/LC_MESSAGES/*.mo
233%{_mandir}/man1/ecpg.*
234#%{_mandir}/man1/pg_config.*
235
236
237%changelog
238* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.1-1
239- new upstream release.
240
241* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
242- new upstream release.
243
244* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
245- new upstream release.
246
247* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
248- new upstream release.
249
250* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
251- new upstream release.
252
253* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
254- added all headers for a strange client.
255
256* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
257- add pgconfig
258- add pg_config*.h and libpq/libpq-fs.h
259
260* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
261- add postgres_ext.h and pg_config_ext.h
262
263* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
264- new upstream release
265
266* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
267- made to build client libraries only.
268
269* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
270- new upstream release
271
272* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
273- new upstream release
274- add Vendor and Distribution tags
275
276* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
277- build with Tcl/Tk 8.5.7-1
278- fix init script (Source3): fix su(1) paramaters.
279
280* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
281- new upstream release
282- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
283- remove *_and_*.so from -contrib (included in -server)
284
285* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
286- updated postgresql to 9.0.4
287
288* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
289- updated postgresql to 9.0.3
290- separated postgresql-jdbc package
291
292* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
293- updated postgresql to 8.4.7 (contains a variety of fixes)
294
295* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
296- updated postgresql to 8.4.6
297- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
298- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
299- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
300
301* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
302- rebuilt with openssl-1.0.0c
303
304* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
305- updated postgresql to 8.4.5
306
307* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
308- updated postgresql to 8.4.4
309
310* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
311- updated postgresql to 8.4.3
312- s/BuildPrereq/Buildrequires/
313
314* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
315- updated postgresql to 8.4.2
316- rebuilt with new environment
317
318* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
319- updated postgresql to 8.4.1
320
321* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
322- moved dict_snowball.so from conrib to server
323
324* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
325- updated postgresql to 8.4.0
326- updated jdbc3,4 to 701
327- dropt postgresql-8.3.3-nls.patch (fixed)
328- dropt postgresql-7.4-ecpg-patch (no effect)
329
330* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
331- changed libs Group to System Environment/Libraries
332
333* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
334- updated postgresql to 8.3.7
335
336* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
337- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
338
339* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
340- new upstream release (postgresql to 8.3.5, jdbc to 604)
341
342* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
343- applied new versioning policy, and spec in utf-8
344- updated postgresql to 8.3.3
345- updated jdbcver to 603
346- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
347- added a script to replace PGVERSION in postgresql.init
348
349* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
350- rebuild with tcl/tk-8.4.18
351
352* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
353- updated postgresql to 8.2.6
354- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
355
356* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
357- updated PGVERSION to 8.2 in postgresql.init (sorry;)
358
359* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
360- rebuild with tcl/tk-8.4.16
361
362* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
363- updated postgresql to 8.2.5
364- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
365- updated nls-patch to 8-2-0
366- dropt postgresql-8.1.4-Pg.patch.gz
367
368* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
369- for VineSeed
370- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
371- JDBC driver updated to 410
372
373* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
374- rebuilt for VineSeed
375- fixed install script
376
377* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
378- upstream release
379- fix missing %defattr in %files server
380
381* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
382- fix version number in postgresql.init
383
384* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
385- upstream release
386- drop rpm-pgsql-8.0.0.patch
387- add Requires: perl-DBD-Pg for contrib
388- add postgresql-8.1.4-Pg.patch.gz
389- update nls patches
390- new JDBC driver
391
392* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
393- added build options --without perl, --without python
394- rebuilt for x86_64 architecture support
395
396* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
397- drop Provides: on postgresql-libs
398- drop Requires: libpq.so on postgresql-server
399
400* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
401- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
402
403* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
404- upstream release
405- update nls patches
406
407* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
408- upstream release
409- update nls patches
410
411* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
412- rebuilded with python-2.4.1-0vl1
413
414* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
415- Dropped PyGreSQL-3.4.tgz.
416- Dropped PyGreSQL-3.4-setup-2.patch.
417- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
418- Dropped pyver and pynextver macros.
419- Changed macro name "python" to "plpython" like plperl.
420- Added "Obsoletes: postgresql-python"
421
422* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
423- Major version up
424- Obsoletes: postgresql7
425- update nls patch(es)
426- modify %postun not to delete postgres account on upgrade
427
428* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
429- upstream release (release as a new package)
430- Conflicts: postgresql
431- update nls patch(es)
432- (this package revision was rejected by Vine Project)
433
434* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
435- upstream release
436- new JDBC driver
437- add BuildRequires: bison, flex, pam-devel
438- drop postgresql-7.4.5-tempfile.patch (repaired)
439
440* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
441- Added a security fix patch postgresql-7.4.5-tempfile.patch
442  from Gentoo Linux (CAN-2004-0977).
443- Changed Patch4:
444  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
445  It is possible to compile this package without pre-installed postgresql.
446- Removed Patch5 because Patch4 was changed.
447
448* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
449- upstream release
450
451* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
452- upstream release
453- new jdbc driver
454
455* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
456- rebuild with python-2.3.3-0vl1
457
458* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
459- changed mode to 644 at Makefile.global, Makefile.shlib
460
461* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
462- updated python install section
463
464* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
465- added PyGreSQL-3.4.tgz and set python flag
466- added PyGreSQL-3.4-setup.patch
467- added PyGreSQL-3.4-pgmodule.patch
468- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
469
470* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
471- rebuild with new openssl
472
473* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
474- upstream release
475- change all of %{?foo:%define foo 0} -like descriptions to simple
476  %define format for latest rpm to build.
477
478* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
479- rebuild on latest tcl package environment.
480
481* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
482- fixed lacking files at server's %files
483
484* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
485- include JDBC driver for 7.4
486- fix typo in postgresql-7.4-psql-patch
487
488* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
489- upstream release
490- change '--includedir=' option to avoid conflicting with unixODBC
491- add postgresql-7.4-ecpg-patch
492
493* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
494- upstream release
495
496* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
497- drop previous version of libpq's trash
498
499* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
500- upstream release with new nls patch
501- fix postgresql-bashprofile (value of PGDATA)
502- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
503
504* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
505- rebuild with tcltk8.4 and readline-4.3
506
507* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
508- upstream release
509
510* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
511- upstream release
512- remove garbage changelog
513
514* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
515- upstream release based on 7.3-2PGDG
516- add nls patch
517
518* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
519- 7.3-2PGDG
520- Fix typo in initscript.  Argh!!
521
522* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
523- 7.3-0.5PGDG
524- Jerk out all perl client stuff and kludgage
525- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
526- Eliminate locale and multibyte explicit enables -- they are both defaults now
527- Eliminate pgaccess code; it's not a part of the main tarball anymore
528- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
529- Eliminated separate tk client package -- rolled the tk client into the tcl client.
530- Moved pltcl into the pl subpackage.
531- Added plpython to the pl subpackage.
532- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
533
534* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
535- 7.3-0.1PGDG (not released)
536- Integrate 7.3 jar's courtesy Joe Conway
537- Integrate multi-postmaster initscript courtesy Karl DeBisschop
538- Some renames and restructures.
539- Stripped out the last dregs of the postgresql-dump migration script.
540- Conflicts with less than 7.3.
541
542- (See below for old changelogs from VineSeed)
543
544* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
545- updated to 7.2.3.
546
547* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
548- absorbed previous patch8 into original nlspatch
549- fixed configure options (--enable-nls and --enable-locale to be antinomy)
550
551* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
552- add patch8 (ja.po for psql was invalid)
553
554* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
555- updated to 7.2.2.
556- improved nlspatch to enable japanese SQL help in psql.
557
558* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
559- fixed garbage chars in description(ja).
560
561* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
562- imported & replaced changelog (following VineSeed's).
563  add some stuff to '%%files'.
564
565* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
566- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
567  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
568
569* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
570- replace nls patch.
571- add *.mo to '%%files'.
572
573* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
574- fix initscript
575
576* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
577- add /usr/bin/pg_id to the package (fix)
578
579* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
580- updated 7.2
581- added nls.patch
582- fixed spec file
583- added New JDBC
584-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
585
586* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
587- updated 7.1.3
588
589* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
590- 7.1.2-7vl3
591- merge 7.1.2-7vl2 and 7.1.2-7
592
593* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
594- 7.1.2-7vl2
595- fixed spec typo (%%{_includesir} -> %%{_includedir})
596
597* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
598- updated 7.1.2 (used postgresql-7.1.2-7)
599- used psqlj patch for 7.1.2
600- used jumbo-20010801.patch.gz
601
602* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
603- Add patches from 7.1-stable branch. This should fix #50799 and #50797
604- Enable kerberos authentication (#50644)
605- handle stop with stale pid file (#50499)
606- make the test subpackage (not built by default) own /usr/lib/pgsql/test
607
608* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
609- Make the -devel subpackage depend on -libs, not the main package
610
611* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
612- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
613
614* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
615- add changes for s390x
616
617* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
618- Many path fixes for contrib packages
619- Newer intarray
620- Don't use nested ifs for tkpkg/pgaccess
621- Turn off test package for Red Hat Linux - it makes most sense just to use
622  this during development
623- One "pgacess" -> "pgaccess"
624
625* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
626- -4PGDG
627- patchset update for pg_regress.sh
628- can the dot in the release -- confused too many people and some programs.
629- -3.PGDG
630- updated README.rpm-dist
631- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
632  was still being used where /usr/lib/pgsql was intended.
633- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
634
635* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
636- sync
637- Run chkconfig --add on server install
638- Move the prereqs on useradd on chkconfig to the server package
639- don't disable the %%clean section
640
641* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
642- Sync up with Trond Eivind's set.
643
644* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
645- Don't create postgres' .bashrc from the server post script: include it instead
646- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
647- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
648  libs
649- Source the i18n data from the .bashrc instead of in the initscript
650
651* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
652- Handle i18n for database startup - backend needs to have the same locale everytime,
653  but this certainly can't be hardcoded to C either
654- Fix stop, restart in initscript (#42217)
655- Make database init _much_ less verbose
656- other minor fixes to the initscript
657
658* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
659- 7.1.2
660
661* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
662- 7.1.2-0.1.1.PGDG PRERELEASE
663- Changed versioning and release numbering a little for better flexibility,
664-- particularly for distribution packagers.
665- Release numbering comment at top of spec, where it's more useful.
666- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
667  changlog, and the last 6.5.3's specfile for the changelog prior to
668  7.0.
669
670* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
671- 7.1.1-4.PGDG
672- _really_ got Python version agnosticism working.
673
674* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
675- 7.1.1-3.PGDG Release
676- Python version agnosticism.....
677
678* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
679- Use openssl
680- Make it obsolete subpackages if they aren't built
681
682* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
683- 7.1.1-2.PGDG Release.
684- Appended .PGDG to release string to differentiate our RPM set from the others.
685- /bin/sh fix in initscript
686- README.rpm-dist updates.
687
688* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
689- Rebuild with new readline
690
691* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
692- Initial 7.1.1
693
694* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
695- Specify shell when running commands through su in the initscript, to avoid problems
696  when people switch the postgres user to use tcsh
697
698* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
699- JDBC driver for Postgresql 7.1
700
701* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
702- slightly different versioning scheming, will go back to the official
703  later when I'm sure the package is ready to use
704
705* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
706- 7.1 RELEASE
707- 7.1-1 RPM RELEASE
708- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
709- Back to old versioning scheme, kept teg's other fixes.
710- README.rpm-dist updated.
711- PGVERSION updated all-around (hopefully!)
712- Couple of fixes from Peter E.
713- Rearrange dependencies -- only the -libs subpackage is required for most stuff
714- Removed broken and confusing logrotate script.
715
716* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
717- chown considered harmful - removed
718- fix dangling symlimks (pg_crc.c)
719- libpq.so changes for maximum compatiblity
720- different versioning scheme, to avoid trouble later
721- remove temporary perl file from the file list
722- fix spelling error in tcl description
723- mark odbcinst.ini as a config file
724- use %%defattr on packages which didn't have it
725
726* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
727- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
728- Packaging reorg: added contrib and docs subpackages.
729- Removed sgml source docs from main package --> docs subpackage.
730- Removed contrib tree from main package --> contrib subpackage.
731- Contrib tree is now prebuilt -- HOWEVER, very little install work is
732  currently done with this.
733
734* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
735- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
736
737* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
738- RC2
739- eliminate versioning information for ancilliary files in prep for CVS.
740- Fix docs mixup.
741
742* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
743- RC1 quickie.
744
745* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
746- Beta 6 initial build.
747- Use make install-all-headers instead of cpio hack for devel headers.
748- Split out the libs into the libs subpackage.
749- Updated initscript to use pg_ctl to stop
750- Updated initscript to initdb and start postmaster with LC_ALL=C to
751  prevent index corruption.
752
753
754* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
755- Beta4
756- Return to 'pgsql' directories instead of 'postgresql'
757- Better perl patches.
758
759* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
760- Edit patches to get rid of some cruft.
761- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
762- Moved pg_id to server
763- added Makefile.global and pg_config to devel
764- Corrected /usr/include/pgsql to /usr/include/postgresql
765- Fixed some configure options.  Will be trying the configure macro next release
766- Since it is terminally ill in this version pg_upgrade is _gone_.
767- Thanks to Peter E for a good review.
768
769* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
770- Running regression. 1 on the release-o-meter.
771- Minor patches to get regression running right. 
772- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
773
774* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
775- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
776- The 7.1 build is different from the 7.0 build -- see the configure line.
777- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
778- by request, conditional packages are now supported. See the top of the spec.
779- Fixed the server postinstall problems.
780
781* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
782- First 7.1 beta test-build
783
Note: See TracBrowser for help on using the repository browser.