source: projects/specs/trunk/lib/libp/libpng/libpng-vl.spec @ 1851

Revision 1851, 12.2 KB checked in by iwaim, 14 years ago (diff)

build with rpm-4.8.1-1; see [VineSeed:21790]

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.2.44
7Release: 3%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: ftp://ftp.simplesystems.org/pub/libpng/png/src/%{name}-%{version}.tar.bz2
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildPrereq: zlib-devel
13Requires: zlib
14URL: http://www.libpng.org/pub/png/
15%define LIBVER 3.%{version}
16Epoch: 2
17Obsoletes: libpng12
18
19%description
20The libpng package contains a library of functions for creating and
21manipulating PNG (Portable Network Graphics) image format files.  PNG
22is a bit-mapped graphics format similar to the GIF format.  PNG was
23created to replace the GIF format, since GIF uses a patented data
24compression algorithm.
25
26Libpng should be installed if you need to manipulate PNG format image
27files.
28
29%description -l ja
30libpng パッケージには PNG (Portable Network Graphics) 形式の
31画像ファイルを作成/操作する為のライブラリが収められています.
32PNG はビットマップの画像形式で,GIF によく似ています.
33GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
34PNG は GIF の代替画像形式として生まれました.
35
36PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
37
38%package devel
39Summary: Development tools for programs to manipulate PNG image format files.
40Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
41Group: Development/Libraries
42Requires: libpng = %{epoch}:%{version}-%{release}
43Requires: zlib-devel
44Obsoletes: libpng12-devel
45
46%description devel
47The libpng-devel package contains the header files necessary for
48developing programs using the PNG (Portable Network Graphics) library.
49
50%description devel -l ja
51libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
52使ったプログラムを開発するのに必要なヘッダファイルが収められています.
53
54%package static
55Summary: Static library for %{name}
56Summary(ja): %{name} のスタティックライブラリ
57Group: Development/Libraries
58Requires: libpng-devel = %{epoch}:%{version}-%{release}
59
60%description static
61The libpng-static package contains the static library for libpng.
62
63
64## to build compat32 for x86_64 architecture support
65%package -n compat32-%{name}
66Summary: A library of functions for manipulating PNG image format files.
67Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
68Group: System Environment/Libraries
69
70%description -n compat32-%{name}
71The libpng package contains a library of functions for creating and
72manipulating PNG (Portable Network Graphics) image format files.  PNG
73is a bit-mapped graphics format similar to the GIF format.  PNG was
74created to replace the GIF format, since GIF uses a patented data
75compression algorithm.
76
77Libpng should be installed if you need to manipulate PNG format image
78files.
79
80%package -n compat32-%{name}-devel
81Summary: Development tools for programs to manipulate PNG image format files.
82Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
83Group: Development/Libraries
84Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
85Requires: zlib-devel
86
87%description -n compat32-%{name}-devel
88The libpng-devel package contains the header files and static
89libraries necessary for developing programs using the PNG (Portable
90Network Graphics) library.
91
92If you want to develop programs which will manipulate PNG image format
93files, you should install libpng-devel.  You'll also need to install
94the libpng package.
95
96#'
97%prep
98%setup -q
99
100%build
101#./autogen.sh
102%configure
103%__make %{?_smp_mflags}
104
105%install
106[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
107%makeinstall
108
109# remove unneeded files
110%__rm -f %{buildroot}%{_libdir}/libpng*.la
111
112%post -p /sbin/ldconfig
113
114%postun -p /sbin/ldconfig
115
116%post -n compat32-%{name} -p /sbin/ldconfig
117
118%postun -n compat32-%{name} -p /sbin/ldconfig
119
120%clean
121[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
122
123%files
124%defattr(-,root,root)
125%doc *.txt example.c README TODO CHANGES
126%{_libdir}/libpng*.so.*
127%{_mandir}/man5/*
128
129%files devel
130%defattr(-,root,root)
131%{_bindir}/libpng-config
132%{_bindir}/libpng12-config
133%{_includedir}/*
134%{_libdir}/libpng*.so
135%{_libdir}/pkgconfig/*
136%{_mandir}/man3/*
137
138%files static
139%defattr(-,root,root)
140%{_libdir}/libpng*.a
141
142## to build compat32 for x86_64 architecture support
143%if %{build_compat32}
144%files -n compat32-%{name}
145%defattr(-,root,root)
146%{_libdir}/libpng*.so.*
147
148%files -n compat32-%{name}-devel
149%defattr(-,root,root)
150%{_libdir}/libpng*.a
151%{_libdir}/libpng*.so
152%{_libdir}/pkgconfig/*
153%endif
154
155%changelog
156* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
157- build with rpm-4.8.1-1 for pkg-config file
158
159* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
160- sync with Vine Linux 5 updates release
161  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
162  - new upstream release with security fix (CVE-2010-1205)
163
164* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
165- sync with Vine Linux 5 updates release
166  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
167  - new upstream release with security fix (CVE-2010-0205)
168
169* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
170- new upstream release with security fix
171
172* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
173- new upstream release with security fix
174
175* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
176- split static library to libpng-static
177  - needed by tuxonice-userui
178
179* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
180- new upstream release with security fix (CVE-2009-0040)
181
182* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
183- new upstream release
184
185* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
186- spec file in UTF-8
187
188* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
189- new upstream release with security fix (CVE-2008-3964)
190
191* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
192- new upstream release with security fix (CVE-2008-1382)
193- added running autogen.sh before configure
194- new versioning policy
195
196* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
197- new upstream release
198
199* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
200- removed %%if !%%{build_compat32} case condition
201
202* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
203- new upstream release
204
205* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
206- new upstream release
207
208* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
209- new upstream release (CVE-2007-2445)
210
211* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
212- new upstream release
213- drop obsolete patch100
214
215* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
216- add Patch100 for fix CVE-2006-5793.patch
217
218* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
219- [SECURITY] new upstream release
220  - potential buffer overrun in chunk error processing (CVE-2006-3334)
221- use %%configure, %%makeinstall
222- drop unneeded patch10
223
224* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
225- rebuilt with glibc-2.3.3-3vl14
226
227* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
228- fixed libdir path in libpng.pc
229
230* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
231- fixed %postun (missing to build as scriptlet by invalid comment)
232
233* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
234- added compat32-* packages for x86_64 architecture support
235- added CC='gcc -m32' to make when build_compat32
236- added LIBPATH=%{_libdir} to make
237
238* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
239- rebuild
240
241* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
242- rebuild for VineSeed
243
244* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
245- new upstream release (bug fix)
246
247* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
248- new upstream release
249
250* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
251- update to 1.2.6rc3
252- add Requires: zlib-devel to libpng-devel.
253
254* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
255- update to 1.2.6rc2
256
257* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
258- update to 1.2.6rc1
259- add patch10 to correct directory name in libpng.pc
260- clean spec file
261
262* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
263- added Patch4 from Redhat WS updates
264  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
265  - Reinstate and improve the transfix patch which got lost sometime ago,
266    but is still needed for CAN-2002-1363 (#125934)
267
268* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
269- rebuild with new toolchain
270- use License tag
271- change URL
272
273* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
274- added Obsoletes: libpng12-devel for libpng-devel
275
276* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
277- change package name from libpng12 to libpng
278- revised install and files section
279- remove all patches
280- define LIBVER 3.%{version}
281- add Obsoletes: libpng12
282
283* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
284- new upstream version
285- change package name to libpng12
286- conflicts libpng-devel(1.0.5) and libpng12-devel
287
288* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
289- added Patch200 for linking libz shared lib
290- include libpng*-config
291
292* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
293- added missing libraries in the file list
294
295* Thu Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
296- update to 1.0.15
297- now, security patch were merged source.
298
299* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
300- added another security patch to preserve libpng from processing too wide
301  image files (a patch itself extracted from DSA 140-2)
302
303* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
304- added a patch to fix buffer overflow (Patch100)
305
306* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
307- 1.0.12-0vl1
308- updated 1.0.12
309
310* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
311- 1.0.7-0vl3
312- use better macros
313- added Japanese summary and description
314
315* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
316- 1.0.7-0vl2
317- oops, spec was in Shift-JIS... Fixed it.
318
319* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
320- update to 1.0.7
321
322* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
323- update to 1.0.6
324
325* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
326- change serial to Epoch to get dependencies working correctly
327
328* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
329- move buildroot and add URL
330
331* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
332- strip library
333- rebuild to compress man pages
334
335* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
336- 1.0.5
337- some tweaks to spec file to make updating easier
338- handle RPM_OPT_FLAGS
339
340* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
341- changed requires in libpng-devel to include serial
342- corrected typo
343
344* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
345- auto rebuild in the new build environment (release 2)
346
347* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
348- rev to 1.0.3
349
350* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
351- build for 6.0
352
353* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
354- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
355  beta to this prior one
356- install man pages; set defattr defaults
357
358* Thu May 07 1998 Prospector System <bugs@redhat.com>
359- translations modified for de, fr, tr
360
361* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
362- devel subpackage moved to Development/Libraries
363
364* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
365- upgraded to 1.0.1
366- added buildroot
367
368* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
369- updated to new version
370- spec file cleanups
371
372* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
373- built against glibc
374
Note: See TracBrowser for help on using the repository browser.