source: projects/specs/trunk/lib/libp/libpng/libpng-vl.spec @ 12189

Revision 12189, 13.9 KB checked in by tomop, 5 years ago (diff)

updated image libs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.6.37
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: https://download.sourceforge.net/libpng/libpng-%{version}.tar.xz
11
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: zlib-devel
14Requires: zlib
15URL: http://www.libpng.org/pub/png/
16%define LIBVER 3.%{version}
17Epoch: 2
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23The libpng package contains a library of functions for creating and
24manipulating PNG (Portable Network Graphics) image format files.  PNG
25is a bit-mapped graphics format similar to the GIF format.  PNG was
26created to replace the GIF format, since GIF uses a patented data
27compression algorithm.
28
29Libpng should be installed if you need to manipulate PNG format image
30files.
31
32%description -l ja
33libpng パッケージには PNG (Portable Network Graphics) 形式の
34画像ファイルを作成/操作する為のライブラリが収められています.
35PNG はビットマップの画像形式で,GIF によく似ています.
36GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
37PNG は GIF の代替画像形式として生まれました.
38
39PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
40
41%package devel
42Summary: Development tools for programs to manipulate PNG image format files.
43Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
44Group: Development/Libraries
45Requires: libpng = %{epoch}:%{version}-%{release}
46Requires: zlib-devel
47
48%description devel
49The libpng-devel package contains the header files necessary for
50developing programs using the PNG (Portable Network Graphics) library.
51
52%description devel -l ja
53libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
54使ったプログラムを開発するのに必要なヘッダファイルが収められています.
55
56%package static
57Summary: Static library for %{name}
58Summary(ja): %{name} のスタティックライブラリ
59Group: Development/Libraries
60Requires: libpng-devel = %{epoch}:%{version}-%{release}
61
62%description static
63The libpng-static package contains the static library for libpng.
64
65%package tools
66Summary: Tools for PNG image format file library
67Summary(ja): %{name} 用のツール
68Group: Development/Libraries
69Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
70
71%description tools
72The libpng-tools package contains tools used by the authors of libpng.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: A library of functions for manipulating PNG image format files.
77Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
78Group: System Environment/Libraries
79
80%description -n compat32-%{name}
81The libpng package contains a library of functions for creating and
82manipulating PNG (Portable Network Graphics) image format files.  PNG
83is a bit-mapped graphics format similar to the GIF format.  PNG was
84created to replace the GIF format, since GIF uses a patented data
85compression algorithm.
86
87Libpng should be installed if you need to manipulate PNG format image
88files.
89
90%package -n compat32-%{name}-devel
91Summary: Development tools for programs to manipulate PNG image format files.
92Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
93Group: Development/Libraries
94Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
95Requires: zlib-devel
96
97%description -n compat32-%{name}-devel
98The libpng-devel package contains the header files and static
99libraries necessary for developing programs using the PNG (Portable
100Network Graphics) library.
101
102If you want to develop programs which will manipulate PNG image format
103files, you should install libpng-devel.  You'll also need to install
104the libpng package.
105
106#'
107%prep
108%setup -q
109
110%build
111#./autogen.sh
112%configure
113%__make %{?_smp_mflags}
114
115%install
116[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
117%makeinstall
118
119# remove unneeded files
120%__rm -f %{buildroot}%{_libdir}/libpng*.la
121
122%post
123/sbin/ldconfig
124
125%postun
126/sbin/ldconfig
127
128%post -n compat32-%{name}
129/sbin/ldconfig
130
131%postun -n compat32-%{name}
132/sbin/ldconfig
133
134%clean
135[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(-,root,root)
139%license LICENSE
140%doc *.txt example.c README TODO CHANGES
141%{_libdir}/libpng*.so.*
142%{_mandir}/man5/*
143
144%files devel
145%defattr(-,root,root)
146%{_bindir}/libpng-config
147%{_bindir}/libpng16-config
148%{_includedir}/*
149%{_libdir}/libpng*.so
150%{_libdir}/pkgconfig/*
151%{_mandir}/man3/*
152
153%files static
154%defattr(-,root,root)
155%{_libdir}/libpng*.a
156
157%files tools
158%defattr(-,root,root)
159%{_bindir}/pngfix
160%{_bindir}/png-fix-itxt
161
162
163## to build compat32 for x86_64 architecture support
164%if %{build_compat32}
165%files -n compat32-%{name}
166%defattr(-,root,root)
167%{_libdir}/libpng*.so.*
168
169%files -n compat32-%{name}-devel
170%defattr(-,root,root)
171%{_libdir}/libpng*.a
172%{_libdir}/libpng*.so
173%{_libdir}/pkgconfig/*
174%endif
175
176%changelog
177* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2:1.6.37-1
178- updated to 1.6.37.
179
180* Fri Jan 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2:1.6.36-1
181- updated to 1.6.36.
182
183* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2:1.6.34-1
184- updated to 1.6.34.
185
186* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2:1.6.23-1
187- updated to 1.6.23.
188
189* Sun Jan 17 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.6.20-1
190- update to 1.6.20
191
192* Sat Nov 21 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2:1.6.19-2
193- fix typo
194
195* Sat Nov 21 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 2:1.6.19-1
196- update to 1.6.19
197
198* Sat Jun 21 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2:1.6.12-1
199- update to 1.6.12
200- add tools subpackage
201
202* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.50-1
203- new upstream release
204- drop old patches (are included in new release)
205
206* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-3vl6
207- add patch110 for fix CVE-2011-3045
208- add patch120 for fix CVE-2011-3048 (png_set_text2())
209
210* Sat Feb 18 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-2
211- add patch100 for fix CVE-2011-3026
212
213* Wed Jul 13 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-1
214- new upstream release with security fix (VU#819894)
215- add Vendor/Distri tags
216
217* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
218- build with rpm-4.8.1-1 for pkg-config file
219
220* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
221- sync with Vine Linux 5 updates release
222  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
223  - new upstream release with security fix (CVE-2010-1205)
224
225* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
226- sync with Vine Linux 5 updates release
227  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
228  - new upstream release with security fix (CVE-2010-0205)
229
230* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
231- new upstream release with security fix
232
233* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
234- new upstream release with security fix
235
236* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
237- split static library to libpng-static
238  - needed by tuxonice-userui
239
240* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
241- new upstream release with security fix (CVE-2009-0040)
242
243* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
244- new upstream release
245
246* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
247- spec file in UTF-8
248
249* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
250- new upstream release with security fix (CVE-2008-3964)
251
252* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
253- new upstream release with security fix (CVE-2008-1382)
254- added running autogen.sh before configure
255- new versioning policy
256
257* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
258- new upstream release
259
260* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
261- removed %%if !%%{build_compat32} case condition
262
263* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
264- new upstream release
265
266* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
267- new upstream release
268
269* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
270- new upstream release (CVE-2007-2445)
271
272* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
273- new upstream release
274- drop obsolete patch100
275
276* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
277- add Patch100 for fix CVE-2006-5793.patch
278
279* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
280- [SECURITY] new upstream release
281  - potential buffer overrun in chunk error processing (CVE-2006-3334)
282- use %%configure, %%makeinstall
283- drop unneeded patch10
284
285* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
286- rebuilt with glibc-2.3.3-3vl14
287
288* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
289- fixed libdir path in libpng.pc
290
291* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
292- fixed %postun (missing to build as scriptlet by invalid comment)
293
294* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
295- added compat32-* packages for x86_64 architecture support
296- added CC='gcc -m32' to make when build_compat32
297- added LIBPATH=%{_libdir} to make
298
299* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
300- rebuild
301
302* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
303- rebuild for VineSeed
304
305* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
306- new upstream release (bug fix)
307
308* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
309- new upstream release
310
311* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
312- update to 1.2.6rc3
313- add Requires: zlib-devel to libpng-devel.
314
315* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
316- update to 1.2.6rc2
317
318* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
319- update to 1.2.6rc1
320- add patch10 to correct directory name in libpng.pc
321- clean spec file
322
323* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
324- added Patch4 from Redhat WS updates
325  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
326  - Reinstate and improve the transfix patch which got lost sometime ago,
327    but is still needed for CAN-2002-1363 (#125934)
328
329* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
330- rebuild with new toolchain
331- use License tag
332- change URL
333
334* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
335- added Obsoletes: libpng12-devel for libpng-devel
336
337* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
338- change package name from libpng12 to libpng
339- revised install and files section
340- remove all patches
341- define LIBVER 3.%{version}
342- add Obsoletes: libpng12
343
344* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
345- new upstream version
346- change package name to libpng12
347- conflicts libpng-devel(1.0.5) and libpng12-devel
348
349* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
350- added Patch200 for linking libz shared lib
351- include libpng*-config
352
353* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
354- added missing libraries in the file list
355
356* Tue Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
357- update to 1.0.15
358- now, security patch were merged source.
359
360* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
361- added another security patch to preserve libpng from processing too wide
362  image files (a patch itself extracted from DSA 140-2)
363
364* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
365- added a patch to fix buffer overflow (Patch100)
366
367* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
368- 1.0.12-0vl1
369- updated 1.0.12
370
371* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
372- 1.0.7-0vl3
373- use better macros
374- added Japanese summary and description
375
376* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
377- 1.0.7-0vl2
378- oops, spec was in Shift-JIS... Fixed it.
379
380* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
381- update to 1.0.7
382
383* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
384- update to 1.0.6
385
386* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
387- change serial to Epoch to get dependencies working correctly
388
389* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
390- move buildroot and add URL
391
392* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
393- strip library
394- rebuild to compress man pages
395
396* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
397- 1.0.5
398- some tweaks to spec file to make updating easier
399- handle RPM_OPT_FLAGS
400
401* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
402- changed requires in libpng-devel to include serial
403- corrected typo
404
405* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
406- auto rebuild in the new build environment (release 2)
407
408* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
409- rev to 1.0.3
410
411* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
412- build for 6.0
413
414* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
415- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
416  beta to this prior one
417- install man pages; set defattr defaults
418
419* Thu May 07 1998 Prospector System <bugs@redhat.com>
420- translations modified for de, fr, tr
421
422* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
423- devel subpackage moved to Development/Libraries
424
425* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
426- upgraded to 1.0.1
427- added buildroot
428
429* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
430- updated to new version
431- spec file cleanups
432
433* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
434- built against glibc
435
Note: See TracBrowser for help on using the repository browser.