source: projects/specs/trunk/lib/libp/libpng/libpng-vl.spec @ 11264

Revision 11264, 13.7 KB checked in by tomop, 6 years ago (diff)

libpng-1.6.34-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.6.34
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: ftp://ftp.simplesystems.org/pub/libpng/png/src/%{name}-%{version}.tar.xz
11
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: zlib-devel
14Requires: zlib
15URL: http://www.libpng.org/pub/png/
16%define LIBVER 3.%{version}
17Epoch: 2
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23The libpng package contains a library of functions for creating and
24manipulating PNG (Portable Network Graphics) image format files.  PNG
25is a bit-mapped graphics format similar to the GIF format.  PNG was
26created to replace the GIF format, since GIF uses a patented data
27compression algorithm.
28
29Libpng should be installed if you need to manipulate PNG format image
30files.
31
32%description -l ja
33libpng パッケージには PNG (Portable Network Graphics) 形式の
34画像ファイルを作成/操作する為のライブラリが収められています.
35PNG はビットマップの画像形式で,GIF によく似ています.
36GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
37PNG は GIF の代替画像形式として生まれました.
38
39PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
40
41%package devel
42Summary: Development tools for programs to manipulate PNG image format files.
43Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
44Group: Development/Libraries
45Requires: libpng = %{epoch}:%{version}-%{release}
46Requires: zlib-devel
47
48%description devel
49The libpng-devel package contains the header files necessary for
50developing programs using the PNG (Portable Network Graphics) library.
51
52%description devel -l ja
53libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
54使ったプログラムを開発するのに必要なヘッダファイルが収められています.
55
56%package static
57Summary: Static library for %{name}
58Summary(ja): %{name} のスタティックライブラリ
59Group: Development/Libraries
60Requires: libpng-devel = %{epoch}:%{version}-%{release}
61
62%description static
63The libpng-static package contains the static library for libpng.
64
65%package tools
66Summary: Tools for PNG image format file library
67Summary(ja): %{name} 用のツール
68Group: Development/Libraries
69Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
70
71%description tools
72The libpng-tools package contains tools used by the authors of libpng.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: A library of functions for manipulating PNG image format files.
77Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
78Group: System Environment/Libraries
79
80%description -n compat32-%{name}
81The libpng package contains a library of functions for creating and
82manipulating PNG (Portable Network Graphics) image format files.  PNG
83is a bit-mapped graphics format similar to the GIF format.  PNG was
84created to replace the GIF format, since GIF uses a patented data
85compression algorithm.
86
87Libpng should be installed if you need to manipulate PNG format image
88files.
89
90%package -n compat32-%{name}-devel
91Summary: Development tools for programs to manipulate PNG image format files.
92Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
93Group: Development/Libraries
94Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
95Requires: zlib-devel
96
97%description -n compat32-%{name}-devel
98The libpng-devel package contains the header files and static
99libraries necessary for developing programs using the PNG (Portable
100Network Graphics) library.
101
102If you want to develop programs which will manipulate PNG image format
103files, you should install libpng-devel.  You'll also need to install
104the libpng package.
105
106#'
107%prep
108%setup -q
109
110%build
111#./autogen.sh
112%configure
113%__make %{?_smp_mflags}
114
115%install
116[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
117%makeinstall
118
119# remove unneeded files
120%__rm -f %{buildroot}%{_libdir}/libpng*.la
121
122%post
123/sbin/ldconfig
124
125%postun
126/sbin/ldconfig
127
128%post -n compat32-%{name}
129/sbin/ldconfig
130
131%postun -n compat32-%{name}
132/sbin/ldconfig
133
134%clean
135[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(-,root,root)
139%doc *.txt example.c README TODO CHANGES
140%{_libdir}/libpng*.so.*
141%{_mandir}/man5/*
142
143%files devel
144%defattr(-,root,root)
145%{_bindir}/libpng-config
146%{_bindir}/libpng16-config
147%{_includedir}/*
148%{_libdir}/libpng*.so
149%{_libdir}/pkgconfig/*
150%{_mandir}/man3/*
151
152%files static
153%defattr(-,root,root)
154%{_libdir}/libpng*.a
155
156%files tools
157%defattr(-,root,root)
158%{_bindir}/pngfix
159%{_bindir}/png-fix-itxt
160
161
162## to build compat32 for x86_64 architecture support
163%if %{build_compat32}
164%files -n compat32-%{name}
165%defattr(-,root,root)
166%{_libdir}/libpng*.so.*
167
168%files -n compat32-%{name}-devel
169%defattr(-,root,root)
170%{_libdir}/libpng*.a
171%{_libdir}/libpng*.so
172%{_libdir}/pkgconfig/*
173%endif
174
175%changelog
176* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2:1.6.34-1
177- updated to 1.6.34.
178
179* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2:1.6.23-1
180- updated to 1.6.23.
181
182* Sun Jan 17 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.6.20-1
183- update to 1.6.20
184
185* Sat Nov 21 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2:1.6.19-2
186- fix typo
187
188* Sat Nov 21 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 2:1.6.19-1
189- update to 1.6.19
190
191* Sat Jun 21 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2:1.6.12-1
192- update to 1.6.12
193- add tools subpackage
194
195* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.50-1
196- new upstream release
197- drop old patches (are included in new release)
198
199* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-3vl6
200- add patch110 for fix CVE-2011-3045
201- add patch120 for fix CVE-2011-3048 (png_set_text2())
202
203* Sat Feb 18 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-2
204- add patch100 for fix CVE-2011-3026
205
206* Wed Jul 13 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-1
207- new upstream release with security fix (VU#819894)
208- add Vendor/Distri tags
209
210* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
211- build with rpm-4.8.1-1 for pkg-config file
212
213* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
214- sync with Vine Linux 5 updates release
215  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
216  - new upstream release with security fix (CVE-2010-1205)
217
218* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
219- sync with Vine Linux 5 updates release
220  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
221  - new upstream release with security fix (CVE-2010-0205)
222
223* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
224- new upstream release with security fix
225
226* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
227- new upstream release with security fix
228
229* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
230- split static library to libpng-static
231  - needed by tuxonice-userui
232
233* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
234- new upstream release with security fix (CVE-2009-0040)
235
236* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
237- new upstream release
238
239* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
240- spec file in UTF-8
241
242* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
243- new upstream release with security fix (CVE-2008-3964)
244
245* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
246- new upstream release with security fix (CVE-2008-1382)
247- added running autogen.sh before configure
248- new versioning policy
249
250* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
251- new upstream release
252
253* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
254- removed %%if !%%{build_compat32} case condition
255
256* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
257- new upstream release
258
259* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
260- new upstream release
261
262* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
263- new upstream release (CVE-2007-2445)
264
265* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
266- new upstream release
267- drop obsolete patch100
268
269* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
270- add Patch100 for fix CVE-2006-5793.patch
271
272* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
273- [SECURITY] new upstream release
274  - potential buffer overrun in chunk error processing (CVE-2006-3334)
275- use %%configure, %%makeinstall
276- drop unneeded patch10
277
278* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
279- rebuilt with glibc-2.3.3-3vl14
280
281* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
282- fixed libdir path in libpng.pc
283
284* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
285- fixed %postun (missing to build as scriptlet by invalid comment)
286
287* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
288- added compat32-* packages for x86_64 architecture support
289- added CC='gcc -m32' to make when build_compat32
290- added LIBPATH=%{_libdir} to make
291
292* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
293- rebuild
294
295* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
296- rebuild for VineSeed
297
298* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
299- new upstream release (bug fix)
300
301* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
302- new upstream release
303
304* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
305- update to 1.2.6rc3
306- add Requires: zlib-devel to libpng-devel.
307
308* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
309- update to 1.2.6rc2
310
311* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
312- update to 1.2.6rc1
313- add patch10 to correct directory name in libpng.pc
314- clean spec file
315
316* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
317- added Patch4 from Redhat WS updates
318  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
319  - Reinstate and improve the transfix patch which got lost sometime ago,
320    but is still needed for CAN-2002-1363 (#125934)
321
322* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
323- rebuild with new toolchain
324- use License tag
325- change URL
326
327* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
328- added Obsoletes: libpng12-devel for libpng-devel
329
330* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
331- change package name from libpng12 to libpng
332- revised install and files section
333- remove all patches
334- define LIBVER 3.%{version}
335- add Obsoletes: libpng12
336
337* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
338- new upstream version
339- change package name to libpng12
340- conflicts libpng-devel(1.0.5) and libpng12-devel
341
342* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
343- added Patch200 for linking libz shared lib
344- include libpng*-config
345
346* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
347- added missing libraries in the file list
348
349* Tue Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
350- update to 1.0.15
351- now, security patch were merged source.
352
353* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
354- added another security patch to preserve libpng from processing too wide
355  image files (a patch itself extracted from DSA 140-2)
356
357* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
358- added a patch to fix buffer overflow (Patch100)
359
360* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
361- 1.0.12-0vl1
362- updated 1.0.12
363
364* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
365- 1.0.7-0vl3
366- use better macros
367- added Japanese summary and description
368
369* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
370- 1.0.7-0vl2
371- oops, spec was in Shift-JIS... Fixed it.
372
373* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
374- update to 1.0.7
375
376* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
377- update to 1.0.6
378
379* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
380- change serial to Epoch to get dependencies working correctly
381
382* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
383- move buildroot and add URL
384
385* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
386- strip library
387- rebuild to compress man pages
388
389* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
390- 1.0.5
391- some tweaks to spec file to make updating easier
392- handle RPM_OPT_FLAGS
393
394* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
395- changed requires in libpng-devel to include serial
396- corrected typo
397
398* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
399- auto rebuild in the new build environment (release 2)
400
401* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
402- rev to 1.0.3
403
404* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
405- build for 6.0
406
407* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
408- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
409  beta to this prior one
410- install man pages; set defattr defaults
411
412* Thu May 07 1998 Prospector System <bugs@redhat.com>
413- translations modified for de, fr, tr
414
415* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
416- devel subpackage moved to Development/Libraries
417
418* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
419- upgraded to 1.0.1
420- added buildroot
421
422* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
423- updated to new version
424- spec file cleanups
425
426* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
427- built against glibc
428
Note: See TracBrowser for help on using the repository browser.