source: projects/specs/trunk/lib/libp/libpfm/libpfm-vl.spec @ 9342

Revision 9342, 5.2 KB checked in by inagaki, 9 years ago (diff)

2015-02-08 Ryoichi INAGAKI <ryo1@…>

  • libpfm, papi: new package


Line 
1%bcond_without python
2%if %{with python}
3%define python_sitearch %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4%define python_prefix %(python -c "import sys; print sys.prefix")
5%{?filter_setup:
6%filter_provides_in %{python_sitearch}/perfmon/.*\.so$
7%filter_setup
8}
9%endif
10
11Name:           libpfm
12Version:        4.5.0
13Release:        6%{?_dist_release}
14
15Summary:        Library to encode performance events for use by perf tool
16Summary(ja):    プロファイラが用いるパフォーマンスイベントをエンコードするライブラリ
17
18Group:          System Environment/Libraries
19License:        MIT
20URL:            http://perfmon2.sourceforge.net/
21Source0:        http://sourceforge.net/projects/perfmon2/files/libpfm4/%{name}-%{version}.tar.gz
22Patch12:        libpfm-ac57.patch
23Patch13:        libpfm-ac53.patch
24
25%if %{with python}
26BuildRequires:  python-devel
27BuildRequires:  python-setuptools
28BuildRequires:  swig
29%endif
30
31%description
32libpfm4 is a library to help encode events for use with operating system
33kernels performance monitoring interfaces. The current version provides support
34for the perf_events interface available in upstream Linux kernels since v2.6.31.
35
36%package devel
37Summary:        Development library to encode performance events for perf_events based tools
38Summary(ja):    パフォーマンスイベントをエンコードするための開発用ライブラリ
39Group:          Development/Libraries
40Requires:       %{name} = %{version}-%{release}
41
42%description devel
43Development library and header files to create performance monitoring
44applications for the perf_events interface.
45
46%package static
47Summary:        Static library to encode performance events for perf_events based tools
48Summary(ja):    パフォーマンスイベントをエンコードするための静的ライブラリ
49Group:          Development/Libraries
50Requires:       %{name}-devel = %{version}-%{release}
51
52%description static
53Static version of the libpfm library for performance monitoring
54applications for the perf_events interface.
55
56%if %{with python}
57%package python
58Summary:        Python bindings for libpfm and perf_event_open system call
59Group:          Development/Libraries
60Requires:       %{name} = %{version}-%{release}
61
62%description python
63Python bindings for libpfm4 and perf_event_open system call.
64%endif
65
66%prep
67%setup -q
68
69%patch12 -p1
70%patch13 -p1
71
72%build
73%if %{with python}
74%global python_config CONFIG_PFMLIB_NOPYTHON=n
75%else
76%global python_config CONFIG_PFMLIB_NOPYTHON=y
77%endif
78make %{python_config} %{?_smp_mflags}
79
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84%if %{with python}
85%global python_config CONFIG_PFMLIB_NOPYTHON=n PYTHON_PREFIX=$RPM_BUILD_ROOT/%{python_prefix}
86%else
87%global python_config CONFIG_PFMLIB_NOPYTHON=y
88%endif
89
90make \
91    PREFIX=$RPM_BUILD_ROOT%{_prefix} \
92    LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
93    %{python_config} \
94    LDCONFIG=/bin/true \
95    install
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101%postun -p /sbin/ldconfig
102
103
104%files
105%doc README
106%{_libdir}/lib*.so.*
107
108%files devel
109%{_includedir}/*
110%{_mandir}/man3/*
111%{_libdir}/lib*.so
112
113%files static
114%{_libdir}/lib*.a
115
116%if %{with python}
117%files python
118%{python_sitearch}/*
119%endif
120
121%changelog
122* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.5.0-6
123- initial build for Vine Linux
124
125* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.0-5
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
127
128* Mon Jun 30 2014 Toshio Kuratomi <toshio@fedoraproject.org> - 4.5.0-4
129- Replace python-setuptools-devel BR with python-setuptools
130
131* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.0-3
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
133
134* Fri May 23 2014 William Cohen <wcohen@redhat.com> 4.5.0-2
135- Add cortex a53 support.
136
137* Fri May 23 2014 William Cohen <wcohen@redhat.com> 4.5.0-1
138- Rebase on libpfm-4.5.0.
139
140* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-3
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
142
143* Fri Jul 19 2013 William Cohen <wcohen@redhat.com> 4.4.0-2
144- Add IBM power 8 support.
145
146* Mon Jun 17 2013 William Cohen <wcohen@redhat.com> 4.4.0-1
147- Rebase on libpfm-4.4.0.
148
149* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3.0-3
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
151
152* Tue Aug 28 2012 William Cohen <wcohen@redhat.com> 4.3.0-2
153- Turn off LDCONFIG and remove patch.
154
155* Tue Aug 28 2012 William Cohen <wcohen@redhat.com> 4.3.0-1
156- Rebase on libpfm-4.3.0.
157
158* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
160
161* Fri Jun 8 2012 William Cohen <wcohen@redhat.com> 4.2.0-7
162- Eliminate swig error.
163
164* Thu Jun 7 2012 William Cohen <wcohen@redhat.com> 4.2.0-6
165- Eliminate rpm_build_root macro in build section.
166- Correct location of shared library files.
167
168* Thu Jun 7 2012 William Cohen <wcohen@redhat.com> 4.2.0-5
169- Use siginfo_t for some examples.
170
171* Mon Jun 4 2012 William Cohen <wcohen@redhat.com> 4.2.0-4
172- Correct python files.
173
174* Wed Mar 28 2012 William Cohen <wcohen@redhat.com> 4.2.0-3
175- Additional spec file fixup for rhbz804666.
176
177* Wed Mar 14 2012 William Cohen <wcohen@redhat.com> 4.2.0-2
178- Some spec file fixup.
179
180* Wed Jan 12 2011 Arun Sharma <asharma@fb.com> 4.2.0-0
181Initial revision
Note: See TracBrowser for help on using the repository browser.