source: projects/specs/trunk/lib/libp/libpeas/libpeas-vl.spec @ 8912

Revision 8912, 6.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1Name:           libpeas
2Version:        1.10.1
3Release:        1%{?_dist_release}
4Summary:        Plug-ins implementation convenience library
5
6Group:          System Environment/Libraries
7License:        LGPLv2+
8URL:            http://ftp.acc.umu.se/pub/GNOME/sources/libpeas/
9Source0:        http://ftp.acc.umu.se/pub/GNOME/sources/%{name}/1.10/%{name}-%{version}.tar.xz
10
11BuildRequires:  gtk3-devel >= 2.99.3
12BuildRequires:  pygobject3-devel
13BuildRequires:  python-devel
14BuildRequires:  gjs-devel
15BuildRequires:  seed-devel
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  intltool
18BuildRequires:  libtool
19
20# For the girepository-1.0 directory
21Requires:       gobject-introspection
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27libpeas is a convenience library making adding plug-ins support
28to GTK+ and glib-based applications.
29
30%package devel
31Summary:        Development files for libpeas
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       gtk-doc
35Requires:       gobject-introspection-devel
36
37%description devel
38This package contains development libraries and header files
39that are needed to write applications that use libpeas.
40
41%prep
42%setup -q
43
44%build
45%configure --disable-static
46
47# FIXME rpath disabling is disabled because it breaks the creation of the GIR files
48# Remove rpath as per https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
49#sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
50#sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
51
52make %{?_smp_mflags}
53
54%install
55make install DESTDIR=$RPM_BUILD_ROOT
56
57rm $RPM_BUILD_ROOT/%{_libdir}/lib*.la   \
58        $RPM_BUILD_ROOT/%{_libdir}/libpeas-1.0/loaders/lib*.la
59
60%find_lang libpeas
61
62%post
63/sbin/ldconfig
64touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
65
66%postun
67/sbin/ldconfig
68if [ $1 -eq 0 ]; then
69  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
70  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
71fi
72
73%posttrans
74gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
75
76%files -f libpeas.lang
77%defattr(-,root,root,-)
78%doc AUTHORS
79%{_libdir}/libpeas*-1.0.so.*
80%dir %{_libdir}/libpeas-1.0/
81%dir %{_libdir}/libpeas-1.0/loaders
82%{_libdir}/libpeas-1.0/loaders/libpythonloader.so
83%{_libdir}/libpeas-1.0/loaders/libseedloader.so
84%{_libdir}/girepository-1.0/*.typelib
85%{_datadir}/icons/hicolor/*/actions/libpeas-plugin.*
86
87%files devel
88%defattr(-,root,root,-)
89%{_bindir}/peas-demo
90%{_includedir}/libpeas-1.0/
91%{_libdir}/peas-demo/
92%{_datadir}/gtk-doc/html/libpeas/
93%{_libdir}/libpeas*-1.0.so
94%{_datadir}/gir-1.0/*.gir
95%{_libdir}/pkgconfig/*.pc
96
97%changelog
98* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
99- new upstream release
100
101* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
102- new upstream release
103- remove Patch0 (libpeas-1.8.1-gjs-1.36.x.patch)
104- remove Patch1 (libpeas-1.8.1-gjs-plugin-loader.patch)
105
106* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
107- rebuild with VineSeed environment
108- add Patch0 (libpeas-1.8.1-gjs-1.36.x.patch)
109- add Patch1 (libpeas-1.8.1-gjs-plugin-loader.patch)
110
111* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
112- new upstream release
113
114* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
115- new upstream release
116
117* Thu Jan 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
118- new upstream release
119
120* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
121- new upstream release
122
123* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
124- new upstream release
125
126* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
127- new upstream release
128
129* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
130- rebuild with python-2.7.2
131
132* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
133- new upstream release
134
135* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
136- new upstream release
137- add BuildRequires: gjs-devel
138
139* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
140- new upstream release
141- change BuildRequires: pygobject3-devel instead of pygobject-devel
142
143* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
144- initial build for Vine Linux
145
146
147* Mon Apr  4 2011 Christopher Aillon <caillon@redhat.com> 1.0.0-1
148- Update to 1.0.0
149
150* Sun Mar 27 2011 Bastien Nocera <bnocera@redhat.com> 0.9.0-1
151- Update to 0.9.0
152
153* Thu Mar 10 2011 Bastien Nocera <bnocera@redhat.com> 0.7.4-1
154- Update to 0.7.4
155
156* Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> 0.7.3-1
157- Update to 0.7.3
158- Drop unneeded dependencies
159
160* Mon Feb 21 2011 Bastien Nocera <bnocera@redhat.com> 0.7.2-1
161- Update to 0.7.2
162
163* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-7
164- Rebuild
165
166* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-6
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
168
169* Wed Feb  2 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-5
170- Rebuild against newer gtk
171
172* Fri Jan 28 2011 Bastien Nocera <bnocera@redhat.com> 0.7.1-4
173- Update to real 0.7.1 release
174
175* Fri Jan  7 2011 Matthias Clasen <mclasen@redhat.com> - 0.7.1-3.gita2f98e
176- Rebuild against newer gtk
177
178* Fri Dec  3 2010 Matthias Clasen <mclasen@redhat.com> - 0.7.1-2.gita2f98e
179- Rebuild against newer gtk
180
181* Thu Nov 11 2010 Dan Williams <dcbw@redhat.com> - 0.7.1-1.gita2f98e
182- Update to 0.7.1
183- Fix some crashes with missing introspection data
184
185* Mon Nov  1 2010 Matthias Clasen <mclasen@redhat.com> 0.7.0-2
186- Rebuild against newer gtk3
187
188* Mon Oct 04 2010 Bastien Nocera <bnocera@redhat.com> 0.7.0-1
189- Update to 0.7.0
190
191* Tue Sep 21 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-2
192- Rebuild against newer gobject-introspection
193
194* Thu Aug 19 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-1
195- Update to 0.5.5
196
197* Thu Aug  5 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.4-1
198- Update to 0.5.4
199
200* Tue Jul 27 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 0.5.3-2
201- Rebuild against python 2.7
202
203* Fri Jul 23 2010 Bastien Nocera <bnocera@redhat.com> 0.5.3-1
204- Update to 0.5.3
205
206* Thu Jul 22 2010 Bastien Nocera <bnocera@redhat.com> 0.5.2-5
207- Fix post scriplet (#615021)
208
209* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 0.5.2-4
210- Rebuild with new gobject-introspection
211
212* Tue Jul 13 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-3
213- Rebuild
214
215* Mon Jul 12 2010 Colin Walters <walters@verbum.org> - 0.5.2-2
216- Rebuild against new gobject-introspection
217
218* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-1
219- Update to 0.5.2
220
221* Thu Jul  8 2010 Matthias Clasen <mclasen@redhat.com> 0.5.1-2
222- Rebuild
223
224* Mon Jun 28 2010 Bastien Nocera <bnocera@redhat.com> 0.5.1-1
225- Update to 0.5.1
226
227* Thu Jun 24 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-4
228- Document rpath work-arounds disabling, and remove verbose build
229
230* Fri Jun 18 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-3
231- Fix a number of comments from review request
232
233* Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-2
234- Call ldconfig when installing the package
235
236* Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-1
237- First package
238
Note: See TracBrowser for help on using the repository browser.