source: projects/specs/trunk/lib/libp/libpeas/libpeas-vl.spec @ 7294

Revision 7294, 6.3 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.9.5

Line 
1Name:           libpeas
2Version:        1.6.2
3Release:        1%{?_dist_release}
4Summary:        Plug-ins implementation convenience library
5
6Group:          System Environment/Libraries
7License:        LGPLv2+
8URL:            http://ftp.acc.umu.se/pub/GNOME/sources/libpeas/
9Source0:        http://ftp.acc.umu.se/pub/GNOME/sources/%{name}/1.6/%{name}-%{version}.tar.xz
10
11BuildRequires:  gtk3-devel >= 2.99.3
12BuildRequires:  pygobject3-devel
13BuildRequires:  python-devel
14BuildRequires:  gjs-devel
15BuildRequires:  seed-devel
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  intltool
18BuildRequires:  libtool
19
20# For the girepository-1.0 directory
21Requires:       gobject-introspection
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27libpeas is a convenience library making adding plug-ins support
28to GTK+ and glib-based applications.
29
30%package devel
31Summary:        Development files for libpeas
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       gtk-doc
35Requires:       gobject-introspection-devel
36
37%description devel
38This package contains development libraries and header files
39that are needed to write applications that use libpeas.
40
41%prep
42%setup -q
43
44%build
45%configure --disable-static
46
47# FIXME rpath disabling is disabled because it breaks the creation of the GIR files
48# Remove rpath as per https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
49#sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
50#sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
51
52make %{?_smp_mflags}
53
54%install
55make install DESTDIR=$RPM_BUILD_ROOT
56
57rm $RPM_BUILD_ROOT/%{_libdir}/lib*.la   \
58        $RPM_BUILD_ROOT/%{_libdir}/libpeas-1.0/loaders/lib*.la
59
60%find_lang libpeas
61
62%post
63/sbin/ldconfig
64touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
65
66%postun
67/sbin/ldconfig
68if [ $1 -eq 0 ]; then
69  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
70  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
71fi
72
73%posttrans
74gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
75
76%files -f libpeas.lang
77%defattr(-,root,root,-)
78%doc AUTHORS
79%{_libdir}/libpeas*-1.0.so.*
80%dir %{_libdir}/libpeas-1.0/
81%dir %{_libdir}/libpeas-1.0/loaders
82%{_libdir}/libpeas-1.0/loaders/libgjsloader.so
83%{_libdir}/libpeas-1.0/loaders/libpythonloader.so
84%{_libdir}/libpeas-1.0/loaders/libseedloader.so
85%{_libdir}/girepository-1.0/*.typelib
86%{_datadir}/icons/hicolor/*/actions/libpeas-plugin.*
87
88%files devel
89%defattr(-,root,root,-)
90%{_bindir}/peas-demo
91%{_includedir}/libpeas-1.0/
92%{_libdir}/peas-demo/
93%{_datadir}/gtk-doc/html/libpeas/
94%{_libdir}/libpeas*-1.0.so
95%{_datadir}/gir-1.0/*.gir
96%{_libdir}/pkgconfig/*.pc
97
98%changelog
99* Thu Jan 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
100- new upstream release
101
102* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
103- new upstream release
104
105* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
106- new upstream release
107
108* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
109- new upstream release
110
111* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
112- rebuild with python-2.7.2
113
114* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
115- new upstream release
116
117* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
118- new upstream release
119- add BuildRequires: gjs-devel
120
121* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
122- new upstream release
123- change BuildRequires: pygobject3-devel instead of pygobject-devel
124
125* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
126- initial build for Vine Linux
127
128
129* Mon Apr  4 2011 Christopher Aillon <caillon@redhat.com> 1.0.0-1
130- Update to 1.0.0
131
132* Sun Mar 27 2011 Bastien Nocera <bnocera@redhat.com> 0.9.0-1
133- Update to 0.9.0
134
135* Thu Mar 10 2011 Bastien Nocera <bnocera@redhat.com> 0.7.4-1
136- Update to 0.7.4
137
138* Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> 0.7.3-1
139- Update to 0.7.3
140- Drop unneeded dependencies
141
142* Mon Feb 21 2011 Bastien Nocera <bnocera@redhat.com> 0.7.2-1
143- Update to 0.7.2
144
145* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-7
146- Rebuild
147
148* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-6
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
150
151* Wed Feb  2 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-5
152- Rebuild against newer gtk
153
154* Fri Jan 28 2011 Bastien Nocera <bnocera@redhat.com> 0.7.1-4
155- Update to real 0.7.1 release
156
157* Fri Jan  7 2011 Matthias Clasen <mclasen@redhat.com> - 0.7.1-3.gita2f98e
158- Rebuild against newer gtk
159
160* Fri Dec  3 2010 Matthias Clasen <mclasen@redhat.com> - 0.7.1-2.gita2f98e
161- Rebuild against newer gtk
162
163* Thu Nov 11 2010 Dan Williams <dcbw@redhat.com> - 0.7.1-1.gita2f98e
164- Update to 0.7.1
165- Fix some crashes with missing introspection data
166
167* Mon Nov  1 2010 Matthias Clasen <mclasen@redhat.com> 0.7.0-2
168- Rebuild against newer gtk3
169
170* Mon Oct 04 2010 Bastien Nocera <bnocera@redhat.com> 0.7.0-1
171- Update to 0.7.0
172
173* Tue Sep 21 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-2
174- Rebuild against newer gobject-introspection
175
176* Thu Aug 19 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-1
177- Update to 0.5.5
178
179* Thu Aug  5 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.4-1
180- Update to 0.5.4
181
182* Tue Jul 27 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 0.5.3-2
183- Rebuild against python 2.7
184
185* Fri Jul 23 2010 Bastien Nocera <bnocera@redhat.com> 0.5.3-1
186- Update to 0.5.3
187
188* Thu Jul 22 2010 Bastien Nocera <bnocera@redhat.com> 0.5.2-5
189- Fix post scriplet (#615021)
190
191* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 0.5.2-4
192- Rebuild with new gobject-introspection
193
194* Tue Jul 13 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-3
195- Rebuild
196
197* Mon Jul 12 2010 Colin Walters <walters@verbum.org> - 0.5.2-2
198- Rebuild against new gobject-introspection
199
200* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-1
201- Update to 0.5.2
202
203* Thu Jul  8 2010 Matthias Clasen <mclasen@redhat.com> 0.5.1-2
204- Rebuild
205
206* Mon Jun 28 2010 Bastien Nocera <bnocera@redhat.com> 0.5.1-1
207- Update to 0.5.1
208
209* Thu Jun 24 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-4
210- Document rpath work-arounds disabling, and remove verbose build
211
212* Fri Jun 18 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-3
213- Fix a number of comments from review request
214
215* Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-2
216- Call ldconfig when installing the package
217
218* Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-1
219- First package
220
Note: See TracBrowser for help on using the repository browser.