source: projects/specs/trunk/lib/libp/libpeas/libpeas-vl.spec @ 4850

Revision 4850, 5.9 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

Line 
1Name:           libpeas
2Version:        1.2.0
3Release:        1%{?_dist_release}
4Summary:        Plug-ins implementation convenience library
5
6Group:          System Environment/Libraries
7License:        LGPLv2+
8URL:            http://ftp.acc.umu.se/pub/GNOME/sources/libpeas/
9Source0:        http://ftp.acc.umu.se/pub/GNOME/sources/%{name}/1.2/%{name}-%{version}.tar.xz
10
11BuildRequires:  gtk3-devel >= 2.99.3
12BuildRequires:  pygobject3-devel
13BuildRequires:  python-devel
14BuildRequires:  seed-devel
15BuildRequires:  gjs-devel
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  intltool
18BuildRequires:  libtool
19
20# For the girepository-1.0 directory
21Requires:       gobject-introspection
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27libpeas is a convenience library making adding plug-ins support
28to GTK+ and glib-based applications.
29
30%package devel
31Summary:        Development files for libpeas
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       gtk-doc
35Requires:       gobject-introspection-devel
36
37%description devel
38This package contains development libraries and header files
39that are needed to write applications that use libpeas.
40
41%prep
42%setup -q
43
44%build
45%configure --disable-static
46
47# FIXME rpath disabling is disabled because it breaks the creation of the GIR files
48# Remove rpath as per https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
49#sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
50#sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
51
52make %{?_smp_mflags}
53
54%install
55make install DESTDIR=$RPM_BUILD_ROOT
56
57rm $RPM_BUILD_ROOT/%{_libdir}/lib*.la   \
58        $RPM_BUILD_ROOT/%{_libdir}/libpeas-1.0/loaders/lib*.la
59
60%find_lang libpeas
61
62%post
63/sbin/ldconfig
64touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
65
66%postun
67/sbin/ldconfig
68if [ $1 -eq 0 ]; then
69  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
70  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
71fi
72
73%posttrans
74gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
75
76%files -f libpeas.lang
77%defattr(-,root,root,-)
78%doc AUTHORS
79%{_libdir}/libpeas*-1.0.so.*
80%dir %{_libdir}/libpeas-1.0/
81%dir %{_libdir}/libpeas-1.0/loaders
82%{_libdir}/libpeas-1.0/loaders/libcloader.so
83%{_libdir}/libpeas-1.0/loaders/libgjsloader.so
84%{_libdir}/libpeas-1.0/loaders/libpythonloader.so
85%{_libdir}/libpeas-1.0/loaders/libseedloader.so
86%{_libdir}/girepository-1.0/*.typelib
87%{_datadir}/icons/hicolor/*/actions/libpeas-plugin.*
88
89%files devel
90%defattr(-,root,root,-)
91%{_bindir}/peas-demo
92%{_includedir}/libpeas-1.0/
93%{_libdir}/peas-demo/
94%{_datadir}/gtk-doc/html/libpeas/
95%{_libdir}/libpeas*-1.0.so
96%{_datadir}/gir-1.0/*.gir
97%{_libdir}/pkgconfig/*.pc
98
99%changelog
100* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
101- new upstream release
102
103* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
104- new upstream release
105- add BuildRequires: gjs-devel
106
107* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
108- new upstream release
109- change BuildRequires: pygobject3-devel instead of pygobject-devel
110
111* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
112- initial build for Vine Linux
113
114
115* Mon Apr  4 2011 Christopher Aillon <caillon@redhat.com> 1.0.0-1
116- Update to 1.0.0
117
118* Sun Mar 27 2011 Bastien Nocera <bnocera@redhat.com> 0.9.0-1
119- Update to 0.9.0
120
121* Thu Mar 10 2011 Bastien Nocera <bnocera@redhat.com> 0.7.4-1
122- Update to 0.7.4
123
124* Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> 0.7.3-1
125- Update to 0.7.3
126- Drop unneeded dependencies
127
128* Mon Feb 21 2011 Bastien Nocera <bnocera@redhat.com> 0.7.2-1
129- Update to 0.7.2
130
131* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-7
132- Rebuild
133
134* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-6
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
136
137* Wed Feb  2 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-5
138- Rebuild against newer gtk
139
140* Fri Jan 28 2011 Bastien Nocera <bnocera@redhat.com> 0.7.1-4
141- Update to real 0.7.1 release
142
143* Fri Jan  7 2011 Matthias Clasen <mclasen@redhat.com> - 0.7.1-3.gita2f98e
144- Rebuild against newer gtk
145
146* Fri Dec  3 2010 Matthias Clasen <mclasen@redhat.com> - 0.7.1-2.gita2f98e
147- Rebuild against newer gtk
148
149* Thu Nov 11 2010 Dan Williams <dcbw@redhat.com> - 0.7.1-1.gita2f98e
150- Update to 0.7.1
151- Fix some crashes with missing introspection data
152
153* Mon Nov  1 2010 Matthias Clasen <mclasen@redhat.com> 0.7.0-2
154- Rebuild against newer gtk3
155
156* Mon Oct 04 2010 Bastien Nocera <bnocera@redhat.com> 0.7.0-1
157- Update to 0.7.0
158
159* Tue Sep 21 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-2
160- Rebuild against newer gobject-introspection
161
162* Thu Aug 19 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-1
163- Update to 0.5.5
164
165* Thu Aug  5 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.4-1
166- Update to 0.5.4
167
168* Tue Jul 27 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 0.5.3-2
169- Rebuild against python 2.7
170
171* Fri Jul 23 2010 Bastien Nocera <bnocera@redhat.com> 0.5.3-1
172- Update to 0.5.3
173
174* Thu Jul 22 2010 Bastien Nocera <bnocera@redhat.com> 0.5.2-5
175- Fix post scriplet (#615021)
176
177* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 0.5.2-4
178- Rebuild with new gobject-introspection
179
180* Tue Jul 13 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-3
181- Rebuild
182
183* Mon Jul 12 2010 Colin Walters <walters@verbum.org> - 0.5.2-2
184- Rebuild against new gobject-introspection
185
186* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-1
187- Update to 0.5.2
188
189* Thu Jul  8 2010 Matthias Clasen <mclasen@redhat.com> 0.5.1-2
190- Rebuild
191
192* Mon Jun 28 2010 Bastien Nocera <bnocera@redhat.com> 0.5.1-1
193- Update to 0.5.1
194
195* Thu Jun 24 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-4
196- Document rpath work-arounds disabling, and remove verbose build
197
198* Fri Jun 18 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-3
199- Fix a number of comments from review request
200
201* Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-2
202- Call ldconfig when installing the package
203
204* Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-1
205- First package
206
Note: See TracBrowser for help on using the repository browser.