source: projects/specs/trunk/lib/libp/libpeas/libpeas-vl.spec @ 12469

Revision 12469, 7.7 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

RevLine 
[12469]1Summary:        Plug-ins implementation convenience library
[4616]2Name:           libpeas
[12396]3Version:        1.26.0
[12469]4Release:        2%{?_dist_release}
5Group:          system
[12396]6Vendor:         Project Vine
7Distribution:   Vine Linux
[4616]8
9License:        LGPLv2+
[12396]10URL:            https://gitlab.gnome.org/GNOME/libpeas/
11%global         shortver %(echo %{version} | cut -d . -f 1,2)
12Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
[4616]13
14BuildRequires:  gtk3-devel >= 2.99.3
[4704]15BuildRequires:  pygobject3-devel
[9475]16BuildRequires:  python3-devel
[6890]17BuildRequires:  gjs-devel
[12396]18BuildRequires:  glade3-devel
19BuildRequires:  gtk-doc
[4616]20BuildRequires:  gobject-introspection-devel
21BuildRequires:  intltool
[12396]22BuildRequires:  meson
[4616]23
24%description
25libpeas is a convenience library making adding plug-ins support
26to GTK+ and glib-based applications.
27
[9475]28
[12396]29%package        devel
[4616]30Summary:        Development files for libpeas
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33Requires:       gobject-introspection-devel
34
35%description devel
36This package contains development libraries and header files
37that are needed to write applications that use libpeas.
38
[9475]39
40%package        docs
41Summary:        Documentation for %{name}
42Summary(ja):    %{name} 用のドキュメント
43Group:          Documentation
44BuildArch:      noarch
45
46%description    docs
47This package contains documentation for %{name}.
48
49
[12396]50%package        python3
[9475]51Summary:        Python3 loader for %{name}
52Group:          System Environment/Libraries
53Requires:       %{name} = %{version}-%{release}
[12396]54Requires:       python3
55Provides:       python3-%{name} = %{version}-%{release}
[9475]56
57%description python3
58%{summary}
59
60
[4616]61%prep
62%setup -q
63
[12396]64
[4616]65%build
[12396]66%meson -Dgtk_doc=true
67%meson_build
[4616]68
69
70%install
[12396]71%meson_install
[4616]72
[12396]73%find_lang libpeas-1.0
[4616]74
75
76%post
77/sbin/ldconfig
78touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
79
80%postun
81/sbin/ldconfig
82if [ $1 -eq 0 ]; then
83  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
84  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
85fi
86
87%posttrans
88gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
89
[12396]90
91%files -f libpeas-1.0.lang
[4616]92%defattr(-,root,root,-)
[12396]93%license COPYING
[4616]94%doc AUTHORS
95%{_libdir}/libpeas*-1.0.so.*
96%dir %{_libdir}/libpeas-1.0/
97%dir %{_libdir}/libpeas-1.0/loaders
[12396]98%{_libdir}/libpeas-1.0/loaders/libpython3loader.so
[4616]99%{_libdir}/girepository-1.0/*.typelib
100%{_datadir}/icons/hicolor/*/actions/libpeas-plugin.*
[12396]101%dir %{_datadir}/glade
102%dir %{_datadir}/glade/catalogs
103%{_datadir}/glade/catalogs/*
[4616]104
105%files devel
106%defattr(-,root,root,-)
107%{_bindir}/peas-demo
108%{_includedir}/libpeas-1.0/
109%{_libdir}/peas-demo/
110%{_libdir}/libpeas*-1.0.so
111%{_datadir}/gir-1.0/*.gir
112%{_libdir}/pkgconfig/*.pc
113
[9475]114%files docs
115%defattr(-,root,root,-)
116%{_datadir}/gtk-doc/html/libpeas/
117
118%files python3
119%defattr(-,root,root,-)
120%{_libdir}/libpeas-1.0/loaders/libpython3loader.so
121
122
[4616]123%changelog
[12469]124* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.0-2
125- rebuilt with python-3.8.
126
[12396]127* Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.0-1
128- new upstream release.
129
[10716]130* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
131- new upstream release
[10405]132
[9791]133* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
134- new upstream release
135
[9560]136* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-2
137- remove *.la files
138
[9475]139* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
140- new upstream release
141- add BuildRequires: python3-devel
142- create %%{name}-docs,python3 subpackages
143
[9073]144* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
145- new upstream release
146
[8912]147* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
148- new upstream release
149
[8355]150* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
151- new upstream release
152- remove Patch0 (libpeas-1.8.1-gjs-1.36.x.patch)
153- remove Patch1 (libpeas-1.8.1-gjs-plugin-loader.patch)
154
[8119]155* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
156- rebuild with VineSeed environment
157- add Patch0 (libpeas-1.8.1-gjs-1.36.x.patch)
158- add Patch1 (libpeas-1.8.1-gjs-plugin-loader.patch)
159
[7756]160* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
161- new upstream release
162
[7633]163* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
164- new upstream release
165
[7294]166* Thu Jan 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
167- new upstream release
168
[6951]169* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
170- new upstream release
171
[6890]172* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
173- new upstream release
174
[6011]175* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
176- new upstream release
177
[5701]178* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
179- rebuild with python-2.7.2
180
[4850]181* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
182- new upstream release
183
[4812]184* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
185- new upstream release
186- add BuildRequires: gjs-devel
187
[4704]188* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
189- new upstream release
190- change BuildRequires: pygobject3-devel instead of pygobject-devel
191
[4616]192* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
193- initial build for Vine Linux
194
195
196* Mon Apr  4 2011 Christopher Aillon <caillon@redhat.com> 1.0.0-1
197- Update to 1.0.0
198
199* Sun Mar 27 2011 Bastien Nocera <bnocera@redhat.com> 0.9.0-1
200- Update to 0.9.0
201
202* Thu Mar 10 2011 Bastien Nocera <bnocera@redhat.com> 0.7.4-1
203- Update to 0.7.4
204
205* Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> 0.7.3-1
206- Update to 0.7.3
207- Drop unneeded dependencies
208
209* Mon Feb 21 2011 Bastien Nocera <bnocera@redhat.com> 0.7.2-1
210- Update to 0.7.2
211
212* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-7
213- Rebuild
214
215* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-6
216- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
217
218* Wed Feb  2 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-5
219- Rebuild against newer gtk
220
221* Fri Jan 28 2011 Bastien Nocera <bnocera@redhat.com> 0.7.1-4
222- Update to real 0.7.1 release
223
224* Fri Jan  7 2011 Matthias Clasen <mclasen@redhat.com> - 0.7.1-3.gita2f98e
225- Rebuild against newer gtk
226
227* Fri Dec  3 2010 Matthias Clasen <mclasen@redhat.com> - 0.7.1-2.gita2f98e
228- Rebuild against newer gtk
229
230* Thu Nov 11 2010 Dan Williams <dcbw@redhat.com> - 0.7.1-1.gita2f98e
231- Update to 0.7.1
232- Fix some crashes with missing introspection data
233
234* Mon Nov  1 2010 Matthias Clasen <mclasen@redhat.com> 0.7.0-2
235- Rebuild against newer gtk3
236
237* Mon Oct 04 2010 Bastien Nocera <bnocera@redhat.com> 0.7.0-1
238- Update to 0.7.0
239
240* Tue Sep 21 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-2
241- Rebuild against newer gobject-introspection
242
243* Thu Aug 19 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-1
244- Update to 0.5.5
245
246* Thu Aug  5 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.4-1
247- Update to 0.5.4
248
249* Tue Jul 27 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 0.5.3-2
250- Rebuild against python 2.7
251
252* Fri Jul 23 2010 Bastien Nocera <bnocera@redhat.com> 0.5.3-1
253- Update to 0.5.3
254
255* Thu Jul 22 2010 Bastien Nocera <bnocera@redhat.com> 0.5.2-5
256- Fix post scriplet (#615021)
257
258* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 0.5.2-4
259- Rebuild with new gobject-introspection
260
261* Tue Jul 13 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-3
262- Rebuild
263
264* Mon Jul 12 2010 Colin Walters <walters@verbum.org> - 0.5.2-2
265- Rebuild against new gobject-introspection
266
267* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-1
268- Update to 0.5.2
269
270* Thu Jul  8 2010 Matthias Clasen <mclasen@redhat.com> 0.5.1-2
271- Rebuild
272
273* Mon Jun 28 2010 Bastien Nocera <bnocera@redhat.com> 0.5.1-1
274- Update to 0.5.1
275
276* Thu Jun 24 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-4
277- Document rpath work-arounds disabling, and remove verbose build
278
279* Fri Jun 18 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-3
280- Fix a number of comments from review request
281
282* Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-2
283- Call ldconfig when installing the package
284
285* Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-1
286- First package
287
Note: See TracBrowser for help on using the repository browser.