source: projects/specs/trunk/lib/libp/libpaper/libpaper-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           libpaper
2Version:        1.1.23
3Release:        1%{?_dist_release}
4Summary:        Library and tools for handling papersize
5Summary(ja):    用紙サイズを扱うライブラリとツール
6Group:          System Environment/Libraries
7License:        GPLv2
8URL:            http://packages.qa.debian.org/libp/libpaper.html
9Source0:        http://ftp.debian.org/debian/pool/main/libp/libpaper/%{name}_%{version}+nmu1.tar.gz
10# Filed upstream as:
11# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496126
12Patch0:         libpaper-1.1.20-automake_1.10.patch
13# Upstream bug:
14# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=475683
15Patch1:         libpaper-1.1.23-debianbug475683.patch
16# Filed upstream as:
17# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=481213
18Patch2:         libpaper-useglibcfallback.patch
19BuildRequires:  libtool, gettext, gawk
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23Packager:       kazutaka
24
25
26%description
27The paper library and accompanying files are intended to provide a
28simple way for applications to take actions based on a system- or
29user-specified paper size. This release is quite minimal, its purpose
30being to provide really basic functions (obtaining the system paper name
31and getting the height and width of a given kind of paper) that
32applications can immediately integrate.
33
34%package devel
35Summary:        Headers/Libraries for developing programs that use libpaper
36Summary(ja):    libpaper を使ったプログラムの開発に必要なヘッダとライブラリ
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39
40%description devel
41This package contains headers and libraries that programmers will need
42to develop applications which use libpaper.
43
44%prep
45%setup -q -n %{name}-%{version}+nmu1
46%patch0 -p1 -b .automake110
47%patch1 -p1 -b .dlfix
48%patch2 -p1 -b .useglibcfallback
49libtoolize
50
51%build
52touch AUTHORS NEWS
53aclocal
54autoconf
55automake -a
56%configure --disable-static
57# Disable rpath
58sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
59sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
60make %{?_smp_mflags}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64make DESTDIR=$RPM_BUILD_ROOT install
65rm $RPM_BUILD_ROOT%{_libdir}/*.la
66mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
67echo '# Simply write the paper name. See papersize(5) for possible values' > $RPM_BUILD_ROOT%{_sysconfdir}/papersize
68mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/libpaper.d
69for i in cs da de es fr gl hu it ja nl pt_BR sv tr uk vi; do
70        mkdir -p $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES/;
71        msgfmt debian/po/$i.po -o $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES/%{name}.mo;
72done
73%find_lang %{name}
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post -p /sbin/ldconfig
79
80%postun -p /sbin/ldconfig
81
82%files -f %{name}.lang
83%defattr(-, root, root, -)
84%doc COPYING ChangeLog README
85%config(noreplace) %{_sysconfdir}/papersize
86%dir %{_sysconfdir}/libpaper.d
87%{_bindir}/paperconf
88%{_libdir}/libpaper.so.*
89%{_sbindir}/paperconfig
90%{_mandir}/man1/*
91%{_mandir}/man5/*
92%{_mandir}/man8/*
93
94%files devel
95%defattr(-, root, root, -)
96%{_includedir}/paper.h
97%{_libdir}/libpaper.so
98%{_mandir}/man3/*
99
100%changelog
101* Thu May 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.1.23-1
102- initial build for Vine Linux based of fedora development
103- add japanese summary
104
105* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.23-5
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
107
108* Mon Feb 16 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1.23-4
109- run libtoolize to fix build with newer libtool
110- disable rpath
111
112* Fri Aug 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1.23-3
113- update to nmu1
114- apply patch to fix imprecise definition of DL format
115- apply patch so that when no config is present, libpaper will fallback through
116  LC_PAPER before giving up and using Letter
117
118* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.23-2
119- Autorebuild for GCC 4.3
120
121* Tue Feb 19 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.23-1
122- 1.1.23
123
124* Fri Aug 24 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.22-1.1
125- missing BR: gawk
126
127* Thu Aug 23 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.22-1
128- bump, no real changes of note, rebuild for ppc32
129- license fix, v2 only
130
131* Mon Jul 09 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.21-1.1
132- BR: libtool
133
134* Mon Jul 09 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.21-1
135- bump to 1.1.21
136- fix automake bug (bz 247458)
137
138* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 1.1.20-5
139 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
140
141* Sat Sep 23 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.20-4
142- remove aclocal call
143
144* Sat Sep 23 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.20-3
145- fix FC-4 with aclocal call
146- move man3 pages to -devel
147- don't set default, just put comment in conf file
148- own /etc/libpaper.d
149- use debian/NEWS
150- include the meager translations
151- use --disable-static
152
153* Sat Sep 23 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.20-2
154- nuke static lib
155- own /etc/papersize
156- fix mixed spaces/tabs rpmlint warning
157
158* Sat Sep 23 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.20-1
159- initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.