source: projects/specs/trunk/lib/libo/libotf/libotf-vl.spec @ 521

Revision 521, 3.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1## -*- coding: utf-8-unix -*-
2Name:           libotf
3Version:        0.9.9
4Release:        1%{?_dist_release}
5Summary:        A Library for handling OpenType Font
6Summary(ja):    OpenType フォントを扱うライブラリ
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://www.m17n.org/libotf/
11Source0:         http://www.m17n.org/%{name}/%{name}-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires:  gcc chrpath freetype2-devel libXaw-devel
15Requires:       freetype2
16
17%description
18The library "libotf" provides the following facilites.
19Read Open Type Layout Tables from OTF file. Currently these tables are
20supported; head, name, cmap, GDEF, GSUB, and GPOS.  Convert a Unicode
21character sequence to a glyph code sequence by using the above tables.
22The combination of libotf and the FreeType library (Ver.2) realizes
23CTL (complex text layout) by OpenType fonts. This library is currently
24used by the m17n library. It seems that the probject Free Type Layout
25provides the similar (or better) facility as this library, but
26currently they have not yet released their library. So, we have
27developed this one.
28
29%package        devel
30Summary:        Development files for %{name}
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}, pkgconfig
33
34%description    devel
35The %{name}-devel package contains libraries and header files for
36developing applications that use %{name}.
37
38
39%prep
40%setup -q
41
42
43%build
44%configure --disable-static
45%__make %{?_smp_mflags}
46
47
48%install
49%__rm -rf $RPM_BUILD_ROOT
50%__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
51find $RPM_BUILD_ROOT -name '*.la' -exec %__rm -f {} ';'
52for file in $RPM_BUILD_ROOT/usr/bin/*; do chrpath -d $file || true; done
53
54(cd example && %__make clean && %__rm -rf .deps && rm Makefile)
55%__rm $RPM_BUILD_ROOT/usr/bin/libotf-config
56
57
58%clean
59%__rm -rf $RPM_BUILD_ROOT
60
61
62%post -p /sbin/ldconfig
63
64%postun -p /sbin/ldconfig
65
66
67%files
68%defattr(-,root,root,-)
69%doc AUTHORS COPYING README NEWS
70%{_libdir}/*.so.*
71%{_bindir}/otfdump
72%{_bindir}/otflist
73%{_bindir}/otftobdf
74%{_bindir}/otfview
75
76%files devel
77%defattr(-,root,root,-)
78%doc example
79%{_includedir}/*
80%{_libdir}/*.so
81%{_libdir}/pkgconfig/*
82
83
84%changelog
85* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1
86- built based on Fedora development
87  - s/freetype/freetype2/ in Requires, BuildRequires tags
88
89* Sat Oct 24 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-3
90- Add BR libXaw-devel (BR 530586)
91
92* Fri Oct  9 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-2
93- Remove libotf-config (just just pkg-config instead)
94- Remove example/Makefile to fix multilib conflict
95
96* Tue Aug 25 2009 Neal Becker <ndbecker2@gmail.com> - 0.9.9-1
97- Update to 0.9.9
98
99* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-3
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
101
102* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
104
105* Fri Aug  8 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.8-1
106- Update to 0.9.8
107
108* Mon Apr 14 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-4
109- Remove .deps from example
110
111* Fri Mar 28 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-3
112- Change to LGPLv2+
113- Add examples
114
115* Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-2
116- Cleanup suggestions from panemade at gmail dot com
117
118* Tue Mar 25 2008 Neal Becker <ndbecker2@gmail.com> - 0.9.7-1
119- Initial
120
Note: See TracBrowser for help on using the repository browser.