source: projects/specs/trunk/lib/libo/libogg/libogg-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        The Ogg bitstream file format library.
4Name:           libogg
5Version:        1.1.4
6Release:        1%{?_dist_release}
7Group:          System Environment/Libraries
8License:        BSD
9URL:            http://www.xiph.org/
10Source:         http://downloads.xiph.org/releases/ogg/%{name}-%{version}.tar.gz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  perl
14
15Vendor: Project Vine
16Distribution: Vine Linux
17
18Packager: kenta, inagaki
19
20%description
21Libogg is a library for manipulating Ogg bitstream file formats.
22Libogg supports both making Ogg bitstreams and getting packets from
23Ogg bitstreams.
24
25%package devel
26Summary:        Files needed for development using libogg.
27Group:          Development/Libraries
28Requires:       %{name} = %{version}-%{release}
29
30%description devel
31The libogg-devel package contains the header files, static libraries
32and documentation needed to develop applications with libogg.
33
34# compat32
35%package -n compat32-%{name}
36Summary:        The Ogg bitstream file format library.
37Group:          System Environment/Libraries
38
39%description -n compat32-%{name}
40Libogg is a library for manipulating Ogg bitstream file formats.
41Libogg supports both making Ogg bitstreams and getting packets from
42Ogg bitstreams.
43
44%package -n compat32-%{name}-devel
45Summary:        Files needed for development using libogg.
46Group:          Development/Libraries
47Requires:       compat32-%{name} = %{version}-%{release}
48Requires:       %{name}-devel = %{version}-%{release}
49
50%description -n compat32-%{name}-devel
51The libogg-devel package contains the header files, static libraries
52and documentation needed to develop applications with libogg.
53
54%prep
55%setup -q -n libogg-%{version}
56
57%build
58perl -p -i -e "s/-O20/$RPM_OPT_FLAGS/" configure
59perl -p -i -e "s/-ffast-math//" configure
60
61%configure --disable-static
62make
63
64%install
65[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
66make DESTDIR=$RPM_BUILD_ROOT install
67
68rm -f doc/libogg/Makefile*
69#rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
70rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
71
72%clean
73[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
74
75%post -p /sbin/ldconfig
76
77%postun -p /sbin/ldconfig
78
79%post -n compat32-%{name} -p /sbin/ldconfig
80
81%postun -n compat32-%{name} -p /sbin/ldconfig
82
83
84%files
85%defattr(-,root,root)
86%doc AUTHORS CHANGES COPYING README
87%{_libdir}/*.so.*
88
89%files devel
90%defattr(-,root,root)
91%doc doc/index.html doc/framing.html doc/oggstream.html
92%doc doc/white-ogg.png doc/white-xifish.png
93%doc doc/stream.png
94%doc doc/libogg
95%dir %{_includedir}/ogg
96%{_includedir}/ogg/*.h
97#{_libdir}/*.a
98%{_libdir}/*.so
99%{_libdir}/pkgconfig/*.pc
100%{_datadir}/aclocal/ogg.m4
101
102# compat32
103%if %{build_compat32}
104%files -n compat32-%{name}
105%{_libdir}/*.so.*
106
107%files -n compat32-%{name}-devel
108%defattr(-,root,root)
109#{_libdir}/*.a
110%{_libdir}/*.so
111%{_libdir}/pkgconfig/*.pc
112%endif
113
114%changelog
115* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-1
116- new upstream release
117
118* Fri Jun 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.3-3
119- used --disable-static option
120- added Vendor, Distribution, Packager tag
121
122* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.3-2
123- added compat32 package for x86_64 arch support
124- removed lib*.a files from devel package
125
126* Mon May 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.3-1
127- applied new versioning policy
128- removed lib*.la files from devel package
129
130* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.3-0vl2
131- rebuild with new toolchain
132
133* Tue Nov 29 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.3-0vl1
134- source upgrade
135
136* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
137- source upgrade
138- update source-URL
139
140* Fri Mar 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
141- rebuild
142
143* Sat Nov 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
144- rebuild for VineSeedPlus
145
146* Fri Nov 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
147- source upgrade
148- build for VinePlus/2.6
149- add %%{_libdir}/*.la and %%{_libdir}/pkgconfig/*.pc to devel package
150
151* Sat Oct  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl3
152- rebuild with new toolchains
153
154* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl2
155- rebuild with new toolchains
156
157* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl1
158- source upgrade
159- update %description devel
160- add PreReq: ldconfig
161
162* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.99.3-1vl1
163- build for VineSeed
164- delete Serial
165- change version number to 0.99.3 (means 1.0rc3)
166
167* Tue Jan  1 2002 Bill Nottingham <notting@redhat.com>
168- update to 1.0rc3
169
170* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
171- update to 1.0rc2
172
173* Fri Jul  6 2001 Bill Nottingham <notting@redhat.com>
174- own %%{_includedir}/ogg
175
176* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
177- update to 1.0rc1
178
179* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
180- fix license tag
181
182* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
183- beta4
184
185* Tue Feb  6 2001 Bill Nottingham <notting@redhat.com>
186- update CVS in prep for beta4
187
188* Thu Dec 27 2000 Bill Nottingham <notting@redhat.com>
189- update CVS
190
191* Tue Dec 11 2000 Bill Nottingham <notting@redhat.com>
192- fix bogus group
193
194* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
195- rebuild because of broken fileutils
196
197* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
198- clean up specfile slightly
199
200* Sat Sep 02 2000 Jack Moffitt <jack@icecast.org>
201- initial spec file created
Note: See TracBrowser for help on using the repository browser.