source: projects/specs/trunk/lib/libn/libnl/libnl-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Convenience library for kernel netlink sockets
2Summary(ja): Kernel の netlink ソケットを利用するための便利ライブラリ
3Group: Development/Libraries
4License: LGPLv2
5Name: libnl
6Version: 1.1
7Release: 1%{?_dist_release}
8URL: http://people.suug.ch/~tgr/libnl/
9Source: http://people.suug.ch/~tgr/libnl/files/libnl-%{version}.tar.gz
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildRequires: doxygen
12Patch1: libnl-1.0-pre5-static.patch
13Patch2: libnl-1.0-pre5-debuginfo.patch
14Patch3: libnl-1.0-pre8-use-vasprintf-retval.patch
15Patch4: libnl-1.0-pre8-more-build-output.patch
16Patch5: libnl-1.1-include-limits-h.patch
17Patch6: libnl-1.1-doc-inlinesrc.patch
18
19%description
20This package contains a convenience library to simplify
21using the Linux kernel's netlink sockets interface for
22network manipulation
23
24%package devel
25Summary: Libraries and headers for using libnl
26Summary(ja): Libraries and headers for using libnl
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29Requires: kernel-headers
30
31%description devel
32This package contains various headers for using libnl
33
34%prep
35%setup -q -n %{name}-%{version}
36%patch1 -p1 -b .build-static
37%patch2 -p1 -b .debuginfo
38%patch3 -p1 -b .use-vasprintf-retval
39%patch4 -p1 -b .more-build-output
40%patch5 -p1 -b .limits
41%patch6 -p1 -b .doc-inlinesrc
42
43# a quick hack to make doxygen stripping builddir from html outputs.
44sed -i.org -e "s,^STRIP_FROM_PATH.*,STRIP_FROM_PATH = `pwd`," doc/Doxyfile.in
45
46%build
47%configure
48make
49make gendoc
50
51%install
52%{__rm} -rf $RPM_BUILD_ROOT
53make install DESTDIR=$RPM_BUILD_ROOT
54
55%clean
56%{__rm} -rf $RPM_BUILD_ROOT
57
58%post -p /sbin/ldconfig
59%postun -p /sbin/ldconfig
60
61%files
62%defattr(-,root,root)
63%{_libdir}/%{name}.so.*
64%doc COPYING
65
66%files devel
67%defattr(-,root,root,0755)
68%{_includedir}/netlink/
69%doc doc/html
70%{_libdir}/%{name}.so
71%{_libdir}/%{name}.a
72%{_libdir}/pkgconfig/%{name}-1.pc
73
74%changelog
75* Wed Jul 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
76- initial build for Vine Linux
77
78* Fri Jun 27 2008 Dan Williams <dcbw@redhat.com> - 1.1-5
79- Build documentation in -devel package (rh #452646)
80
81* Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1-4
82- fix license tag
83
84* Fri Feb 22 2008 Dan Williams <dcbw@redhat.com> - 1.1-3
85- Include limits.h to fix gcc 4.3 rebuild issues (rh #434055)
86
87* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1-2
88- Autorebuild for GCC 4.3
89
90* Wed Jan 23 2008 Dan Williams <dcbw@redhat.com> - 1.1-1
91- Update to version 1.1
92
93* Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.15.pre8.git20071218
94- Handle removal of include/linux/ip_mp_alg.h in 2.6.24
95
96* Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.14.pre8.git20071217
97- devel package should require kernel-headers
98
99* Mon Dec 17 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.13.pre8.git20071217
100- Add dist tag to revision
101
102* Mon Dec 17 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.12.pre8.git20071217
103- Update to -pre8 + fixes (rh #401761)
104
105* Mon Aug 14 2006 Peter Jones <pjones@redhat.com> - 1.0-0.10.pre5.4
106- Fix nl_recv() for ppc64
107
108* Mon Jul 31 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.10.pre5.3
109- unbreak the pkgconfig file
110
111* Wed Jul 26 2006 Matthias Clasen <mclasen@redhat.com> - 1.0-0.10.pre5.2
112- Fix the pkgconfig file on 64-bit systems (#197176)
113
114* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.10.pre5.1
115- rebuild
116
117* Thu Jun 15 2006 Peter Jones <pjones@redhat.com> 1.0-0.10.pre5
118- Fix debuginfo generation.
119
120* Fri May 26 2006 Jason Vas Dias <jvdias@redhat.com> 1.0-0.9.pre5
121- Allow build to succeed with new gcc / glibc-kernheaders
122  (compile failed on __u64 redefinition on x86_64).
123- Add a static %{_libdir}/libnl.a library to libnl-devel for
124  programs that might need to do a static link to libnl.
125  Added after consultation with Christopher Aillon.
126
127* Tue Feb 12 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.8.pre5
128- Rebuild
129
130* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0-0.7.pre5.1
131- rebuilt for new gcc4.1 snapshot and glibc changes
132
133* Mon Jan 16 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.7.pre5
134- Add patch to not chown files to root.root during make install; it
135  happens normally.
136
137* Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.6.pre5
138- Correctly install the pkgconfig file
139
140* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
141- rebuilt
142
143* Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.5.pre5
144- Fix 64bit LIBDIR issue; use $LIBDIR instead of $PREFIX/lib
145
146* Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.4.pre5
147- Update to 1.0-pre5
148
149* Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.3.pre4
150- Update to 1.0-pre4
151
152* Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.2.pre3
153- Minor specfile cleanup
154
155* Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.1.pre3
156- Split into main and devel packages
157
158* Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.0.pre3
159- initial build
Note: See TracBrowser for help on using the repository browser.