source: projects/specs/trunk/lib/libn/libnet/libnet-vl.spec @ 5910

Revision 5910, 5.8 KB checked in by shaolin, 12 years ago (diff)
  • libnet: updated to 1.1.5; spec revamped
Line 
1Summary:        C library for portable packet creation and injection
2Name:           libnet
3Version:        1.1.5
4Release:        1%{?_dist_release}
5License:        BSD
6Group:          System Environment/Libraries
7URL:            http://www.sourceforge.net/projects/libnet-dev/
8Source:         http://downloads.sourceforge.net/libnet-dev/%{name}-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14%description
15Libnet is an API to help with the construction and handling of network
16packets. It provides a portable framework for low-level network packet
17writing and handling (use libnet in conjunction with libpcap and you can
18write some really cool stuff). Libnet includes packet creation at the IP
19layer and at the link layer as well as a host of supplementary and
20complementary functionality.
21
22%package devel
23Summary:        Development files for the libnet library
24Group:          Development/Libraries
25Requires:       %{name} = %{version}-%{release}
26
27%description devel
28The libnet-devel package includes header files and libraries necessary
29for developing programs which use the libnet library. Libnet is very handy
30with which to write network tools and network test code. See the manpage
31and sample test code for more detailed information.
32
33%prep
34%setup -q
35
36# Keep the sample directory untouched by make
37rm -rf __dist_sample
38mkdir __dist_sample
39cp -a sample __dist_sample
40
41%build
42%configure --libdir=/%{_lib}
43make %{?_smp_mflags}
44
45%install
46rm -rf %{buildroot}
47make DESTDIR=%{buildroot} INSTALL='install -p' install
48
49# Move %{name}.so to %{_libdir}, remove static .a and libtool .la files
50rm -f %{buildroot}/%{_lib}/%{name}.{a,la,so}
51pushd %{buildroot}/%{_lib}
52mkdir -p %{buildroot}%{_libdir}
53ln -sf ../../%{_lib}/$(ls %{name}.so.?.?.?) %{buildroot}%{_libdir}/%{name}.so
54popd
55
56# Prepare samples directory and perform some fixes
57rm -rf __dist_sample/sample/win32
58rm -f __dist_sample/sample/Makefile.{am,in}
59sed -e 's@#include "../include/libnet.h"@#include <libnet.h>@' \
60  __dist_sample/sample/libnet_test.h > __dist_sample/sample/libnet_test.h.new
61touch -c -r __dist_sample/sample/libnet_test.h{,.new}
62mv -f __dist_sample/sample/libnet_test.h{.new,}
63
64# Remove makefile relics from documentation
65rm -f doc/html/Makefile*
66
67%clean
68rm -rf %{buildroot}
69
70%post -p /sbin/ldconfig
71
72%postun -p /sbin/ldconfig
73
74%files
75%defattr(-,root,root,-)
76%doc README doc/CHANGELOG doc/CONTRIB doc/COPYING
77/%{_lib}/%{name}.so.*
78
79%files devel
80%defattr(-,root,root,-)
81%doc doc/BUGS doc/DESIGN_NOTES doc/MIGRATION doc/PACKET_BUILDING
82%doc doc/RAWSOCKET_NON_SEQUITUR doc/TODO doc/html/ __dist_sample/sample/
83%{_bindir}/%{name}-config
84%{_libdir}/%{name}.so
85%{_includedir}/libnet.h
86%{_includedir}/%{name}/
87%{_mandir}/man3/%{name}*.3*
88
89%changelog
90* Thu Mar 15 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.5-1
91- updated to 1.1.5; spec revamped
92
93  - Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2.1-2
94  - rebuilt with current VineSeed
95 
96  - Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.2.1-1vl5
97  - applied new versioning policy
98 
99  - Mon Oct 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2.1-0vl1
100  - initial build for Vine Linux based on FE package.
101
102* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.5-3
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
104
105* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.5-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
107
108* Tue Dec 28 2010 Robert Scheck <robert@fedoraproject.org> 1.1.5-1
109- Upgrade to 1.1.5
110
111* Fri Jul 09 2010 Robert Scheck <robert@fedoraproject.org> 1.1.4-4
112- Added patch for capability support rather UID check (#589770)
113
114* Fri Aug 21 2009 Robert Scheck <robert@fedoraproject.org> 1.1.4-3
115- Move libnet.so.* to /lib[64] to avoid static linking (#518150)
116
117* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
119
120* Thu Jun 11 2009 Robert Scheck <robert@fedoraproject.org> 1.1.4-1
121- Upgrade to 1.1.4
122
123* Sat Jun 06 2009 Robert Scheck <robert@fedoraproject.org> 1.1.3-2
124- Added upstream patch to solve HAVE_CONFIG_H (#501633, #502400)
125
126* Sat May 16 2009 Robert Scheck <robert@fedoraproject.org> 1.1.3-1
127- Upgrade to 1.1.3
128
129* Sun Apr 19 2009 Robert Scheck <robert@fedoraproject.org> 1.1.2.1-14
130- Enabled a shared library and made lots of spec file cleanups
131
132* Mon Feb 23 2009 Robert Scheck <robert@fedoraproject.org> 1.1.2.1-13
133- Rebuild against gcc 4.4 and rpm 4.6
134
135* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.2.1-12
136- Autorebuild for GCC 4.3
137
138* Wed Aug  1 2007 Patrice Dumas <pertusus@free.fr> 1.1.2.1-11
139- build with -fPIC (#250296)
140
141* Fri Jan 12 2007 Patrice Dumas <pertusus@free.fr> 1.1.2.1-10
142- add debian patch to correct bad checksums
143
144* Tue Aug 29 2006 Patrice Dumas <pertusus@free.fr> 1.1.2.1-9
145- rebuild for FC6
146
147* Fri Feb 17 2006 Patrice Dumas <pertusus@free.fr> 1.1.2.1-8
148- rebuild for fc5
149
150* Thu Dec 22 2005 Patrice Dumas <pertusus@free.fr> 1.1.2.1-7
151- rebuild
152
153* Mon Sep 12 2005 Patrice Dumas <pertusus@free.fr> 1.1.2.1-6
154- bump release and add dist tag
155
156* Tue Aug 30 2005 Paul Howarth <paul@city-fan.org> 1.1.2.1-5
157- spec file cleanup
158
159* Fri Aug 26 2005 Patrice Dumas <pertusus@free.fr> 1.1.2.1-4
160- use pushd and popd (from Oliver Falk)
161
162* Mon Aug 22 2005 Patrice Dumas <pertusus@free.fr> 1.1.2.1-3
163- Correct dos end of lines
164- add in devel: Provides: %%{name} = %%{version}-%%{release}
165
166* Fri Aug 12 2005 Patrice Dumas <pertusus@free.fr> 1.1.2.1-2
167- put everything in a devel subpackage
168- add smpflags
169- clean in sample
170
171* Fri Aug 12 2005 Patrice Dumas <pertusus@free.fr> 1.1.2.1-1
172- rebuild changing only name
173
174* Wed Jun 02 2004 Marcin Garski <garski@poczta.onet.pl> 1.1.2.1-2.fc2
175- Rebuild for Fedora Core 2
176
177* Sat May 08 2004 Marcin Garski <garski@poczta.onet.pl> 1.1.2.1-1
178- Initial specfile
Note: See TracBrowser for help on using the repository browser.