source: projects/specs/trunk/lib/libn/libnasl/libnasl-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           libnasl
2Version:        2.2.11
3Release:        6%{?dist}
4Summary:        Nessus Attack Scripting Language
5
6Group:          System Environment/Libraries
7License:        GPLv2
8URL:            http://www.nessus.org
9#http://nessus.org/download/index.php
10Source0:        libnasl-2.2.11.tar.gz
11Patch0:         libnasl-config.patch
12Patch1:         libnasl-2.2.4.pki.patch
13Patch2:         libnasl-nasl-config-multi.patch
14# fix #479655 bad signature check
15Patch3:         libnasl-openssl.patch
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  bison
19BuildRequires:  nessus-libraries-devel >= %{version}
20BuildRequires:  libpcap-devel
21BuildRequires:  tetex
22
23%description
24NASL is a scripting language designed for the Nessus security scanner.
25Its aim is to allow anyone to write a test for a given security hole
26in a few minutes, to allow people to share their tests without having
27to worry about their operating system, and to guarantee everyone that
28a NASL script can not do anything nasty except performing a given
29security test against a given target.
30
31Thus, NASL allows you to easily forge IP packets, or to send regular
32packets. It provides you some convenient functions that will make the
33test of web and FTP server more easy to write. NASL garantees you that
34a NASL script:
35- will not send any packet to a host other than the target host,
36- will not execute any commands on your local system.
37
38%package devel
39Summary:        Nessus Attack Scripting Language header files
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42
43%description devel
44The %{name}-devel package contains the files needed for development
45with %{name}.
46
47%package doc
48Summary:        Nessus Attack Scripting Language documentation
49Group:          Documentation
50
51%description doc
52Documentation for the Nessus Attack Scripting Language.
53
54%prep
55%setup -q -n %{name}
56%patch0
57%patch1 -p1
58%patch2
59%patch3
60
61%build
62export CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/pcap"
63%configure --enable-shared --disable-static --with-pic
64#smp_mflags will breake build
65make
66cd doc
67make
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install DESTDIR=$RPM_BUILD_ROOT
72
73rm -f $RPM_BUILD_ROOT/%{_libdir}/libnasl.la
74
75mkdir -p $RPM_BUILD_ROOT/%{_datadir}/libnasl/doc/
76cp doc/nasl_guide.{ps,dvi} $RPM_BUILD_ROOT/%{_datadir}/libnasl/doc/
77
78touch -r VERSION %{buildroot}%{_bindir}/nasl-config
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87%files
88%defattr(-,root,root,-)
89%doc COPYING
90%{_bindir}/nasl
91%{_libdir}/libnasl.so.*
92%{_mandir}/man1/nasl.1*
93%{_localstatedir}/lib/nessus
94%{_sysconfdir}/pki/nessus
95
96%files devel
97%defattr(-,root,root,-)
98%{_bindir}/nasl-config
99%{_libdir}/libnasl.so
100%{_includedir}/nessus
101%{_mandir}/man1/nasl-config.1*
102
103%files doc
104%defattr(-,root,root,-)
105%doc %{_datadir}/libnasl/
106
107%changelog
108* Sat Apr 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.2.11-6
109- Initial build for Vine
110
111* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.11-5
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
113
114* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.2.11-4
115- rebuild with new openssl
116
117* Mon Jan 12 2009 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
118- 2.2.11-3
119- fix #479655
120
121* Mon Dec  1 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2.11-2
122- in doc pkg: include missing dirs and mark files as %%doc
123
124* Sun Nov 23 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
125- 2.2.11-1
126- version upgrade
127- fix #465106
128
129* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.10-5
130- Autorebuild for GCC 4.3
131
132* Sat Dec 08 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1332.2.10-4
134- fix #342241
135
136* Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 2.2.10-3
137- Rebuild for deps
138
139* Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 2.2.10-2
140- Rebuild for deps
141
142* Wed Aug 22 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1432.2.10-1
144- version upgrade
145- new license tag
146
147* Wed Apr 25 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1482.2.9-2
149- fix #228374
150
151* Tue Dec 19 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1522.2.9-1
153- version upgrade
154
155* Mon Dec 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1562.2.8-3
157- bump
158
159* Wed Sep 13 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1602.2.8-2
161- FE6 rebuild
162
163* Sun Jun 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1642.2.8-1
165- version upgrade
166
167* Wed May 17 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1682.2.7-1
169- version upgrade
170- add CVE-2006-2093 patch
171
172* Sat Mar 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1732.2.6-3
174- fix BR
175
176* Fri Feb 24 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1772.2.6-2
178- add pki location patch
179- tune BR
180- honor now localstatedir
181
182* Fri Feb 24 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
1832.2.6-1
184- initial version
Note: See TracBrowser for help on using the repository browser.