source: projects/specs/trunk/lib/libm/libmtp/libmtp-vl.spec @ 521

Revision 521, 8.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           libmtp
2Version:        0.3.7
3Release:        1%{?_dist_release}
4Summary:        A software library for MTP media players
5Summary(ja):    MTPメディアプレイヤーのためのソフトウェアライブラリ
6URL:            http://libmtp.sourceforge.net/
7
8Group:          System Environment/Libraries
9Source0:        http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
10Patch0:         libmtp-0.2.6.1-simpler-rules.patch
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12License:        LGPLv2+
13Requires:       udev
14Requires:       hal
15BuildRequires:  libusb-devel
16BuildRequires:  doxygen
17
18%description
19This package provides a software library for communicating with MTP
20(Media Transfer Protocol) media players, typically audio players, video
21players etc.
22
23%description -l ja
24このパッケージは典型的な音声プレイヤーや動画プレイヤーなどの
25MTP (Media Transfer Protocol) メディアプレイヤーのための
26ソフトウェアライブラリを提供します.
27
28%package examples
29Summary:        Example programs for libmtp
30Summary(ja):    libmtpのためのプログラム例集
31Group:          Applications/Multimedia
32Requires:       %{name} = %{version}-%{release}
33
34%description examples
35This package provides example programs for communicating with MTP
36devices.
37
38%description -l ja examples
39このパッケージは MTP デバイスを用いて通信するためのプログラム例集を提供します.
40
41%package devel
42Summary:        Development files for libmtp
43Group:          System Environment/Libraries
44Requires:       %{name} = %{version}-%{release}
45Requires:       pkgconfig
46Requires:       libusb-devel
47
48%description devel
49This package provides development files for the libmtp
50library for MTP media players.
51
52%description -l ja devel
53このパッケージは MTP メディアプレイヤーのための libmtp ライブラリに対する
54開発ファイル群を提供します.
55
56%prep
57%setup -q
58%patch0 -p1 -b .rules
59
60%build
61%configure --disable-static --program-prefix=mtp-
62make %{?_smp_mflags}
63# Remove permissions from symlink in udev script, we use
64# HALd rules to fix the permissions instead.
65examples/hotplug -a"SYMLINK+=\"libmtp-%k\"" > libmtp.rules
66
67%install
68rm -rf $RPM_BUILD_ROOT
69make DESTDIR=$RPM_BUILD_ROOT install
70# Remove libtool archive remnant
71rm -f $RPM_BUILD_ROOT%{_libdir}/libmtp.la
72# Install udev rules file.
73mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
74install -p -m 644 libmtp.rules $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/60-libmtp.rules
75mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/information/10freedesktop
76install -p -m 644 libmtp.fdi $RPM_BUILD_ROOT%{_datadir}/hal/fdi/information/10freedesktop/10-usb-music-players-libmtp.fdi
77# Copy documentation to a good place
78install -p -m 644 AUTHORS ChangeLog COPYING INSTALL README TODO \
79$RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
80# Touch generated files to make them always have the same time stamp.
81touch -r configure.ac \
82      $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* \
83      $RPM_BUILD_ROOT%{_includedir}/*.h \
84      $RPM_BUILD_ROOT%{_libdir}/pkgconfig/*.pc \
85      $RPM_BUILD_ROOT%{_datadir}/hal/fdi/information/10freedesktop/10-usb-music-players-libmtp.fdi
86# Remove the Doxygen HTML documentation, this get different
87# each time it is generated and thus creates multiarch conflicts.
88# I don't want to pre-generate it but will instead wait for upstream
89# to find a suitable solution that will always bring the same files,
90# or that Doxygen is fixed not to do this.
91rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html
92
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98%postun -p /sbin/ldconfig
99
100%files
101%defattr(-, root,root,-)
102%{_libdir}/*.so.*
103%config(noreplace) %{_sysconfdir}/udev/rules.d/*
104%config(noreplace) %{_datadir}/hal/fdi/information/10freedesktop/10-usb-music-players-libmtp.fdi
105%files examples
106%defattr(-,root,root,-)
107%{_bindir}/*
108
109%files devel
110%defattr(-,root,root,-)
111%{_libdir}/*.so
112%dir %{_docdir}/%{name}-%{version}
113%{_docdir}/%{name}-%{version}/*
114%{_includedir}/*.h
115%{_libdir}/pkgconfig/*.pc
116
117
118%changelog
119* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.3.7-1
120- new upstream release
121
122* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.3.5-1
123- initial build based on Fedora package
124
125* Sun Dec 21 2008 Linus Walleij <triad@df.lth.se> 0.3.5-1
126- New upstream bugfix release.
127- Nuke documentation again. Multilib no like.
128
129* Fri Nov 7 2008 Linus Walleij <triad@df.lth.se> 0.3.4-1
130- New upstream bugfix release.
131- Bastiens patch is upstreamed, dropping that patch.
132
133* Sat Oct 25 2008 - Bastien Nocera <bnocera@redhat.com> - 0.3.3-4
134- Update device list from CVS and fix the build
135
136* Sat Oct 25 2008 - Bastien Nocera <bnocera@redhat.com> - 0.3.3-3
137- Add support for more Nokia phones from their WMP10 drivers
138
139* Fri Oct 24 2008 - Bastien Nocera <bnocera@redhat.com> - 0.3.3-2
140- Add support for the Nokia N82
141
142* Fri Sep 26 2008 Linus Walleij <triad@df.lth.se> 0.3.3-1
143- New upstream bugfix release.
144
145* Sat Sep 20 2008 Linus Walleij <triad@df.lth.se> 0.3.2-1
146- New upstream version. (API and ABI compatible.) Fixes
147  bugs on Creative devices.
148
149* Tue Aug 26 2008 Linus Walleij <triad@df.lth.se> 0.3.1-1
150- New upstream version. (API and ABI compatible.)
151
152* Thu Aug 7 2008 Linus Walleij <triad@df.lth.se> 0.3.0-1
153- Upgrade to 0.3.0. This has to happen some way, perhaps the
154  painful way: I upgrade to gnomad2 2.9.2 that use 0.3.0 and
155  then I write patches to Rhythmbox and Amarok to use 0.3.0
156  and also send these upstream.
157
158* Fri Jul 11 2008 Linus Walleij <triad@df.lth.se> 0.2.6.1-3
159- Loose PAM console permissions, also assume that we can ship
160  documentation again since Doxygen has been updated. Fedora
161  HALd rules for the portable_audio_player capability in
162  20-acl-management.fdi will change permissions on the device
163  node for each plugged-in device.
164
165* Fri May 23 2008 Adam Jackson <ajax@redhat.com> 0.2.6.1-2
166- libmtp-0.2.6.1-simpler-rules.patch: Simplify udev rules for faster bootup.
167
168* Sat Mar 8 2008 Linus Walleij <triad@df.lth.se> 0.2.6.1-1
169- New upstream bugfix release.
170
171* Sun Mar 2 2008 Linus Walleij <triad@df.lth.se> 0.2.6-1
172- New upstream release.
173
174* Sat Feb 9 2008 Linus Walleij <triad@df.lth.se> 0.2.5-2
175- Rebuild for GCC 4.3.
176
177* Wed Jan 9 2008 Linus Walleij <triad@df.lth.se> 0.2.5-1
178- New upstream release.
179
180* Thu Nov 22 2007 Linus Walleij <triad@df.lth.se> 0.2.4-1
181- New upstream release.
182
183* Thu Oct 25 2007 Linus Walleij <triad@df.lth.se> 0.2.3-1
184- New upstream release.
185- New soname libmtp.so.7 so all apps using libmtp have to
186  be recompiled, have fun.
187- If it works out we'll try to reserve a spot to backport
188  this fixed version to F8 and F7 in a controlled manner.
189
190* Wed Oct 24 2007 Linus Walleij <triad@df.lth.se> 0.2.2-2
191- Flat out KILL the Doxygen HTML docs to resolve multiarch conflicts.
192  Either upstream (that's me!) needs to work around the HTML files being
193  different each time OR Doxygen must stop generating anchors that
194  hash the system time, creating different files with each generation.
195  Pre-generating the docs is deemed silly. (Someone will disagree.)
196
197* Fri Aug 17 2007 Linus Walleij <triad@df.lth.se> 0.2.2-1
198- New upstream release.
199
200* Fri Aug 17 2007 Linus Walleij <triad@df.lth.se> 0.2.1-2
201- License field update from LGPL to LGPLv2+
202
203* Tue Aug 7 2007 Linus Walleij <triad@df.lth.se> 0.2.1-1
204- Upstream bugfix release.
205
206* Sat Aug 4 2007 Linus Walleij <triad@df.lth.se> 0.2.0-1
207- New upstream release.
208- Fixes (hopefully) the issues found by Harald.
209- Dependent apps will need to recompile and patch some minor code.
210
211* Mon Jul 30 2007 Harald Hoyer <harald@redhat.com> - 0.1.5-2
212- changed udev rules for new kernel and udev versions
213
214* Mon Mar 26 2007 Linus Walleij <triad@df.lth.se> 0.1.5-1
215- New upstream release.
216- Candidate for FC5, FC6 backport.
217- Hopefully API/ABI compatible, testing in devel tree.
218
219* Wed Mar 7 2007 Linus Walleij <triad@df.lth.se> 0.1.4-1
220- New upstream release.
221- Candidate for FC5, FC6 backport.
222- Hopefully API/ABI compatible, testing in devel tree.
223
224* Wed Jan 17 2007 Linus Walleij <triad@df.lth.se> 0.1.3-1
225- New upstream release.
226- Candidate for FC5, FC6 backport.
227
228* Thu Dec 7 2006 Linus Walleij <triad@df.lth.se> 0.1.0-1
229- New upstream release.
230- Start providing HAL rules.
231
232* Fri Oct 20 2006 Linus Walleij <triad@df.lth.se> 0.0.21-1
233- New upstream release.
234
235* Tue Sep 26 2006 Linus Walleij <triad@df.lth.se> 0.0.20-1
236- New upstream release.
237- Updated after review by Parag AN, Kevin Fenzi and Ralf Corsepius.
238- Fixed pkgconfig bug upstream after being detected by Ralf...
239
240* Sun Aug 27 2006 Linus Walleij <triad@df.lth.se> 0.0.15-1
241- New upstream release.
242
243* Wed Aug 23 2006 Linus Walleij <triad@df.lth.se> 0.0.13-1
244- First RPM'ed
Note: See TracBrowser for help on using the repository browser.