source: projects/specs/trunk/lib/libm/libmpc/libmpc-vl.spec @ 7961

Revision 7961, 3.4 KB checked in by Takemikaduchi, 10 years ago (diff)

upgrade toolchain + xserver-1.14.4

Line 
1Summary: C library for multiple precision complex arithmetic
2Name: libmpc
3Version: 1.0.1
4Release: 1%{?_dist_release}
5License: LGPLv3+
6Group: Development/Tools
7URL: http://www.multiprecision.org/
8Source0: mpc-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10BuildRequires: gmp-devel >= 4.3.2
11BuildRequires: mpfr-devel >= 2.4.2
12BuildRequires: texinfo
13
14%description
15
16MPC is a C library for the arithmetic of complex numbers with
17arbitrarily high precision and correct rounding of the result. It is
18built upon and follows the same principles as Mpfr.
19
20%package devel
21Summary: Header and shared development libraries for MPC
22Group: Development/Libraries
23Requires: %{name} = %{version}-%{release}
24Requires: mpfr-devel gmp-devel
25
26%description devel
27Header files and shared object symlinks for MPC is a C library.
28
29%prep
30%setup -q -n mpc-%{version}
31
32%build
33export CPPFLAGS="%{optflags} -std=gnu99"
34export CFLAGS="%{optflags} -std=gnu99"
35export EGREP=egrep
36%configure
37make %{?_smp_mflags}
38
39%check
40make check
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make install DESTDIR=$RPM_BUILD_ROOT
45rm -f $RPM_BUILD_ROOT/%{_libdir}/libmpc.{l,}a
46rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post -p /sbin/ldconfig
52%postun -p /sbin/ldconfig
53
54%post devel
55if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
56   /sbin/install-info %{_infodir}/mpc.info.gz %{_infodir}/dir || :
57fi
58
59%preun devel
60if [ $1 = 0 ]; then
61   if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
62      /sbin/install-info --delete %{_infodir}/mpc.info.gz %{_infodir}/dir || :
63   fi
64fi
65
66%files
67%defattr(-,root,root,-)
68%doc README NEWS COPYING.LESSER
69%{_libdir}/libmpc.so.*
70
71%files devel
72%defattr(-,root,root,-)
73%{_libdir}/libmpc.so
74%{_includedir}/mpc.h
75%{_infodir}/*.info*
76
77%changelog
78* Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
79- update to 1.0.1
80
81* Tue Nov 01 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9-2
82- initial build for Vine Linux
83
84* Wed Jun 22 2011  <pmachata@redhat.com> - 0.9-1
85- Upstream 0.9
86
87* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-0.3.svn855
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
89
90* Tue Nov 30 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.2.svn855
91- Bump for rebuild against the new mpfr
92
93* Fri Nov 19 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.1.svn855
94- Devel updates (to-be-0.8.3, SVN release 855)
95  - New functions mpc_set_dc, mpc_set_ldc, mpc_get_dc, mpc_get_ldc
96  - Speed-up mpc_pow_si and mpc_pow_z
97  - Bug fixes in trigonometric functions, exp, sqrt
98- Upstream 0.8.2
99  - Speed-up mpc_pow_ui
100- Adjust BuildRequires
101- Resolves: #653931
102
103* Wed Jan 20 2010 Petr Machata <pmachata@redhat.com> - 0.8.1-1
104- Upstream 0.8.1
105  - acosh, asinh, atanh: swap of precisions between real and imaginary parts
106  - atan: memory leak
107  - log: wrong ternary value in data file; masked by bug in Mpfr 2.4.1
108- Resolves: #555471 FTBFS libmpc-0.8-3.fc13
109
110* Fri Nov 13 2009 Petr Machata <pmachata@redhat.com> - 0.8-3
111- Require mpfr-devel, gmp-devel in -devel subpackage
112- Don't pass --entry to install-info
113
114* Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-2
115- Rename the package to libmpc, it's a better choice of name
116- %%preun should uninstall mpc's info page, not make's
117- Move info page to -devel
118- BR on -devel packages
119- Drop postscript documentation
120
121* Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-1
122- Initial package.
Note: See TracBrowser for help on using the repository browser.