source: projects/specs/trunk/lib/libm/libmpc/libmpc-vl.spec @ 5185

Revision 5185, 3.3 KB checked in by kenta, 12 years ago (diff)

libmpc: initial build for Vine Linux

Line 
1Summary: C library for multiple precision complex arithmetic
2Name: libmpc
3Version: 0.9
4Release: 2%{?_dist_release}
5License: LGPLv2+
6Group: Development/Tools
7URL: http://www.multiprecision.org/
8Source0: mpc-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10BuildRequires: gmp-devel >= 4.3.2
11BuildRequires: mpfr-devel >= 2.4.2
12BuildRequires: texinfo
13
14%description
15
16MPC is a C library for the arithmetic of complex numbers with
17arbitrarily high precision and correct rounding of the result. It is
18built upon and follows the same principles as Mpfr.
19
20%package devel
21Summary: Header and shared development libraries for MPC
22Group: Development/Libraries
23Requires: %{name} = %{version}-%{release}
24Requires: mpfr-devel gmp-devel
25
26%description devel
27Header files and shared object symlinks for MPC is a C library.
28
29%prep
30%setup -q -n mpc-%{version}
31
32%build
33export CPPFLAGS="%{optflags} -std=gnu99"
34export CFLAGS="%{optflags} -std=gnu99"
35export EGREP=egrep
36%configure
37make %{?_smp_mflags}
38
39%check
40make check
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make install DESTDIR=$RPM_BUILD_ROOT
45rm -f $RPM_BUILD_ROOT/%{_libdir}/libmpc.{l,}a
46rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post -p /sbin/ldconfig
52%postun -p /sbin/ldconfig
53
54%post devel
55if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
56   /sbin/install-info %{_infodir}/mpc.info.gz %{_infodir}/dir || :
57fi
58
59%preun devel
60if [ $1 = 0 ]; then
61   if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
62      /sbin/install-info --delete %{_infodir}/mpc.info.gz %{_infodir}/dir || :
63   fi
64fi
65
66%files
67%defattr(-,root,root,-)
68%doc README NEWS COPYING.LIB
69%{_libdir}/libmpc.so.*
70
71%files devel
72%defattr(-,root,root,-)
73%{_libdir}/libmpc.so
74%{_includedir}/mpc.h
75%{_infodir}/*.info*
76
77%changelog
78* Tue Nov 01 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9-2
79- initial build for Vine Linux
80
81* Wed Jun 22 2011  <pmachata@redhat.com> - 0.9-1
82- Upstream 0.9
83
84* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-0.3.svn855
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
86
87* Tue Nov 30 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.2.svn855
88- Bump for rebuild against the new mpfr
89
90* Fri Nov 19 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.1.svn855
91- Devel updates (to-be-0.8.3, SVN release 855)
92  - New functions mpc_set_dc, mpc_set_ldc, mpc_get_dc, mpc_get_ldc
93  - Speed-up mpc_pow_si and mpc_pow_z
94  - Bug fixes in trigonometric functions, exp, sqrt
95- Upstream 0.8.2
96  - Speed-up mpc_pow_ui
97- Adjust BuildRequires
98- Resolves: #653931
99
100* Wed Jan 20 2010 Petr Machata <pmachata@redhat.com> - 0.8.1-1
101- Upstream 0.8.1
102  - acosh, asinh, atanh: swap of precisions between real and imaginary parts
103  - atan: memory leak
104  - log: wrong ternary value in data file; masked by bug in Mpfr 2.4.1
105- Resolves: #555471 FTBFS libmpc-0.8-3.fc13
106
107* Fri Nov 13 2009 Petr Machata <pmachata@redhat.com> - 0.8-3
108- Require mpfr-devel, gmp-devel in -devel subpackage
109- Don't pass --entry to install-info
110
111* Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-2
112- Rename the package to libmpc, it's a better choice of name
113- %%preun should uninstall mpc's info page, not make's
114- Move info page to -devel
115- BR on -devel packages
116- Drop postscript documentation
117
118* Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-1
119- Initial package.
Note: See TracBrowser for help on using the repository browser.