source: projects/specs/trunk/lib/libm/libmpc/libmpc-vl.spec @ 10327

Revision 10327, 3.7 KB checked in by Takemikaduchi, 8 years ago (diff)

MATE-1.14.1

Line 
1Summary: C library for multiple precision complex arithmetic
2Name: libmpc
3Version: 1.0.3
4Release: 1%{?_dist_release}
5License: LGPLv3+
6Group: System Environment/Libraries
7URL: http://www.multiprecision.org/
8Source0: mpc-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10BuildRequires: gmp-devel >= 4.3.2
11BuildRequires: mpfr-devel >= 2.4.2
12BuildRequires: grep
13BuildRequires: texinfo
14
15%description
16MPC is a C library for the arithmetic of complex numbers with
17arbitrarily high precision and correct rounding of the result. It is
18built upon and follows the same principles as Mpfr.
19
20%package devel
21Summary: Header and shared development libraries for MPC
22Group: Development/Libraries
23Requires: %{name} = %{version}-%{release}
24Requires: gmp-devel
25Requires: mpfr-devel
26Requires(post): /sbin/install-info
27Requires(preun): /sbin/install-info
28
29%description devel
30Header files and shared object symlinks for MPC is a C library.
31
32%prep
33%setup -q -n mpc-%{version}
34
35%build
36export CPPFLAGS="%{optflags} -std=gnu99"
37export CFLAGS="%{optflags} -std=gnu99"
38export EGREP=egrep
39
40%configure --disable-static
41make %{?_smp_mflags}
42
43%check
44make check
45
46%install
47rm -rf $RPM_BUILD_ROOT
48make install DESTDIR=$RPM_BUILD_ROOT
49
50rm -f $RPM_BUILD_ROOT/%{_libdir}/libmpc.{l,}a
51rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post -p /sbin/ldconfig
57%postun -p /sbin/ldconfig
58
59%post devel
60if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
61   /sbin/install-info %{_infodir}/mpc.info.gz %{_infodir}/dir || :
62fi
63
64%preun devel
65if [ $1 = 0 ]; then
66   if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
67      /sbin/install-info --delete %{_infodir}/mpc.info.gz %{_infodir}/dir || :
68   fi
69fi
70
71%files
72%defattr(-,root,root,-)
73%doc README NEWS COPYING.LESSER
74%{_libdir}/libmpc.so.*
75
76%files devel
77%defattr(-,root,root,-)
78%{_libdir}/libmpc.so
79%{_includedir}/mpc.h
80%{_infodir}/*.info*
81
82%changelog
83* Fri May 20 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
84- updated to 1.0.3
85
86* Fri Sep 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
87- updated to 1.0.2
88- change Group to System Environment/Libraries (libmpc)
89
90* Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
91- update to 1.0.1
92
93* Tue Nov 01 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9-2
94- initial build for Vine Linux
95
96* Wed Jun 22 2011  <pmachata@redhat.com> - 0.9-1
97- Upstream 0.9
98
99* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-0.3.svn855
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
101
102* Tue Nov 30 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.2.svn855
103- Bump for rebuild against the new mpfr
104
105* Fri Nov 19 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.1.svn855
106- Devel updates (to-be-0.8.3, SVN release 855)
107  - New functions mpc_set_dc, mpc_set_ldc, mpc_get_dc, mpc_get_ldc
108  - Speed-up mpc_pow_si and mpc_pow_z
109  - Bug fixes in trigonometric functions, exp, sqrt
110- Upstream 0.8.2
111  - Speed-up mpc_pow_ui
112- Adjust BuildRequires
113- Resolves: #653931
114
115* Wed Jan 20 2010 Petr Machata <pmachata@redhat.com> - 0.8.1-1
116- Upstream 0.8.1
117  - acosh, asinh, atanh: swap of precisions between real and imaginary parts
118  - atan: memory leak
119  - log: wrong ternary value in data file; masked by bug in Mpfr 2.4.1
120- Resolves: #555471 FTBFS libmpc-0.8-3.fc13
121
122* Fri Nov 13 2009 Petr Machata <pmachata@redhat.com> - 0.8-3
123- Require mpfr-devel, gmp-devel in -devel subpackage
124- Don't pass --entry to install-info
125
126* Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-2
127- Rename the package to libmpc, it's a better choice of name
128- %%preun should uninstall mpc's info page, not make's
129- Move info page to -devel
130- BR on -devel packages
131- Drop postscript documentation
132
133* Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-1
134- Initial package.
Note: See TracBrowser for help on using the repository browser.