source: projects/specs/trunk/lib/libm/libmowgli/libmowgli-vl.spec @ 521

Revision 521, 2.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        An algorithm framework
2Summary(ja):    アルゴリズムフレームワーク
3Name:           libmowgli
4Version:        0.7.0
5Release:        1%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        ISC
9URL:            http://atheme.org/projects/mowgli.shtml
10
11Source0:        http://distfiles.atheme.org/libmowgli-%{version}.tgz
12
13BuildRoot:       %{_tmppath}/%{name}-%{version}-root
14
15%description
16mowgli is a development framework for C (like GLib), which provides high
17performance and highly flexible algorithms. It can be used as a suppliment to
18GLib (to add additional functions (dictionaries, hashes), or replace some of
19the slow GLib list manipulation functions), or stand alone. It also provides a
20powerful hook system and convenient logging for your code, as well as a high
21performance block allocator.
22
23%package devel
24Summary:        Development files for libmowgli
25Summary(ja):    libmowgli の開発用ファイル
26Group:          Development/Libraries
27Requires:       libmowgli = %{version}-%{release}
28Requires:       pkgconfig
29
30%description devel
31mowgli is a development framework for C (like GLib), which provides high
32performance and highly flexible algorithms. It can be used as a suppliment to
33GLib (to add additional functions (dictionaries, hashes), or replace some of
34the slow GLib list manipulation functions), or stand alone. It also provides a
35powerful hook system and convenient logging for your code, as well as a high
36performance block allocator.
37
38This package contains the files necessary for writing programs that use
39libmowgli.
40
41%prep
42%setup -q
43# Make the build system more verbose
44perl -pi -e 's/^\.SILENT:.*$//' buildsys.mk.in
45
46# The build generates a wrong SONAME, fix it.
47perl -pi -e "s/-soname=.*'/-soname=\\\$\{LIB\}.\\\$\{LIB_MAJOR\}'/" configure
48
49%build
50%configure \
51    --disable-dependency-tracking
52
53make %{?_smp_mflags}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57make install DESTDIR=$RPM_BUILD_ROOT
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%post -p /sbin/ldconfig
63
64%postun -p /sbin/ldconfig
65
66
67%files
68%defattr(-,root,root,-)
69%doc AUTHORS COPYING README
70%{_libdir}/*.so.*
71
72%files devel
73%defattr(-,root,root,-)
74%doc src/examples
75%{_libdir}/*.so
76%{_includedir}/libmowgli
77%{_libdir}/pkgconfig/libmowgli.pc
78
79%changelog
80* Sat Apr 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.0-1
81- new upstream release
82- changed Group to System Environment/Libraires
83
84* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-1
85- initial build for Vine Linux
86
87* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.0-2
88- Autorebuild for GCC 4.3
89
90* Sat Nov 10 2007 Ralf Ertzinger <ralf@skytale.net> 0.5.0-1
91- Initial build for FE
Note: See TracBrowser for help on using the repository browser.