source: projects/specs/trunk/lib/libm/libmng/libmng-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libmng
4Version: 1.0.10
5Release: 3%{?_dist_release}
6URL: http://www.libmng.com/
7Summary: A library of functions for manipulating MNG format files.
8License: AS IS
9Source: http://prdownloads.sourceforge.net/libmng/%{name}-%{version}.tar.gz
10Group: System Environment/Libraries
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildPrereq: glibc-devel zlib-devel libjpeg-devel lcms-devel
13BuildPrereq: automake autoconf libtool
14PreReq: ldconfig
15Requires: zlib libjpeg lcms
16
17%package devel
18Summary: Development tools for programs to manipulate MNG format files.
19Group: Development/Libraries
20Requires: %{name} = %{version}-%{release}
21Requires: zlib-devel libjpeg-devel lcms-devel
22
23%description
24libmng - library for reading, writing, displaying and examing
25Multiple-Image Network Graphics. MNG is the animation extension to the
26popular PNG image-format.
27
28%description devel
29The libmng-devel package contains the header files
30necessary for developing programs using the MNG
31(Multiple-Image Network Graphics) library.
32
33%package static
34Summary: Static libraries of %{name}
35Group: Development/Libraries
36Requires: %{name}-devel = %{version}-%{release}
37
38%description static
39The libmng-static package contains static libraries.
40
41# compat32
42%package -n compat32-%{name}
43Summary: A library of functions for manipulating MNG format files.
44Group: System Environment/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description -n compat32-%{name}
48libmng - library for reading, writing, displaying and examing
49Multiple-Image Network Graphics. MNG is the animation extension to the
50popular PNG image-format.
51
52%package -n compat32-%{name}-devel
53Summary: Development tools for programs to manipulate MNG format files.
54Group: Development/Libraries
55Requires: %{name}-devel = %{version}-%{release}
56Requires: compat32-%{name} = %{version}-%{release}
57Requires: compat32-zlib-devel compat32-libjpeg-devel compat32-lcms-devel
58
59%description -n compat32-%{name}-devel
60The libmng-devel package contains the header files
61necessary for developing programs using the MNG
62(Multiple-Image Network Graphics) library.
63
64
65%prep
66%setup -q
67
68%build
69# generate, but don't run
70#[ ! -x ./configure ] && ./autogen.sh
71cp -p makefiles/configure.in .
72cp -p makefiles/Makefile.am .
73
74libtoolize -f -c
75aclocal
76automake -a -c
77autoconf
78
79%configure --enable-shared --with-zlib --with-jpeg \
80        --with-gnu-ld --with-lcms
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85%makeinstall
86
87rm $RPM_BUILD_ROOT%{_libdir}/*.la
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%post -n compat32-%{name} -p /sbin/ldconfig
97
98%postun -n compat32-%{name} -p /sbin/ldconfig
99
100%files
101%defattr(-,root,root)
102%doc CHANGES LICENSE README doc
103%{_libdir}/*.so.*
104%{_mandir}/man*/*
105
106%files devel
107%defattr(-,root,root)
108%{_includedir}/*
109%{_libdir}/*.so
110
111%files static
112%defattr(-,root,root)
113%{_libdir}/*.a
114
115# compat32
116%if %{build_compat32}
117%files -n compat32-%{name}
118%defattr(-,root,root)
119%{_libdir}/*.so.*
120
121%files -n compat32-%{name}-devel
122%defattr(-,root,root)
123%{_libdir}/*.so
124%endif
125
126%changelog
127* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.10-3
128- added compat32 package for x86_64 arch support
129
130* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-2
131- add libmng-static which is needed by tuxonice-userui
132  - remove --disable-static
133  - remove Obsoletes: libmng-static
134
135* Wed Mar 19 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.10-1
136- new upstream release
137- delete *.la
138- add --disable-static
139
140* Sat May 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.9-0vl1
141- updated to 1.0.9
142- added BuildPrereq: automake, autoconf, libtool
143
144* Sun May 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.7-0vl3
145- add BuildPrereq: lcms-devel and Requires: lcms
146- add Requires: zlib-devel libjpeg-devel lcms-devel to -devel pkg
147- add --with-lcms to configure option
148
149* Wed May 11 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.7-0vl2
150- rebuilt to fix unwanted dependencies with lcms (ppc only)
151
152* Thu Apr 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-0vl1
153- rebuild with new toolchains
154- updated to 1.0.7
155
156* Mon Oct 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl2
157- License: AS IS
158- Obsoletes: libmng-static, and merge %%{prefix}/lib/*.a to -devel pkg
159- add PreReq: ldconfig
160- revised summaries and descriptions
161
162* Mon Oct 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl1
163- source upgrade
164- add %%doc Changes LICENSE README doc
165- add Requires: %%{name} = %%{version}-%%{release} for devel package
166- add Requires: %%{name}-devel = %%{version}-%%{release} for static package
167
168* Sat Oct 13 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl1
169- Update to 1.0.3
170- Build for VineSeed
171
172* Mon Jun 11 2001 net_hal <net_hal@cwa.bai.ne.jp>
173- First build for Vine2.1.5
174
175* Thu Apr 11 2001 Rex Dieter <rdieter@unl.edu> 1.0.0-0.6x.2
176- redhat6 backport based on rawhide's libmng-1.0.0-2
177
178* Wed Feb 28 2001 Trond Eivind Glomsrd <teg@redhat.com>
179- remove bogus symlink trick
180
181* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
182- Update to 1.0.0 to make Qt 2.3.0 happy
183
184* Sat Jan 19 2001 Bernhard Rosenkraenzer <bero@redhat.com>
185- 0.9.4, fixes MNG 1.0 spec compliance
186
187* Tue Dec 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
188- 0.9.3
189- Add ldconfig calls in %%post and %%postun
190
191* Tue Dec 05 2000 Florian La Roche <Florian.LaRoche@redhat.de>
192- added a clean section to the spec file
193
194* Tue Sep 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
195- initial rpm
196
Note: See TracBrowser for help on using the repository browser.