source: projects/specs/trunk/lib/libm/libmicrohttpd/libmicrohttpd-vl.spec @ 9257

Revision 9257, 5.6 KB checked in by inagaki, 9 years ago (diff)

2015-01-12 Ryoichi INAGAKI <ryo1@…>

  • WindowMaker?-Icons, remmina: rebuilt
  • gutenprint: changed Group
  • libmicrohttpd, pbzip2: updated


Line 
1Summary: Lightweight library for embedding a webserver in applications
2Name: libmicrohttpd
3Version: 0.9.39
4Release: 1%{?_dist_release}
5Group: System Environment/Libraries
6License: LGPLv2+
7URL: http://www.gnu.org/software/libmicrohttpd/
8
9Source0: ftp://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12BuildRequires:  autoconf, automake, libtool
13BuildRequires:  curl-devel
14BuildRequires:  gnutls-devel
15BuildRequires:  libgcrypt-devel
16BuildRequires:  openssl-devel
17BuildRequires:  zlib-devel
18BuildRequires:  graphviz
19BuildRequires:  doxygen
20
21Requires(post): info
22Requires(preun): info
23
24%description
25GNU libmicrohttpd is a small C library that is supposed to make it
26easy to run an HTTP server as part of another application.
27Key features that distinguish libmicrohttpd from other projects are:
28
29* C library: fast and small
30* API is simple, expressive and fully reentrant
31* Implementation is http 1.1 compliant
32* HTTP server can listen on multiple ports
33* Support for IPv6
34* Support for incremental processing of POST data
35* Creates binary of only 25k (for now)
36* Three different threading models
37
38%package devel
39Summary:        Development files for libmicrohttpd
40Summary(ja):    libmicrohttpd の開発用ファイル
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43
44%description devel
45Development files for libmicrohttpd
46
47%package doc
48Summary:        Documentation for libmicrohttpd
49Summary(ja):    libmicrohttpd のドキュメント
50Group:          Documentation
51Buildarch:      noarch
52Requires:       %{name} = %{version}-%{release}
53
54%description doc
55Doxygen documentation for libmicrohttpd and some example source code
56
57%prep
58%setup -q
59
60%build
61%configure --disable-static --with-gnutls
62make %{?_smp_mflags}
63make full -C doc/doxygen
64
65
66# Disabled for now due to problems reported at
67# https://gnunet.org/bugs/view.php?id=1619
68#check
69#make check %{?_smp_mflags}
70
71%install
72rm -rf %{buildroot}
73make install DESTDIR=%{buildroot}
74
75rm -f %{buildroot}%{_libdir}/libmicrohttpd.la
76rm -f %{buildroot}%{_libdir}/libmicrospdy.la
77rm -f %{buildroot}%{_infodir}/dir
78
79# Install some examples in /usr/share/doc/libmicrohttpd-${version}/examples
80rm -rf examples
81mkdir -p examples
82install -m 644 src/examples/*.c examples
83
84# Install the doxygen documentation in /usr/share/doc/libmicrohttpd-${version}/html
85rm -rf html
86cp -R doc/doxygen/html .
87
88%clean
89rm -rf %{buildroot}
90
91%post -p /sbin/ldconfig
92%postun -p /sbin/ldconfig
93
94%post doc
95/sbin/install-info %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
96/sbin/install-info %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
97
98%preun doc
99if [ $1 = 0 ] ; then
100    /sbin/install-info --delete %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
101    /sbin/install-info --delete %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
102fi
103
104%files
105%defattr(-,root,root,-)
106%doc COPYING
107%{_bindir}/microspdy2http
108%{_libdir}/libmicro*.so.*
109
110%files devel
111%defattr(-,root,root,-)
112%{_includedir}/micro*.h
113%{_libdir}/libmicro*.so
114%{_libdir}/pkgconfig/libmicro*.pc
115
116%files doc
117%doc AUTHORS README ChangeLog
118%doc examples
119%doc html
120%defattr(-,root,root,-)
121%{_mandir}/man3/libmicrohttpd.3.gz
122%{_infodir}/libmicrohttpd.info.gz
123%{_infodir}/libmicrohttpd-tutorial.info.gz
124
125%changelog
126* Mon Jan 12 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.39-1
127- updated to 0.9.39
128- built with libgcrypt 1.6.0 and gnutls 3.2.20
129
130* Mon Jan 17 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9.2-1
131- initial build for Vine Linux based on fedora development
132
133* Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-3
134- Add missing BR gnutls-devel and libgcrypt-devel
135- Added patch to fix test apps (NSS instead of GnuTLS/OpenSSL curl,
136  implicit DSO linking)
137- Disable test cases for now due to false errors, reported upstream
138
139* Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-2
140- Re-enable HTTPS, configure flags had unexpected result
141
142* Sun Nov  7 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-1
143- Update to 0.9.2
144
145* Sun Jun  4 2010 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.6-1
146- Update to 0.4.6
147
148* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-2
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
150
151* Tue Jul 21 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.2-1
152- Update to version 0.4.2
153- Drop upstreamed patch
154
155* Fri Feb 27 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0a-1
156- Update to version 0.4.0a
157- Drop upstreamed patch
158- Added a new patch to fix a 64bit issue
159- The -devel package now contains a pkgconfig file
160- The configure script is now run with '--enable-messages --enable-https'
161- Made the -doc subpackage noarch (F11+)
162
163* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
165
166* Sat Feb 14 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0-1
167- Update to version 0.4.0
168- This version introduces a API bump (which is required for
169  supporting large files on 32bit environments)
170- The license issues we had with version 0.3.1 of this package (as
171  discussed in #457924) are resolved in this version. The license
172  of this package is now changed to LGPLv2+
173- Added a patch to fix two testcases on 64bit environments (upstream bug #1454)
174
175* Sat Sep 6 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-3
176- Changed license to GPLv3+ and added some comments
177  regarding the license issues with this package
178
179* Sun Aug 10 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-2
180- Changed license to LGPLv2+
181- Moved the COPYING file to the main package
182
183* Tue Aug 5 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-1
184- Initial release
185
Note: See TracBrowser for help on using the repository browser.