source: projects/specs/trunk/lib/libm/libmicrohttpd/libmicrohttpd-vl.spec @ 12361

Revision 12361, 5.9 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

cryptsetup-2.3.1-1

gdisk-1.0.5-1

kernel-4.14.174-1

lvm2-2.03.09-1

libblockdev-2.23-1

libmicrohttpd-0.9.70-1

udisks-1.0.5-1

udisks2-2.8.4-1

Line 
1Summary: Lightweight library for embedding a webserver in applications
2Name: libmicrohttpd
3Version: 0.9.70
4Release: 1%{?_dist_release}
5Group: System Environment/Libraries
6
7Vendor: Project Vine
8Distribution: Vine Linux
9
10License: LGPLv2+
11URL: https://www.gnu.org/software/libmicrohttpd/
12Source0: https://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires:  autoconf, automake, libtool
16BuildRequires:  curl-devel
17BuildRequires:  gnutls-devel
18BuildRequires:  libgcrypt-devel
19BuildRequires:  openssl-devel
20BuildRequires:  zlib-devel
21BuildRequires:  graphviz
22BuildRequires:  doxygen
23
24Requires(post): info
25Requires(preun): info
26
27%description
28GNU libmicrohttpd is a small C library that is supposed to make it
29easy to run an HTTP server as part of another application.
30Key features that distinguish libmicrohttpd from other projects are:
31
32* C library: fast and small
33* API is simple, expressive and fully reentrant
34* Implementation is http 1.1 compliant
35* HTTP server can listen on multiple ports
36* Support for IPv6
37* Support for incremental processing of POST data
38* Creates binary of only 25k (for now)
39* Three different threading models
40
41%package devel
42Summary:        Development files for libmicrohttpd
43Summary(ja):    libmicrohttpd の開発用ファイル
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46
47%description devel
48Development files for libmicrohttpd
49
50%package doc
51Summary:        Documentation for libmicrohttpd
52Summary(ja):    libmicrohttpd のドキュメント
53Group:          Documentation
54Buildarch:      noarch
55Requires:       %{name} = %{version}-%{release}
56
57%description doc
58Doxygen documentation for libmicrohttpd and some example source code
59
60%prep
61%setup -q
62
63%build
64%configure --disable-static --with-gnutls
65make %{?_smp_mflags}
66make full -C doc/doxygen
67
68
69# Disabled for now due to problems reported at
70# https://gnunet.org/bugs/view.php?id=1619
71#check
72#make check %{?_smp_mflags}
73
74%install
75rm -rf %{buildroot}
76make install DESTDIR=%{buildroot}
77
78rm -f %{buildroot}%{_libdir}/libmicrohttpd.la
79rm -f %{buildroot}%{_libdir}/libmicrospdy.la
80rm -f %{buildroot}%{_infodir}/dir
81
82# Install some examples in /usr/share/doc/libmicrohttpd-${version}/examples
83rm -rf examples
84mkdir -p examples
85install -m 644 src/examples/*.c examples
86
87# Install the doxygen documentation in /usr/share/doc/libmicrohttpd-${version}/html
88rm -rf html
89cp -R doc/doxygen/html .
90
91%clean
92rm -rf %{buildroot}
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%post doc
98/sbin/install-info %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
99/sbin/install-info %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
100
101%preun doc
102if [ $1 = 0 ] ; then
103    /sbin/install-info --delete %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
104    /sbin/install-info --delete %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
105fi
106
107%files
108%defattr(-,root,root,-)
109%license COPYING
110%{_libdir}/libmicro*.so.*
111
112%files devel
113%defattr(-,root,root,-)
114%{_includedir}/micro*.h
115%{_libdir}/libmicro*.so
116%{_libdir}/pkgconfig/libmicro*.pc
117
118%files doc
119%doc AUTHORS README ChangeLog
120%doc examples
121%doc html
122%defattr(-,root,root,-)
123%{_mandir}/man3/libmicrohttpd.3.gz
124%{_infodir}/libmicrohttpd.info.gz
125%{_infodir}/libmicrohttpd_performance_data.png.gz
126%{_infodir}/libmicrohttpd-tutorial.info.gz
127
128%changelog
129* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.70-1
130- rebuilt with current environment.
131
132* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.39-2
133- rebuild with openssl-1.0.2
134
135* Mon Jan 12 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.39-1
136- updated to 0.9.39
137- built with libgcrypt 1.6.0 and gnutls 3.2.20
138
139* Mon Jan 17 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9.2-1
140- initial build for Vine Linux based on fedora development
141
142* Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-3
143- Add missing BR gnutls-devel and libgcrypt-devel
144- Added patch to fix test apps (NSS instead of GnuTLS/OpenSSL curl,
145  implicit DSO linking)
146- Disable test cases for now due to false errors, reported upstream
147
148* Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-2
149- Re-enable HTTPS, configure flags had unexpected result
150
151* Sun Nov  7 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-1
152- Update to 0.9.2
153
154* Fri Jun  4 2010 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.6-1
155- Update to 0.4.6
156
157* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-2
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
159
160* Tue Jul 21 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.2-1
161- Update to version 0.4.2
162- Drop upstreamed patch
163
164* Fri Feb 27 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0a-1
165- Update to version 0.4.0a
166- Drop upstreamed patch
167- Added a new patch to fix a 64bit issue
168- The -devel package now contains a pkgconfig file
169- The configure script is now run with '--enable-messages --enable-https'
170- Made the -doc subpackage noarch (F11+)
171
172* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
174
175* Sat Feb 14 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0-1
176- Update to version 0.4.0
177- This version introduces a API bump (which is required for
178  supporting large files on 32bit environments)
179- The license issues we had with version 0.3.1 of this package (as
180  discussed in #457924) are resolved in this version. The license
181  of this package is now changed to LGPLv2+
182- Added a patch to fix two testcases on 64bit environments (upstream bug #1454)
183
184* Sat Sep 6 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-3
185- Changed license to GPLv3+ and added some comments
186  regarding the license issues with this package
187
188* Sun Aug 10 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-2
189- Changed license to LGPLv2+
190- Moved the COPYING file to the main package
191
192* Tue Aug 5 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-1
193- Initial release
194
Note: See TracBrowser for help on using the repository browser.