source: projects/specs/trunk/lib/libm/libmemcached/libmemcached-vl.spec @ 8200

Revision 8200, 7.6 KB checked in by tomop, 10 years ago (diff)

libmemcached-1.0.17-1, php-ext-mysqlnd_qc-1.2.0-3, postfix-2.10.3-1

Line 
1%bcond_with tests
2
3Name:      libmemcached
4Summary:   Client library and command line tools for memcached server
5Version:   1.0.17
6Release:   1%{?_dist_release}
7License:   BSD
8Group:     System Environment/Libraries
9URL:       http://libmemcached.org/
10# Original sources:
11#   http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
12# The source tarball must be repackaged to remove the Hsieh hash
13# code, since the license is non-free.  When upgrading, download the new
14# source tarball, and run "./strip-hsieh.sh <version>" to produce the
15# "-exhsieh" tarball.
16Source0:   libmemcached-%{version}-exhsieh.tar.gz
17Source1:   strip-hsieh.sh
18
19# fix https://bugs.launchpad.net/libmemcached/+bug/1220452
20Patch0:    libmemcached-memcached.patch
21# fix https://bugs.launchpad.net/libmemcached/+bug/1169311
22Patch1:    0bb781d2-a19f-11e2-90e1-002481e91f22.txt
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25BuildRequires: cyrus-sasl-devel
26BuildRequires: flex bison
27%if %{with tests}
28BuildRequires: memcached
29%endif
30BuildRequires: libevent-devel
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: tomop
35
36%description
37libmemcached is a C/C++ client library and tools for the memcached server
38(http://memcached.org/). It has been designed to be light on memory
39usage, and provide full access to server side methods.
40
41It also implements several command line tools:
42
43memcapable  Checking a Memcached server capibilities and compatibility
44memcat      Copy the value of a key to standard output
45memcp       Copy data to a server
46memdump     Dumping your server
47memerror    Translate an error code to a string
48memexist    Check for the existance of a key
49memflush    Flush the contents of your servers
50memparse    Parse an option string
51memping     Test to see if a server is available.
52memrm       Remove a key(s) from the server
53memslap     Generate testing loads on a memcached cluster
54memstat     Dump the stats of your servers to standard output
55memtouch    Touches a key
56
57
58%package devel
59Summary: Header files and development libraries for %{name}
60Group: Development/Libraries
61Requires: %{name}%{?_isa} = %{version}-%{release}
62Requires: pkgconfig
63Requires: cyrus-sasl-devel%{?_isa}
64
65%description devel
66This package contains the header files and development libraries
67for %{name}. If you like to develop programs using %{name},
68you will need to install %{name}-devel.
69
70
71%prep
72%setup -q
73%patch0 -p1 -b .without-memcached
74%patch1 -p0 -b .compile-option
75
76mkdir examples
77cp -p tests/*.{cc,h} examples/
78
79# Will be regenerated during build
80rm -f libmemcached/csl/{parser,scanner}.cc
81
82# Temporary fix for SASL detection
83sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
84
85# fix library dependency
86# perl -pi -e 's/^(Libs:.+)$/$1 -lpthread/' ./support/libmemcached.pc.in
87
88%build
89aclocal
90autoconf
91automake --add-missing
92
93# option --with-memcached=false to disable server binary check (as we don't run test)
94%configure --disable-static \
95%if ! %{with tests}
96   --with-memcached=false
97%endif
98
99make %{_smp_mflags}
100
101
102%install
103rm -rf %{buildroot}
104make install  DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
105
106
107%check
108%if %{with tests}
109# test suite cannot run in mock (same port use for memcache servers on all arch)
110# All tests completed successfully
111# diff output.res output.cmp fails but result depend on server version
112make test
113%else
114echo 'Test suite disabled (missing "--with tests" option)'
115%endif
116
117
118%clean
119rm -rf %{buildroot}
120
121
122%post
123/sbin/ldconfig
124
125
126%postun
127/sbin/ldconfig
128 
129
130%files
131%defattr (-,root,root,-)
132%doc AUTHORS COPYING README THANKS TODO ChangeLog
133%{_bindir}/mem*
134%exclude %{_libdir}/lib*.la
135%{_libdir}/lib*.so.*
136%{_mandir}/man1/mem*
137
138
139%files devel
140%defattr (-,root,root,-)
141%doc examples
142%{_datadir}/aclocal/ax_libmemcached.m4
143%{_includedir}/*
144%{_libdir}/lib*.so
145%{_libdir}/pkgconfig/libmemcached.pc
146%{_mandir}/man3/libmemcached*
147%{_mandir}/man3/libhashkit*
148%{_mandir}/man3/memcached*
149%{_mandir}/man3/hashkit*
150
151
152%changelog
153* Sat Jan 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.17-1
154- new upstream release.
155
156* Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
157- built for Vine Linux.
158
159* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
160- update to 1.0.7
161- regenerate parser using flex/bison (#816766)
162
163* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
164- workaround for SASL detection
165
166* Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
167- update to 1.0.6
168- soname bump to libmemcached.so.10 and libhashkit.so.2
169
170* Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
171- update to 1.0.4
172- soname bump to libmemcached.so.9
173- update description
174
175* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
176- Rebuilt for c++ ABI breakage
177
178* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
180
181* Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
182- update to 1.0.2
183
184* Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
185- update to 0.53
186
187* Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
188- update to 0.52
189
190* Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
191- update to 0.51 (soname bump libmemcached.so.8)
192
193* Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
194- update to 0.49
195- add build option : --with tests
196
197* Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
198- update to 0.47
199- remove patch merged upstream
200
201* Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
202- patch Makefile.in instead of include.am (to avoid autoconf)
203- donc requires pkgconfig with arch
204
205* Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
206- update to 0.46
207
208* Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
209- arch specific requires
210
211* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
213
214* Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
215- repackage source tarball to remove non-free Hsieh hash code
216
217* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
218- improves SASL patch
219
220* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
221- enable SASL support
222
223* Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
224- update to 0.44
225- add soname version in %%file to detect change
226
227* Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
228- update to 0.43
229
230* Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
231- update to 0.42
232
233* Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
234- update to 0.40 (new soname for libmemcached.so.5)
235- new URI (site + source)
236
237* Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
238- update to 0.38
239
240* Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
241- update to 0.37 (soname bump)
242- new libhashkit (should be a separated project in the futur)
243
244* Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
245- update to 0.31
246
247* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
249
250* Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
251- update to 0.30
252
253* Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
254- update to 0.29
255
256* Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
257- add upstream patch to disable nonfree hsieh hash method
258
259* Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
260- Initial RPM from Brian Aker spec
261- create -devel subpackage
262- add %%post %%postun %%check section
263
Note: See TracBrowser for help on using the repository browser.