source: projects/specs/trunk/lib/libm/libmemcached/libmemcached-vl.spec @ 12406

Revision 12406, 7.9 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

dovecot-2.3.10.1-1

libmemcached-1.0.18-3

postfix-3.5.2-1

Line 
1%bcond_with tests
2
3Name:           libmemcached
4Summary:        Client library and command line tools for memcached server
5Version:        1.0.18
6Release:        3%{?_dist_release}
7Group:          System Environment/Libraries
8Vendor:         Project Vine
9Distribution:   Vine Linux
10Packager:       tomop
11
12License:        BSD
13URL:            http://libmemcached.org/
14# Original sources:
15#   http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
16# The source tarball must be repackaged to remove the Hsieh hash
17# code, since the license is non-free.  When upgrading, download the new
18# source tarball, and run "./strip-hsieh.sh <version>" to produce the
19# "-exhsieh" tarball.
20Source0:        libmemcached-%{version}-exhsieh.tar.gz
21Source1:        strip-hsieh.sh
22
23Patch0:         move-ax_confix_aux_dir.patch
24Patch1:         fix-gcc7-build.diff
25Patch2:         c++11.patch
26Patch3:         m4_pthread.patch
27
28BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
29BuildRequires:  cyrus-sasl-devel
30BuildRequires:  flex bison
31%if %{with tests}
32BuildRequires:  memcached
33%endif
34BuildRequires:  libevent-devel
35
36%description
37libmemcached is a C/C++ client library and tools for the memcached server
38(http://memcached.org/). It has been designed to be light on memory
39usage, and provide full access to server side methods.
40
41It also implements several command line tools:
42
43memcapable  Checking a Memcached server capibilities and compatibility
44memcat      Copy the value of a key to standard output
45memcp       Copy data to a server
46memdump     Dumping your server
47memerror    Translate an error code to a string
48memexist    Check for the existance of a key
49memflush    Flush the contents of your servers
50memparse    Parse an option string
51memping     Test to see if a server is available.
52memrm       Remove a key(s) from the server
53memslap     Generate testing loads on a memcached cluster
54memstat     Dump the stats of your servers to standard output
55memtouch    Touches a key
56
57
58%package devel
59Summary: Header files and development libraries for %{name}
60Group: Development/Libraries
61Requires: %{name}%{?_isa} = %{version}-%{release}
62Requires: pkgconfig
63Requires: cyrus-sasl-devel%{?_isa}
64
65%description devel
66This package contains the header files and development libraries
67for %{name}. If you like to develop programs using %{name},
68you will need to install %{name}-devel.
69
70
71%prep
72%setup -q
73%autopatch -p1
74
75mkdir examples
76cp -p tests/*.{cc,h} examples/
77
78# Will be regenerated during build
79rm -f libmemcached/csl/{parser,scanner}.cc
80
81# Temporary fix for SASL detection
82sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
83
84# fix library dependency
85# perl -pi -e 's/^(Libs:.+)$/$1 -lpthread/' ./support/libmemcached.pc.in
86
87
88%build
89autoreconf -fiv
90
91# option --with-memcached=false to disable server binary check (as we don't run test)
92%configure --disable-static \
93%if ! %{with tests}
94   --with-memcached=false
95%endif
96
97make %{_smp_mflags}
98
99
100%install
101rm -rf %{buildroot}
102make install  DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
103
104
105%check
106%if %{with tests}
107# test suite cannot run in mock (same port use for memcache servers on all arch)
108# All tests completed successfully
109# diff output.res output.cmp fails but result depend on server version
110make test
111%else
112echo 'Test suite disabled (missing "--with tests" option)'
113%endif
114
115
116%clean
117rm -rf %{buildroot}
118
119
120%post
121/sbin/ldconfig
122
123%postun
124/sbin/ldconfig
125 
126
127%files
128%defattr (-,root,root,-)
129%license COPYING
130%doc AUTHORS README THANKS TODO ChangeLog
131%{_bindir}/mem*
132%exclude %{_libdir}/lib*.la
133%{_libdir}/lib*.so.*
134%{_mandir}/man1/mem*
135
136%files devel
137%defattr (-,root,root,-)
138%doc examples
139%{_datadir}/aclocal/ax_libmemcached.m4
140%{_includedir}/*
141%{_libdir}/lib*.so
142%{_libdir}/pkgconfig/libmemcached.pc
143%{_mandir}/man3/libmemcached*
144%{_mandir}/man3/libhashkit*
145%{_mandir}/man3/memcached*
146%{_mandir}/man3/hashkit*
147
148
149%changelog
150* Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-3
151- rebuilt with current environment.
152- imported Patch0-3 from debian.
153
154* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.18-2
155- rebuild with gcc-5.4.0
156
157* Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-1
158- new upstream release.
159- removed all patches (fixed in upstream).
160
161* Sat Jan 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.17-1
162- new upstream release.
163
164* Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
165- built for Vine Linux.
166
167* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
168- update to 1.0.7
169- regenerate parser using flex/bison (#816766)
170
171* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
172- workaround for SASL detection
173
174* Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
175- update to 1.0.6
176- soname bump to libmemcached.so.10 and libhashkit.so.2
177
178* Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
179- update to 1.0.4
180- soname bump to libmemcached.so.9
181- update description
182
183* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
184- Rebuilt for c++ ABI breakage
185
186* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
188
189* Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
190- update to 1.0.2
191
192* Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
193- update to 0.53
194
195* Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
196- update to 0.52
197
198* Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
199- update to 0.51 (soname bump libmemcached.so.8)
200
201* Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
202- update to 0.49
203- add build option : --with tests
204
205* Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
206- update to 0.47
207- remove patch merged upstream
208
209* Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
210- patch Makefile.in instead of include.am (to avoid autoconf)
211- donc requires pkgconfig with arch
212
213* Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
214- update to 0.46
215
216* Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
217- arch specific requires
218
219* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
220- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
221
222* Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
223- repackage source tarball to remove non-free Hsieh hash code
224
225* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
226- improves SASL patch
227
228* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
229- enable SASL support
230
231* Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
232- update to 0.44
233- add soname version in %%file to detect change
234
235* Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
236- update to 0.43
237
238* Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
239- update to 0.42
240
241* Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
242- update to 0.40 (new soname for libmemcached.so.5)
243- new URI (site + source)
244
245* Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
246- update to 0.38
247
248* Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
249- update to 0.37 (soname bump)
250- new libhashkit (should be a separated project in the futur)
251
252* Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
253- update to 0.31
254
255* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
256- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
257
258* Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
259- update to 0.30
260
261* Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
262- update to 0.29
263
264* Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
265- add upstream patch to disable nonfree hsieh hash method
266
267* Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
268- Initial RPM from Brian Aker spec
269- create -devel subpackage
270- add %%post %%postun %%check section
271
Note: See TracBrowser for help on using the repository browser.