source: projects/specs/trunk/lib/libm/libmemcached/libmemcached-vl.spec @ 10570

Revision 10570, 7.5 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%bcond_with tests
2
3Name:      libmemcached
4Summary:   Client library and command line tools for memcached server
5Version:   1.0.18
6Release:   2%{?_dist_release}
7License:   BSD
8Group:     System Environment/Libraries
9URL:       http://libmemcached.org/
10# Original sources:
11#   http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
12# The source tarball must be repackaged to remove the Hsieh hash
13# code, since the license is non-free.  When upgrading, download the new
14# source tarball, and run "./strip-hsieh.sh <version>" to produce the
15# "-exhsieh" tarball.
16Source0:   libmemcached-%{version}-exhsieh.tar.gz
17Source1:   strip-hsieh.sh
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20BuildRequires: cyrus-sasl-devel
21BuildRequires: flex bison
22%if %{with tests}
23BuildRequires: memcached
24%endif
25BuildRequires: libevent-devel
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: tomop
30
31%description
32libmemcached is a C/C++ client library and tools for the memcached server
33(http://memcached.org/). It has been designed to be light on memory
34usage, and provide full access to server side methods.
35
36It also implements several command line tools:
37
38memcapable  Checking a Memcached server capibilities and compatibility
39memcat      Copy the value of a key to standard output
40memcp       Copy data to a server
41memdump     Dumping your server
42memerror    Translate an error code to a string
43memexist    Check for the existance of a key
44memflush    Flush the contents of your servers
45memparse    Parse an option string
46memping     Test to see if a server is available.
47memrm       Remove a key(s) from the server
48memslap     Generate testing loads on a memcached cluster
49memstat     Dump the stats of your servers to standard output
50memtouch    Touches a key
51
52
53%package devel
54Summary: Header files and development libraries for %{name}
55Group: Development/Libraries
56Requires: %{name}%{?_isa} = %{version}-%{release}
57Requires: pkgconfig
58Requires: cyrus-sasl-devel%{?_isa}
59
60%description devel
61This package contains the header files and development libraries
62for %{name}. If you like to develop programs using %{name},
63you will need to install %{name}-devel.
64
65
66%prep
67%setup -q
68
69mkdir examples
70cp -p tests/*.{cc,h} examples/
71
72# Will be regenerated during build
73rm -f libmemcached/csl/{parser,scanner}.cc
74
75# Temporary fix for SASL detection
76sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
77
78# fix library dependency
79# perl -pi -e 's/^(Libs:.+)$/$1 -lpthread/' ./support/libmemcached.pc.in
80
81%build
82aclocal
83autoconf
84automake --add-missing
85
86# option --with-memcached=false to disable server binary check (as we don't run test)
87%configure --disable-static \
88%if ! %{with tests}
89   --with-memcached=false
90%endif
91
92make %{_smp_mflags}
93
94
95%install
96rm -rf %{buildroot}
97make install  DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
98
99
100%check
101%if %{with tests}
102# test suite cannot run in mock (same port use for memcache servers on all arch)
103# All tests completed successfully
104# diff output.res output.cmp fails but result depend on server version
105make test
106%else
107echo 'Test suite disabled (missing "--with tests" option)'
108%endif
109
110
111%clean
112rm -rf %{buildroot}
113
114
115%post
116/sbin/ldconfig
117
118
119%postun
120/sbin/ldconfig
121 
122
123%files
124%defattr (-,root,root,-)
125%doc AUTHORS COPYING README THANKS TODO ChangeLog
126%{_bindir}/mem*
127%exclude %{_libdir}/lib*.la
128%{_libdir}/lib*.so.*
129%{_mandir}/man1/mem*
130
131
132%files devel
133%defattr (-,root,root,-)
134%doc examples
135%{_datadir}/aclocal/ax_libmemcached.m4
136%{_includedir}/*
137%{_libdir}/lib*.so
138%{_libdir}/pkgconfig/libmemcached.pc
139%{_mandir}/man3/libmemcached*
140%{_mandir}/man3/libhashkit*
141%{_mandir}/man3/memcached*
142%{_mandir}/man3/hashkit*
143
144
145%changelog
146* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.18-2
147- rebuild with gcc-5.4.0
148
149* Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-1
150- new upstream release.
151- removed all patches (fixed in upstream).
152
153* Sat Jan 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.17-1
154- new upstream release.
155
156* Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
157- built for Vine Linux.
158
159* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
160- update to 1.0.7
161- regenerate parser using flex/bison (#816766)
162
163* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
164- workaround for SASL detection
165
166* Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
167- update to 1.0.6
168- soname bump to libmemcached.so.10 and libhashkit.so.2
169
170* Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
171- update to 1.0.4
172- soname bump to libmemcached.so.9
173- update description
174
175* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
176- Rebuilt for c++ ABI breakage
177
178* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
180
181* Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
182- update to 1.0.2
183
184* Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
185- update to 0.53
186
187* Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
188- update to 0.52
189
190* Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
191- update to 0.51 (soname bump libmemcached.so.8)
192
193* Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
194- update to 0.49
195- add build option : --with tests
196
197* Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
198- update to 0.47
199- remove patch merged upstream
200
201* Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
202- patch Makefile.in instead of include.am (to avoid autoconf)
203- donc requires pkgconfig with arch
204
205* Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
206- update to 0.46
207
208* Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
209- arch specific requires
210
211* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
213
214* Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
215- repackage source tarball to remove non-free Hsieh hash code
216
217* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
218- improves SASL patch
219
220* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
221- enable SASL support
222
223* Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
224- update to 0.44
225- add soname version in %%file to detect change
226
227* Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
228- update to 0.43
229
230* Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
231- update to 0.42
232
233* Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
234- update to 0.40 (new soname for libmemcached.so.5)
235- new URI (site + source)
236
237* Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
238- update to 0.38
239
240* Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
241- update to 0.37 (soname bump)
242- new libhashkit (should be a separated project in the futur)
243
244* Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
245- update to 0.31
246
247* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
249
250* Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
251- update to 0.30
252
253* Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
254- update to 0.29
255
256* Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
257- add upstream patch to disable nonfree hsieh hash method
258
259* Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
260- Initial RPM from Brian Aker spec
261- create -devel subpackage
262- add %%post %%postun %%check section
263
Note: See TracBrowser for help on using the repository browser.