source: projects/specs/trunk/lib/libm/libmemcached/libmemcached-vl.spec @ 9498

Revision 9498, 7.4 KB checked in by tomop, 9 years ago (diff)

libmemcached-1.0.18-1

Line 
1%bcond_with tests
2
3Name:      libmemcached
4Summary:   Client library and command line tools for memcached server
5Version:   1.0.18
6Release:   1%{?_dist_release}
7License:   BSD
8Group:     System Environment/Libraries
9URL:       http://libmemcached.org/
10# Original sources:
11#   http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
12# The source tarball must be repackaged to remove the Hsieh hash
13# code, since the license is non-free.  When upgrading, download the new
14# source tarball, and run "./strip-hsieh.sh <version>" to produce the
15# "-exhsieh" tarball.
16Source0:   libmemcached-%{version}-exhsieh.tar.gz
17Source1:   strip-hsieh.sh
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20BuildRequires: cyrus-sasl-devel
21BuildRequires: flex bison
22%if %{with tests}
23BuildRequires: memcached
24%endif
25BuildRequires: libevent-devel
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: tomop
30
31%description
32libmemcached is a C/C++ client library and tools for the memcached server
33(http://memcached.org/). It has been designed to be light on memory
34usage, and provide full access to server side methods.
35
36It also implements several command line tools:
37
38memcapable  Checking a Memcached server capibilities and compatibility
39memcat      Copy the value of a key to standard output
40memcp       Copy data to a server
41memdump     Dumping your server
42memerror    Translate an error code to a string
43memexist    Check for the existance of a key
44memflush    Flush the contents of your servers
45memparse    Parse an option string
46memping     Test to see if a server is available.
47memrm       Remove a key(s) from the server
48memslap     Generate testing loads on a memcached cluster
49memstat     Dump the stats of your servers to standard output
50memtouch    Touches a key
51
52
53%package devel
54Summary: Header files and development libraries for %{name}
55Group: Development/Libraries
56Requires: %{name}%{?_isa} = %{version}-%{release}
57Requires: pkgconfig
58Requires: cyrus-sasl-devel%{?_isa}
59
60%description devel
61This package contains the header files and development libraries
62for %{name}. If you like to develop programs using %{name},
63you will need to install %{name}-devel.
64
65
66%prep
67%setup -q
68
69mkdir examples
70cp -p tests/*.{cc,h} examples/
71
72# Will be regenerated during build
73rm -f libmemcached/csl/{parser,scanner}.cc
74
75# Temporary fix for SASL detection
76sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
77
78# fix library dependency
79# perl -pi -e 's/^(Libs:.+)$/$1 -lpthread/' ./support/libmemcached.pc.in
80
81%build
82aclocal
83autoconf
84automake --add-missing
85
86# option --with-memcached=false to disable server binary check (as we don't run test)
87%configure --disable-static \
88%if ! %{with tests}
89   --with-memcached=false
90%endif
91
92make %{_smp_mflags}
93
94
95%install
96rm -rf %{buildroot}
97make install  DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
98
99
100%check
101%if %{with tests}
102# test suite cannot run in mock (same port use for memcache servers on all arch)
103# All tests completed successfully
104# diff output.res output.cmp fails but result depend on server version
105make test
106%else
107echo 'Test suite disabled (missing "--with tests" option)'
108%endif
109
110
111%clean
112rm -rf %{buildroot}
113
114
115%post
116/sbin/ldconfig
117
118
119%postun
120/sbin/ldconfig
121 
122
123%files
124%defattr (-,root,root,-)
125%doc AUTHORS COPYING README THANKS TODO ChangeLog
126%{_bindir}/mem*
127%exclude %{_libdir}/lib*.la
128%{_libdir}/lib*.so.*
129%{_mandir}/man1/mem*
130
131
132%files devel
133%defattr (-,root,root,-)
134%doc examples
135%{_datadir}/aclocal/ax_libmemcached.m4
136%{_includedir}/*
137%{_libdir}/lib*.so
138%{_libdir}/pkgconfig/libmemcached.pc
139%{_mandir}/man3/libmemcached*
140%{_mandir}/man3/libhashkit*
141%{_mandir}/man3/memcached*
142%{_mandir}/man3/hashkit*
143
144
145%changelog
146* Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-1
147- new upstream release.
148- removed all patches (fixed in upstream).
149
150* Sat Jan 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.17-1
151- new upstream release.
152
153* Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
154- built for Vine Linux.
155
156* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
157- update to 1.0.7
158- regenerate parser using flex/bison (#816766)
159
160* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
161- workaround for SASL detection
162
163* Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
164- update to 1.0.6
165- soname bump to libmemcached.so.10 and libhashkit.so.2
166
167* Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
168- update to 1.0.4
169- soname bump to libmemcached.so.9
170- update description
171
172* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
173- Rebuilt for c++ ABI breakage
174
175* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
177
178* Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
179- update to 1.0.2
180
181* Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
182- update to 0.53
183
184* Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
185- update to 0.52
186
187* Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
188- update to 0.51 (soname bump libmemcached.so.8)
189
190* Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
191- update to 0.49
192- add build option : --with tests
193
194* Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
195- update to 0.47
196- remove patch merged upstream
197
198* Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
199- patch Makefile.in instead of include.am (to avoid autoconf)
200- donc requires pkgconfig with arch
201
202* Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
203- update to 0.46
204
205* Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
206- arch specific requires
207
208* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
209- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
210
211* Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
212- repackage source tarball to remove non-free Hsieh hash code
213
214* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
215- improves SASL patch
216
217* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
218- enable SASL support
219
220* Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
221- update to 0.44
222- add soname version in %%file to detect change
223
224* Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
225- update to 0.43
226
227* Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
228- update to 0.42
229
230* Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
231- update to 0.40 (new soname for libmemcached.so.5)
232- new URI (site + source)
233
234* Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
235- update to 0.38
236
237* Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
238- update to 0.37 (soname bump)
239- new libhashkit (should be a separated project in the futur)
240
241* Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
242- update to 0.31
243
244* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
245- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
246
247* Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
248- update to 0.30
249
250* Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
251- update to 0.29
252
253* Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
254- add upstream patch to disable nonfree hsieh hash method
255
256* Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
257- Initial RPM from Brian Aker spec
258- create -devel subpackage
259- add %%post %%postun %%check section
260
Note: See TracBrowser for help on using the repository browser.