source: projects/specs/trunk/lib/libm/libmediainfo/libmediainfo-vl.spec @ 4837

Revision 4837, 7.0 KB checked in by kudoh, 13 years ago (diff)

# Copyright (c) 2007-2008 oc2pus
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments to toni@…
#
# * This spec is modified for Vine Linux *

# norootforbuild

%define _prefix /usr
# %define _SO_nr 0
# %define libzen_version 0.3.6
# %define libzen_SO_nr 0

Name: libmediainfo
Version: 0.7.50
Release: 1%{?_dist_release}
Summary: Supplies technical and tag information about a video or audio file
Summary(ja): ビデオとオーディオファイルの詳細な情報を提供するライブラリ
Group: System Environment/Libraries?
License: GPL
URL:  http://mediainfo.sourceforge.net/
Source0: libmediainfo_%{version}.tar.bz2
BuildRoot?: %{_tmppath}/%{name}-%{version}-%{release}-root
## BuildRequires?: dos2unix
BuildRequires?: nkf

## NEED GCC3
BuildRequires?: gcc-c++
BuildRequires?: libzen-devel
BuildRequires?: pkgconfig
BuildRequires?: zlib-devel
BuildRequires?: doxygen
Requires: libzen

Packager: babasaki

%description
MediaInfo? supplies technical and tag information about a video or
audio file.

What information can I get from MediaInfo??

  • General: title, author, director, album, track number, date, duration...
  • Video: codec, aspect, fps, bitrate...
  • Audio: codec, sample rate, channels, language, bitrate...
  • Text: language of subtitle
  • Chapters: number of chapters, list of chapters

DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime?,
RealVideo?, RealAudio?, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2

What format (container) does MediaInfo? support?

  • Video: MKV, OGM, AVI, DivX, WMV, QuickTime?, Real, MPEG-1, MPEG-2, MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
  • Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
  • Subtitles: SRT, SSA, ASS, SAMI

This package contains the shared library for MediaInfo?(-gui).

%description -l ja
MediaInfo? はビデオとオーディオファイルの詳細な情報を提供します。

MediaInfo? で確認できる情報:

  • 全般: タイトル、作者、ディレクター、アルバム、トラック番号、 日付、時間...
  • ビデオ: codec、アスペクト比、フレームレート、ビットレート...
  • オーディオ: codec、サンプリングレート、チャンネル数、言語、 ビットレート...
  • テキスト: 字幕の言語
  • チャプター: チャプター数、チャプターの一覧

DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime?,
RealVideo?, RealAudio?, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2

MediaInfo? がサポートするフォーマット:

  • ビデオ: MKV, OGM, AVI, DivX, WMV, QuickTime?, Real, MPEG-1, MPEG-2, MPEG-4, DVD (VOB) (Codec: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
  • オーディオ: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
  • 字幕: SRT, SSA, ASS, SAMI

このパッケージは Mediainfo(-gui) 用の共有ライブラリを含んでい
ます。

%package -n libmediainfo-devel
Summary: Include files and mandatory librariesfor development
Summary(ja): libmediainfo の開発用のヘッダとライブラリファイル
Group: Development/Libraries?
Requires: libmediainfo = %{version}
#Requires: libzen = %{libzen_version}
Requires: libzen

%description -n libmediainfo-devel
Include files and mandatory librariesfor development.

%description -n libmediainfo-devel -l ja
libmediainfo の開発用のヘッダとライブラリファイルです。

%prep
%setup -q -n MediaInfoLib?
cp Release/ReadMe_DLL_Linux.txt ReadMe?.txt
mv History_DLL.txt History.txt
## dos2unix *.txt *.html Source/Doc/?*.html
nkf --unix --overwrite *.txt *.html Source/Doc/?*.html

%chmod 644 *.txt *.html Source/Doc/?*.html

%build
export CFLAGS="$RPM_OPT_FLAGS"
export CPPFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS"

pushd Source/Doc/?

doxygen Doxyfile

popd
cp Source/Doc/?*.html ./

pushd Project/GNU/Library

%chmod +x autogen
./autogen
%configure --enable-shared --disable-static

%make clean
%
make %{?jobs:-j%{jobs}}

popd

%install
pushd Project/GNU/Library/

%make install-strip DESTDIR=%{buildroot}

popd

# MediaInfoDLL headers and MediaInfo?-config
for i in MediaInfo? MediaInfoDLL; do

%install -dm 755 %{buildroot}%{_includedir}/$i
%
install -m 644 Source/$i/*.h \

%{buildroot}%{_includedir}/$i

done

%sed -i -e 's|Version: |Version: %{version}|g' \

Project/GNU/Library/libmediainfo.pc

%install -dm 755 %{buildroot}%{_libdir}/pkgconfig
%install -m 644 Project/GNU/Library/libmediainfo.pc \

%{buildroot}%{_libdir}/pkgconfig

# remove unpackaged files
rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la

%clean
[ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %rm -rf "%{buildroot}"

%post -n libmediainfo -p /sbin/ldconfig

%postun -n libmediainfo -p /sbin/ldconfig

%files
%defattr(-,root,root,-)
%doc History.txt License.html ReadMe?.txt
%{_libdir}/libmediainfo.so.*

%files -n libmediainfo-devel
%defattr(-,root,root,-)
%doc Changes.txt Documentation.html Doc/*
%dir %{_includedir}/MediaInfo?
%{_includedir}/MediaInfo/?*
%dir %{_includedir}/MediaInfoDLL
%{_includedir}/MediaInfoDLL/*
#%{_libdir}/libmediainfo.a
#%{_libdir}/libmediainfo.la
%{_libdir}/libmediainfo.so
%{_libdir}/pkgconfig/*.pc

%changelog

  • Tue Sep 27 2011 Toshiharu Kudoh <toshi.kd2@…> 0.7.50-1
  • new upstream release
  • Fri Jul 15 2011 Toshiharu Kudoh <toshi.kd2@…> 0.7.47-1
  • new upstream release
  • Wed Jan 26 2011 Toshiharu Kudoh <toshi.kd2@…> 0.7.41-1
  • new upstream release
  • Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@…> 0.7.38-1
  • new upstream release
  • Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@…> 0.7.37-1
  • new upstream release
  • Mon Sep 27 2010 Shu KONNO <owa@…> 0.7.35-2
  • rebuilt with rpm-4.8.1 for pkg-config
  • Fri Sep 10 2010 Toshiharu Kudoh <toshi.kd2@…> 0.7.35-1
  • new upstream release
  • Tue Jul 27 2010 Toshiharu Kudoh <toshi.kd2@…> 0.7.34-1
  • new upstream release
  • Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@…> 0.7.33-1
  • new upstream release
  • Thu Oct 29 2009 Toshiharu Kudoh <toshi.kd2@…> 0.7.23-1
  • new upstream release
  • Mon Oct 12 2009 Toshiharu Kudoh <toshi.kd2@…> 0.7.22-1
  • new upstream release
  • Tue Jul 28 2009 Kazutaka HARADA <kazutaka@…> 0.7.19-1
  • new upstream release
  • change spec file name to libmediainfo-vl.spec
  • add japanese summary and description
  • change group for -devel sub package to Development/Libraries?
  • not to specify %{libzen_version} strictly
  • add configure option --disable-static
  • remove unpackaged file (.la)
  • add Packager tag
  • Tue Jan 01 2009 Jerome Martinez <zen@…> - 0.7.9-0
  • See History.txt for more info and real dates
  • Previous packages made by Toni Graffy <toni@…>
Line 
1# Copyright (c) 2007-2008 oc2pus
2# This file and all modifications and additions to the pristine
3# package are under the same license as the package itself.
4#
5# Please submit bugfixes or comments to toni@links2linux.de
6#
7# *** This spec is modified for Vine Linux ***
8
9# norootforbuild
10
11%define _prefix /usr
12# %define _SO_nr        0
13# %define libzen_version        0.3.6
14# %define libzen_SO_nr  0
15
16Name:                   libmediainfo
17Version:                0.7.50
18Release:                1%{?_dist_release}
19Summary:                Supplies technical and tag information about a video or audio file
20Summary(ja):            ビデオとオーディオファイルの詳細な情報を提供するライブラリ
21Group:                  System Environment/Libraries
22License:                GPL
23URL:                    http://mediainfo.sourceforge.net/
24Source0:                libmediainfo_%{version}.tar.bz2
25BuildRoot:              %{_tmppath}/%{name}-%{version}-%{release}-root
26## BuildRequires:       dos2unix
27BuildRequires:          nkf
28
29## NEED GCC3
30BuildRequires:  gcc-c++
31BuildRequires:  libzen-devel
32BuildRequires:  pkgconfig
33BuildRequires:  zlib-devel
34BuildRequires:  doxygen
35Requires:       libzen
36
37Packager:               babasaki
38
39%description
40MediaInfo supplies technical and tag information about a video or
41audio file.
42
43What information can I get from MediaInfo?
44* General: title, author, director, album, track number, date, duration...
45* Video: codec, aspect, fps, bitrate...
46* Audio: codec, sample rate, channels, language, bitrate...
47* Text: language of subtitle
48* Chapters: number of chapters, list of chapters
49
50DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
51MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime,
52RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
53VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
54
55What format (container) does MediaInfo support?
56* Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
57  MPEG-2, MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP,
58  H.264, AVC...)
59* Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
60* Subtitles: SRT, SSA, ASS, SAMI
61
62This package contains the shared library for MediaInfo(-gui).
63
64%description -l ja
65MediaInfo はビデオとオーディオファイルの詳細な情報を提供します。
66
67MediaInfo で確認できる情報:
68* 全般: タイトル、作者、ディレクター、アルバム、トラック番号、
69  日付、時間...
70* ビデオ: codec、アスペクト比、フレームレート、ビットレート...
71* オーディオ: codec、サンプリングレート、チャンネル数、言語、
72  ビットレート...
73* テキスト: 字幕の言語
74* チャプター: チャプター数、チャプターの一覧
75
76DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
77MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime,
78RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
79VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
80
81MediaInfo がサポートするフォーマット:
82* ビデオ: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
83  MPEG-2, MPEG-4, DVD (VOB) (Codec: DivX, XviD, MSMPEG4, ASP,
84  H.264, AVC...)
85* オーディオ: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
86* 字幕: SRT, SSA, ASS, SAMI
87
88このパッケージは Mediainfo(-gui) 用の共有ライブラリを含んでい
89ます。
90
91
92%package -n libmediainfo-devel
93Summary:        Include files and mandatory librariesfor development
94Summary(ja):    libmediainfo の開発用のヘッダとライブラリファイル
95Group:          Development/Libraries
96Requires:       libmediainfo = %{version}
97#Requires:      libzen = %{libzen_version}
98Requires:       libzen
99
100%description -n libmediainfo-devel
101Include files and mandatory librariesfor development.
102
103%description -n libmediainfo-devel -l ja
104libmediainfo の開発用のヘッダとライブラリファイルです。
105
106%prep
107%setup -q -n MediaInfoLib
108cp           Release/ReadMe_DLL_Linux.txt ReadMe.txt
109mv           History_DLL.txt History.txt
110## dos2unix     *.txt *.html Source/Doc/*.html
111nkf --unix --overwrite *.txt *.html Source/Doc/*.html
112
113%__chmod 644 *.txt *.html Source/Doc/*.html
114
115%build
116export CFLAGS="$RPM_OPT_FLAGS"
117export CPPFLAGS="$RPM_OPT_FLAGS"
118export CXXFLAGS="$RPM_OPT_FLAGS"
119
120pushd Source/Doc/
121        doxygen Doxyfile
122popd
123cp Source/Doc/*.html ./
124
125pushd Project/GNU/Library
126        %__chmod +x autogen
127        ./autogen
128        %configure --enable-shared --disable-static
129
130        %__make clean
131        %__make %{?jobs:-j%{jobs}}
132popd
133
134%install
135pushd Project/GNU/Library/
136        %__make install-strip DESTDIR=%{buildroot}
137popd
138
139# MediaInfoDLL headers and MediaInfo-config
140for i in MediaInfo MediaInfoDLL; do
141        %__install -dm 755 %{buildroot}%{_includedir}/$i
142        %__install -m 644 Source/$i/*.h \
143                %{buildroot}%{_includedir}/$i
144done
145
146%__sed -i -e 's|Version: |Version: %{version}|g' \
147        Project/GNU/Library/libmediainfo.pc
148%__install -dm 755 %{buildroot}%{_libdir}/pkgconfig
149%__install -m 644 Project/GNU/Library/libmediainfo.pc \
150        %{buildroot}%{_libdir}/pkgconfig
151
152# remove unpackaged files
153rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la
154
155%clean
156[ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %__rm -rf "%{buildroot}"
157
158%post -n libmediainfo -p /sbin/ldconfig
159
160%postun -n libmediainfo -p /sbin/ldconfig
161
162%files
163%defattr(-,root,root,-)
164%doc History.txt License.html ReadMe.txt
165%{_libdir}/libmediainfo.so.*
166
167%files -n libmediainfo-devel
168%defattr(-,root,root,-)
169%doc Changes.txt Documentation.html Doc/*
170%dir %{_includedir}/MediaInfo
171%{_includedir}/MediaInfo/*
172%dir %{_includedir}/MediaInfoDLL
173%{_includedir}/MediaInfoDLL/*
174#%{_libdir}/libmediainfo.a
175#%{_libdir}/libmediainfo.la
176%{_libdir}/libmediainfo.so
177%{_libdir}/pkgconfig/*.pc
178
179%changelog
180* Tue Sep 27 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.50-1
181- new upstream release
182
183* Fri Jul 15 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.47-1
184- new upstream release
185
186* Wed Jan 26 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.41-1
187- new upstream release
188
189* Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.38-1
190- new upstream release
191
192* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.37-1
193- new upstream release
194
195* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.35-2
196- rebuilt with rpm-4.8.1 for pkg-config
197
198* Fri Sep 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.35-1
199- new upstream release
200
201* Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.34-2
202- fixed Group to System Environment/Libraries
203
204* Tue Jul 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.34-1
205- new upstream release
206
207* Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.33-1
208- new upstream release
209
210* Thu Oct 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.23-1
211- new upstream release
212
213* Mon Oct 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.22-1
214- new upstream release
215
216* Tue Jul 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7.19-1
217- new upstream release
218- change spec file name to libmediainfo-vl.spec
219- add japanese summary and description
220- change group for -devel sub package to Development/Libraries
221- not to specify %{libzen_version} strictly
222- add configure option --disable-static
223- remove unpackaged file (.la)
224- add Packager tag
225
226* Tue Jan 01 2009 Jerome Martinez <zen@mediaarea.net> - 0.7.9-0
227- See History.txt for more info and real dates
228- Previous packages made by Toni Graffy <toni@links2linux.de>
Note: See TracBrowser for help on using the repository browser.