source: projects/specs/trunk/lib/libm/libmediainfo/libmediainfo-vl.spec @ 10570

Revision 10570, 7.7 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1# Copyright (c) 2007-2008 oc2pus
2# This file and all modifications and additions to the pristine
3# package are under the same license as the package itself.
4#
5# Please submit bugfixes or comments to toni@links2linux.de
6#
7# *** This spec is modified for Vine Linux ***
8
9# norootforbuild
10
11%define _prefix /usr
12# %define _SO_nr        0
13# %define libzen_version        0.3.6
14# %define libzen_SO_nr  0
15
16Name:           libmediainfo
17Version:        0.7.73
18Release:        2%{?_dist_release}
19Summary:        Supplies technical and tag information about a video or audio file
20Summary(ja):    ビデオとオーディオファイルの詳細な情報を提供するライブラリ
21Group:          System Environment/Libraries
22License:        BSD
23URL:            http://mediainfo.sourceforge.net/
24Source0:        http://mediaarea.net/download/source/libmediainfo/0.7.73/libmediainfo_%{version}.tar.bz2
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
27BuildRequires:  nkf
28
29BuildRequires:  doxygen
30BuildRequires:  gcc-c++
31BuildRequires:  libzen-devel
32BuildRequires:  pkgconfig
33BuildRequires:  zlib-devel
34Requires:       libzen
35
36Packager:       babasaki
37
38%description
39MediaInfo supplies technical and tag information about a video or
40audio file.
41
42What information can I get from MediaInfo?
43* General: title, author, director, album, track number, date, duration...
44* Video: codec, aspect, fps, bitrate...
45* Audio: codec, sample rate, channels, language, bitrate...
46* Text: language of subtitle
47* Chapters: number of chapters, list of chapters
48
49DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
50MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime,
51RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
52VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
53
54What format (container) does MediaInfo support?
55* Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
56  MPEG-2, MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP,
57  H.264, AVC...)
58* Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
59* Subtitles: SRT, SSA, ASS, SAMI
60
61This package contains the shared library for MediaInfo(-gui).
62
63%description -l ja
64MediaInfo はビデオとオーディオファイルの詳細な情報を提供します。
65
66MediaInfo で確認できる情報:
67* 全般: タイトル、作者、ディレクター、アルバム、トラック番号、
68  日付、時間...
69* ビデオ: codec、アスペクト比、フレームレート、ビットレート...
70* オーディオ: codec、サンプリングレート、チャンネル数、言語、
71  ビットレート...
72* テキスト: 字幕の言語
73* チャプター: チャプター数、チャプターの一覧
74
75DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
76MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime,
77RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
78VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
79
80MediaInfo がサポートするフォーマット:
81* ビデオ: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
82  MPEG-2, MPEG-4, DVD (VOB) (Codec: DivX, XviD, MSMPEG4, ASP,
83  H.264, AVC...)
84* オーディオ: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
85* 字幕: SRT, SSA, ASS, SAMI
86
87このパッケージは Mediainfo(-gui) 用の共有ライブラリを含んでい
88ます。
89
90
91%package -n libmediainfo-devel
92Summary:        Include files and mandatory librariesfor development
93Summary(ja):    libmediainfo の開発用のヘッダとライブラリファイル
94Group:          Development/Libraries
95Requires:       libmediainfo = %{version}-%{release}
96Requires:       libzen-devel
97Requires:       zlib-devel
98
99%description -n libmediainfo-devel
100Include files and mandatory librariesfor development.
101
102%description -n libmediainfo-devel -l ja
103libmediainfo の開発用のヘッダとライブラリファイルです。
104
105%prep
106%setup -q -n MediaInfoLib
107cp           Release/ReadMe_DLL_Linux.txt ReadMe.txt
108mv           History_DLL.txt History.txt
109## dos2unix     *.txt *.html Source/Doc/*.html
110nkf --unix --overwrite *.txt *.html Source/Doc/*.html
111
112%__chmod 644 *.txt *.html Source/Doc/*.html
113
114%build
115export CFLAGS="$RPM_OPT_FLAGS"
116export CPPFLAGS="$RPM_OPT_FLAGS"
117export CXXFLAGS="$RPM_OPT_FLAGS"
118
119pushd Source/Doc/
120        doxygen Doxyfile
121popd
122cp Source/Doc/*.html ./
123
124pushd Project/GNU/Library
125        %__chmod +x autogen
126        ./autogen
127        %configure --enable-shared --disable-static
128
129        %__make clean
130        %__make %{?jobs:-j%{jobs}}
131popd
132
133%install
134pushd Project/GNU/Library/
135        %__make install-strip DESTDIR=%{buildroot}
136popd
137
138# MediaInfoDLL headers and MediaInfo-config
139for i in MediaInfo MediaInfoDLL; do
140        %__install -dm 755 %{buildroot}%{_includedir}/$i
141        %__install -m 644 Source/$i/*.h \
142                %{buildroot}%{_includedir}/$i
143done
144
145%__sed -i -e 's|Version: |Version: %{version}|g' \
146        Project/GNU/Library/libmediainfo.pc
147%__install -dm 755 %{buildroot}%{_libdir}/pkgconfig
148%__install -m 644 Project/GNU/Library/libmediainfo.pc \
149        %{buildroot}%{_libdir}/pkgconfig
150
151# remove unpackaged files
152rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la
153
154%clean
155[ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %__rm -rf "%{buildroot}"
156
157%post -n libmediainfo -p /sbin/ldconfig
158
159%postun -n libmediainfo -p /sbin/ldconfig
160
161%files
162%defattr(-,root,root,-)
163%doc History.txt License.html ReadMe.txt
164%{_libdir}/libmediainfo.so.*
165
166%files -n libmediainfo-devel
167%defattr(-,root,root,-)
168%doc Changes.txt Documentation.html Doc/*
169%dir %{_includedir}/MediaInfo
170%{_includedir}/MediaInfo/*
171%dir %{_includedir}/MediaInfoDLL
172%{_includedir}/MediaInfoDLL/*
173#%{_libdir}/libmediainfo.a
174#%{_libdir}/libmediainfo.la
175%{_libdir}/libmediainfo.so
176%{_libdir}/pkgconfig/*.pc
177
178%changelog
179* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.73-2
180- rebuild with gcc-5.4.0
181
182* Tue May 12 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.7.73-1
183- new upstream release
184
185* Mon Oct 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.64-1
186- new upstream release
187
188* Fri Mar 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.62-1
189- new upstream release
190
191* Sat Sep 15 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.60-1
192- new upstream release
193
194* Sun Jul 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.58-1
195- new upstream release
196
197* Sun May 13 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.57-1
198- new upstream release
199
200* Sun Jan 15 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.52-1
201- new upstream release
202
203* Tue Sep 27 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.50-1
204- new upstream release
205
206* Fri Jul 15 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.47-1
207- new upstream release
208
209* Wed Jan 26 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.41-1
210- new upstream release
211
212* Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.38-1
213- new upstream release
214
215* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.37-1
216- new upstream release
217
218* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.35-2
219- rebuilt with rpm-4.8.1 for pkg-config
220
221* Fri Sep 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.35-1
222- new upstream release
223
224* Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.34-2
225- fixed Group to System Environment/Libraries
226
227* Tue Jul 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.34-1
228- new upstream release
229
230* Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.33-1
231- new upstream release
232
233* Thu Oct 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.23-1
234- new upstream release
235
236* Mon Oct 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.22-1
237- new upstream release
238
239* Tue Jul 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7.19-1
240- new upstream release
241- change spec file name to libmediainfo-vl.spec
242- add japanese summary and description
243- change group for -devel sub package to Development/Libraries
244- not to specify %{libzen_version} strictly
245- add configure option --disable-static
246- remove unpackaged file (.la)
247- add Packager tag
248
249* Thu Jan 01 2009 Jerome Martinez <zen@mediaarea.net> - 0.7.9-0
250- See History.txt for more info and real dates
251- Previous packages made by Toni Graffy <toni@links2linux.de>
Note: See TracBrowser for help on using the repository browser.