source: projects/specs/trunk/lib/libm/libmariadb/libmariadb-vl.spec @ 12413

Revision 12413, 11.3 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

cyrus-sasl-2.1.27-2

dnsmasq-2.81-1

freerdp-2.1.1-1

glib2-2.64.3-1

libmariadb-3.1.8-1

openssh-8.3p1-1

Line 
1Name:           libmariadb
2Summary:        The MariaDB Native Client library (C driver)
3Epoch:          1
4Version:        3.1.8
5Release:        1%{?_dist_release}
6Group:          System Environment/Libraries
7Vendor:         Project Vine
8Distribution:   Vine Linux
9Packager:       tomop
10
11License:        LGPLv2+
12Url:            http://mariadb.org/
13Source:         https://downloads.mariadb.com/Connectors/c/connector-c-%{version}/mariadb-connector-c-%{version}-src.tar.gz
14Source2:        my.cnf
15Source3:        client.cnf
16# More information: https://mariadb.com/kb/en/mariadb/building-connectorc-from-source/
17
18Requires:       mariadb-common
19BuildRequires:  zlib-devel cmake openssl-devel gcc-c++
20# Remote-IO plugin
21BuildRequires:  curl-devel
22
23%description
24The MariaDB Native Client library (C driver) is used to connect applications
25developed in C/C++ to MariaDB and MySQL databases.
26
27
28%package devel
29Summary:        Development files for mariadb-connector-c
30Group:          Development/Libraries
31Provides:       libmysqlclient-devel = %{epoch}:%{version}-%{release}
32Obsoletes:      libmysqlclient-devel
33Requires:       %{name} = %{epoch}:%{version}-%{release}
34Requires:       openssl-devel
35
36%description devel
37Development files for mariadb-connector-c.
38Contains everything needed to build against libmariadb.so >=3 client library.
39
40
41
42%package -n mariadb-common
43Summary:        Configuration files for packages that use /etc/my.cnf as a configuration file
44BuildArch:      noarch
45
46%description -n mariadb-common
47This package delivers /etc/my.cnf that includes other configuration files
48from the /etc/my.cnf.d directory and ships this directory as well.
49Other packages should only put their files into /etc/my.cnf.d directory
50and require this package, so the /etc/my.cnf file is present.
51
52
53
54%prep
55%setup -q -n mariadb-connector-c-%{version}-src
56
57# Remove unsused parts
58rm -r win zlib win-iconv examples
59
60
61
62%build
63
64# https://jira.mariadb.org/browse/MDEV-13836:
65#   The server has (used to have for ages) some magic around the port number.
66#   If it's 0, the default port value will use getservbyname("mysql", "tcp"), that is, whatever is written in /etc/services.
67#   If it's a positive number, say, 3306, it will be 3306, no matter what /etc/services say.
68#   I don't know if that behavior makes much sense, /etc/services wasn't supposed to be a system configuration file.
69
70# The INSTALL_xxx macros have to be specified relative to CMAKE_INSTALL_PREFIX
71# so we can't use %%{_datadir} and so forth here.
72
73%cmake . \
74       -DCMAKE_BUILD_TYPE=RelWithDebInfo \
75       -DCMAKE_SYSTEM_PROCESSOR="%{_arch}" \
76\
77       -DMARIADB_UNIX_ADDR=%{_sharedstatedir}/mysql/mysql.sock \
78       -DMARIADB_PORT=3306 \
79\
80       -DWITH_EXTERNAL_ZLIB=YES \
81       -DWITH_SSL=OPENSSL \
82       -DWITH_MYSQLCOMPAT=ON \
83\
84       -DINSTALL_LAYOUT=RPM \
85       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
86       -DINSTALL_BINDIR="bin" \
87       -DINSTALL_LIBDIR="%{_lib}" \
88       -DINSTALL_INCLUDEDIR="include/mysql" \
89       -DINSTALL_PLUGINDIR="%{_lib}/mariadb/plugin" \
90\
91       -DWITH_UNITTEST=ON
92
93
94
95#cmake -LAH
96
97make %{?_smp_mflags}
98
99
100
101%install
102rm -rf %{buildroot}
103
104make install DESTDIR=%{buildroot}
105
106#multilib_fix_c_header --file %{_includedir}/mysql/mariadb_version.h
107
108sed -e 's/libmariadb/libmysqlclient/' < %{buildroot}%{_libdir}/pkgconfig/libmariadb.pc > %{buildroot}%{_libdir}/pkgconfig/libmysqlclient.pc
109
110# Remove static linked libraries and symlinks to them
111rm %{buildroot}%{_libdir}/lib*.a
112
113# Add a compatibility symlinks
114ln -s mariadb_config %{buildroot}%{_bindir}/mysql_config
115ln -s mariadb_version.h %{buildroot}%{_includedir}/mysql/mysql_version.h
116
117# Install config files
118install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/my.cnf
119install -D -p -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
120
121
122%check
123# Check the generated configuration on the actual machine
124%{buildroot}%{_bindir}/mariadb_config
125
126# Run the unit tests
127# - don't run mytap tests
128# - ignore the testsuite result for now. Enable tests now, fix them later.
129pushd unittest/libmariadb/
130ctest || :
131popd
132
133
134
135# https://fedoraproject.org/wiki/Packaging:Directory_Replacement
136%pretrans -p <lua>
137path = "%{_libdir}/mariadb"
138st = posix.stat(path)
139if st and st.type == "link" then
140  os.remove(path)
141end
142path = "%{_libdir}/mysql"
143st = posix.stat(path)
144if st and st.type == "link" then
145  os.remove(path)
146end
147
148
149
150%files
151%{_libdir}/libmariadb.so.*
152
153%dir %{_libdir}/mariadb
154%dir %{_libdir}/mariadb/plugin
155%{_libdir}/mariadb/plugin/*
156
157%doc README
158%license COPYING.LIB
159
160
161
162%files devel
163# Binary which provides compiler info for software compiling against this library
164%{_bindir}/mariadb_config
165%{_bindir}/mysql_config
166
167# Symlinks to the versioned library
168%{_libdir}/libmariadb.so
169%{_libdir}/libmysqlclient.so
170%{_libdir}/libmysqlclient_r.so
171
172# pkgconfig files
173%dir %{_libdir}/pkgconfig
174%{_libdir}/pkgconfig/*
175
176# Header files
177%dir %{_includedir}/mysql
178%{_includedir}/mysql/*
179
180%license COPYING.LIB
181
182
183%files -n mariadb-common
184%dir %{_sysconfdir}/my.cnf.d
185%config(noreplace) %{_sysconfdir}/my.cnf
186%config(noreplace) %{_sysconfdir}/my.cnf.d/client.cnf
187
188
189
190# RPMLint issues from 2.3.2 release tracked on the upstream JIRA:
191#   https://jira.mariadb.org/browse/CONC-232
192#   https://jira.mariadb.org/browse/CONC-234
193# RPMLint issues from 3.0.2 release tracked on the upstream JIRA:
194#   https://jira.mariadb.org/browse/CONC-287
195#   https://jira.mariadb.org/browse/CONC-291
196
197%changelog
198* Sat May 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-1
199- new upstream release.
200
201* Fri Feb 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
202- new upstream release.
203
204* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.3-1
205- new upstream release.
206
207* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.7-1
208- new upstream release.
209- dropped Patch0: fixed in upstream.
210
211* Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.6-3
212- initial built for Vine Linux.
213
214* Tue Sep 04 2018 Michal Schorm <mschorm@redhat.com> - 3.0.6-2
215- Fix parallel installability of x86_64 and i686 devel package
216
217* Fri Aug 03 2018 Michal Schorm <mschorm@redhat.com> - 3.0.6-1
218- Rebase to 3.0.6
219
220* Tue Jul 17 2018 Honza Horak <hhorak@redhat.com> - 3.0.5-3
221- Add -config sub-package that delivers system-wide /etc/my.cnf and
222  /etc/my.cnf.d directory, that other packages should use
223  This package also obsoletes mariadb-config
224
225* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.5-2
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
227
228* Fri Jun 08 2018 Michal Schorm <mschorm@redhat.com> - 3.0.5-1
229- Rebase to 3.0.5
230
231* Thu Apr 26 2018 Michal Schorm <mschorm@redhat.com> - 3.0.4-1
232- Rebase to 3.0.4
233
234* Mon Apr 23 2018 Michal Schorm <mschorm@redhat.com> - 3.0.3-4
235- Further fix of the '--plugindir' output from the config binary
236  Realted: #1569159
237
238* Wed Mar 21 2018 Richard W.M. Jones <rjones@redhat.com> - 3.0.3-3
239- Fix plugin install directory (INSTALL_PLUGINDIR not PLUGIN_INSTALL_DIR).
240
241* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.3-2
242- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
243
244* Fri Jan 19 2018 Michal Schorm <mschorm@redhat.com> - 3.0.3-1
245- Rebase to 3.0.3
246
247* Mon Nov 27 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-21
248- Remove unneeded dependency on xmlto
249
250* Tue Nov 14 2017 Pavel Raiskup <praiskup@redhat.com> - 3.0.2-19
251- drop misleading provides
252
253* Wed Nov 08 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-19
254- Move the scriptlet to the correct package
255
256* Thu Nov 02 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-18
257- Fix typo in require
258
259* Wed Nov 01 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-17
260- Use correct require for OpenSSL
261
262* Wed Nov 01 2017 Merlin Mathesius <mmathesi@redhat.com> - 3.0.2-16
263- Correct typo in spec file conditional
264
265* Tue Oct 31 2017 Merlin Mathesius <mmathesi@redhat.com> - 3.0.2-15
266- Cleanup spec file conditionals
267
268* Tue Oct 31 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-14
269- Remove Requires for openssl. Managed by RPM.
270
271* Mon Oct 30 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-13
272- Update scriplet dealing with symlinks as Guidelines suggests
273  Related: #1501933
274
275* Thu Oct 26 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-12
276- Move library directly to libdir, don't create any symlinks to directories
277- Update scritplets, so they only check for old symlinks to directories
278  Related: #1501933
279- Add 'Conflicts' with mariadb package on F<28
280  Related: #1506441
281
282* Mon Oct 09 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-11
283- Fix ldconfig path
284
285* Wed Oct 04 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-10
286- Add scriptlets to handle errors in /usr/lib64/ created by older versions
287  of mariadb and mariadb-connector-c pakages
288
289* Wed Sep 20 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-9
290- Add symlinks so more packages will build succesfully
291- Change libdir from .../lib64/mariadb to mysql
292  Related: #1497234
293
294* Wed Sep 13 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-7
295- Move header files to the same location, as they would be in mariadb-server
296- Add provides "libmysqlclient.so"
297
298* Tue Sep 05 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-5
299- Remove a symlink /usr/lib64/mysql that conflicts with mariadb-libs
300
301* Mon Aug 14 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-4
302- Add compatibility symlinks
303
304* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3
305- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
306
307* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
308- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
309
310* Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-1
311- Rebase to version 3.0.2
312- Library libmariadb.so.3 introduced
313- Plugin Remote-IO enabled
314
315* Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.3-1
316- Rebase to version 2.3.3
317- Patch dropped, solved by upstream; https://jira.mariadb.org/browse/CONC-231
318
319* Tue Feb 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.2-2
320- Fix based on output from RPMLint in previous version
321
322* Tue Jan 24 2017 Michal Schorm <mschorm@redhat.com> - 2.3.2-1
323- Rebase to version 2.3.2, patch needed (fixed by upstream in later versions)
324- Plugin dir moved from /libdir/plugin to /libdir/mariadb/plugin
325
326* Thu Oct 27 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-3
327- Fixed ownership of {_libdir}/mariadb (this dir must me owned by package)
328- Fixed ownership of {_sysconfigdir}/ld.so.conf.d (this dir must me owned by package)
329- Fixed redundnace on lines with {_sysconfigdir}/ld.so.conf.d
330- Fixed ownership of {_bindir} (only one program is owned, so let's be accurate)
331- Some comments added, for me and future maintainers
332
333* Mon Oct 17 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-2
334- Fixed ownership of {_libdir}/mariadb directory and cosmetic specfile changes
335
336* Tue Sep 13 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-1
337- Rebase to version 2.3.1
338
339* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
340- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
341
342* Thu Jul 23 2015 Matej Mužila <mmuzila@redhat.com> - 2.1.0-1
343- Rebase to version 2.1.0
344
345* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3
346- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
347
348* Wed Sep 24 2014 Matej Mužila <mmuzila@redhat.com> - 2.0.0-2
349- Fixed html IDs in documentation
350
351* Tue Aug 26 2014 Matej Mužila <mmuzila@redhat.com> - 2.0.0-2
352- Initial version for 2.0.0
Note: See TracBrowser for help on using the repository browser.