source: projects/specs/trunk/lib/libm/libmariadb/libmariadb-vl.spec @ 12321

Revision 12321, 11.2 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

bash-5.0.16-1

gtk-doc-1.32-3

libmariadb-3.1.7-1

libpq-12.2-1

librsvg2-2.46.4-1

postgresql-12.2-1

python-pygments-2.5.2-1

Line 
1Name:           libmariadb
2Version:        3.1.7
3Release:        1%{?_dist_release}
4Epoch:          1
5Summary:        The MariaDB Native Client library (C driver)
6Group:          System Environment/Libraries
7License:        LGPLv2+
8Vendor:         Project Vine
9Distribution:   Vine Linux
10Packager:       tomop
11Source:         https://downloads.mariadb.com/Connectors/c/connector-c-%{version}/mariadb-connector-c-%{version}-src.tar.gz
12Source2:        my.cnf
13Source3:        client.cnf
14Url:            http://mariadb.org/
15# More information: https://mariadb.com/kb/en/mariadb/building-connectorc-from-source/
16
17Requires:       mariadb-common
18BuildRequires:  zlib-devel cmake openssl-devel gcc-c++
19# Remote-IO plugin
20BuildRequires:  curl-devel
21
22%description
23The MariaDB Native Client library (C driver) is used to connect applications
24developed in C/C++ to MariaDB and MySQL databases.
25
26
27%package devel
28Summary:        Development files for mariadb-connector-c
29Group:          Development/Libraries
30Provides:       libmysqlclient-devel = %{epoch}:%{version}-%{release}
31Obsoletes:      libmysqlclient-devel
32Requires:       %{name} = %{epoch}:%{version}-%{release}
33Requires:       openssl-devel
34
35%description devel
36Development files for mariadb-connector-c.
37Contains everything needed to build against libmariadb.so >=3 client library.
38
39
40
41%package -n mariadb-common
42Summary:        Configuration files for packages that use /etc/my.cnf as a configuration file
43BuildArch:      noarch
44
45%description -n mariadb-common
46This package delivers /etc/my.cnf that includes other configuration files
47from the /etc/my.cnf.d directory and ships this directory as well.
48Other packages should only put their files into /etc/my.cnf.d directory
49and require this package, so the /etc/my.cnf file is present.
50
51
52
53%prep
54%setup -q -n mariadb-connector-c-%{version}-src
55
56# Remove unsused parts
57rm -r win zlib win-iconv examples
58
59
60
61%build
62
63# https://jira.mariadb.org/browse/MDEV-13836:
64#   The server has (used to have for ages) some magic around the port number.
65#   If it's 0, the default port value will use getservbyname("mysql", "tcp"), that is, whatever is written in /etc/services.
66#   If it's a positive number, say, 3306, it will be 3306, no matter what /etc/services say.
67#   I don't know if that behavior makes much sense, /etc/services wasn't supposed to be a system configuration file.
68
69# The INSTALL_xxx macros have to be specified relative to CMAKE_INSTALL_PREFIX
70# so we can't use %%{_datadir} and so forth here.
71
72%cmake . \
73       -DCMAKE_BUILD_TYPE=RelWithDebInfo \
74       -DCMAKE_SYSTEM_PROCESSOR="%{_arch}" \
75\
76       -DMARIADB_UNIX_ADDR=%{_sharedstatedir}/mysql/mysql.sock \
77       -DMARIADB_PORT=3306 \
78\
79       -DWITH_EXTERNAL_ZLIB=YES \
80       -DWITH_SSL=OPENSSL \
81       -DWITH_MYSQLCOMPAT=ON \
82\
83       -DINSTALL_LAYOUT=RPM \
84       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
85       -DINSTALL_BINDIR="bin" \
86       -DINSTALL_LIBDIR="%{_lib}" \
87       -DINSTALL_INCLUDEDIR="include/mysql" \
88       -DINSTALL_PLUGINDIR="%{_lib}/mariadb/plugin" \
89\
90       -DWITH_UNITTEST=ON
91
92
93
94#cmake -LAH
95
96make %{?_smp_mflags}
97
98
99
100%install
101rm -rf %{buildroot}
102
103make install DESTDIR=%{buildroot}
104
105#multilib_fix_c_header --file %{_includedir}/mysql/mariadb_version.h
106
107sed -e 's/libmariadb/libmysqlclient/' < %{buildroot}%{_libdir}/pkgconfig/libmariadb.pc > %{buildroot}%{_libdir}/pkgconfig/libmysqlclient.pc
108
109# Remove static linked libraries and symlinks to them
110rm %{buildroot}%{_libdir}/lib*.a
111
112# Add a compatibility symlinks
113ln -s mariadb_config %{buildroot}%{_bindir}/mysql_config
114ln -s mariadb_version.h %{buildroot}%{_includedir}/mysql/mysql_version.h
115
116# Install config files
117install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/my.cnf
118install -D -p -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
119
120
121%check
122# Check the generated configuration on the actual machine
123%{buildroot}%{_bindir}/mariadb_config
124
125# Run the unit tests
126# - don't run mytap tests
127# - ignore the testsuite result for now. Enable tests now, fix them later.
128pushd unittest/libmariadb/
129ctest || :
130popd
131
132
133
134# https://fedoraproject.org/wiki/Packaging:Directory_Replacement
135%pretrans -p <lua>
136path = "%{_libdir}/mariadb"
137st = posix.stat(path)
138if st and st.type == "link" then
139  os.remove(path)
140end
141path = "%{_libdir}/mysql"
142st = posix.stat(path)
143if st and st.type == "link" then
144  os.remove(path)
145end
146
147
148
149%files
150%{_libdir}/libmariadb.so.*
151
152%dir %{_libdir}/mariadb
153%dir %{_libdir}/mariadb/plugin
154%{_libdir}/mariadb/plugin/*
155
156%doc README
157%license COPYING.LIB
158
159
160
161%files devel
162# Binary which provides compiler info for software compiling against this library
163%{_bindir}/mariadb_config
164%{_bindir}/mysql_config
165
166# Symlinks to the versioned library
167%{_libdir}/libmariadb.so
168%{_libdir}/libmysqlclient.so
169%{_libdir}/libmysqlclient_r.so
170
171# pkgconfig files
172%dir %{_libdir}/pkgconfig
173%{_libdir}/pkgconfig/*
174
175# Header files
176%dir %{_includedir}/mysql
177%{_includedir}/mysql/*
178
179%license COPYING.LIB
180
181
182%files -n mariadb-common
183%dir %{_sysconfdir}/my.cnf.d
184%config(noreplace) %{_sysconfdir}/my.cnf
185%config(noreplace) %{_sysconfdir}/my.cnf.d/client.cnf
186
187
188
189# RPMLint issues from 2.3.2 release tracked on the upstream JIRA:
190#   https://jira.mariadb.org/browse/CONC-232
191#   https://jira.mariadb.org/browse/CONC-234
192# RPMLint issues from 3.0.2 release tracked on the upstream JIRA:
193#   https://jira.mariadb.org/browse/CONC-287
194#   https://jira.mariadb.org/browse/CONC-291
195
196%changelog
197* Fri Feb 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
198- new upstream release.
199
200* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.3-1
201- new upstream release.
202
203* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.7-1
204- new upstream release.
205- dropped Patch0: fixed in upstream.
206
207* Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.6-3
208- initial built for Vine Linux.
209
210* Tue Sep 04 2018 Michal Schorm <mschorm@redhat.com> - 3.0.6-2
211- Fix parallel installability of x86_64 and i686 devel package
212
213* Fri Aug 03 2018 Michal Schorm <mschorm@redhat.com> - 3.0.6-1
214- Rebase to 3.0.6
215
216* Tue Jul 17 2018 Honza Horak <hhorak@redhat.com> - 3.0.5-3
217- Add -config sub-package that delivers system-wide /etc/my.cnf and
218  /etc/my.cnf.d directory, that other packages should use
219  This package also obsoletes mariadb-config
220
221* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.5-2
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
223
224* Fri Jun 08 2018 Michal Schorm <mschorm@redhat.com> - 3.0.5-1
225- Rebase to 3.0.5
226
227* Thu Apr 26 2018 Michal Schorm <mschorm@redhat.com> - 3.0.4-1
228- Rebase to 3.0.4
229
230* Mon Apr 23 2018 Michal Schorm <mschorm@redhat.com> - 3.0.3-4
231- Further fix of the '--plugindir' output from the config binary
232  Realted: #1569159
233
234* Wed Mar 21 2018 Richard W.M. Jones <rjones@redhat.com> - 3.0.3-3
235- Fix plugin install directory (INSTALL_PLUGINDIR not PLUGIN_INSTALL_DIR).
236
237* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.3-2
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
239
240* Fri Jan 19 2018 Michal Schorm <mschorm@redhat.com> - 3.0.3-1
241- Rebase to 3.0.3
242
243* Mon Nov 27 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-21
244- Remove unneeded dependency on xmlto
245
246* Tue Nov 14 2017 Pavel Raiskup <praiskup@redhat.com> - 3.0.2-19
247- drop misleading provides
248
249* Wed Nov 08 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-19
250- Move the scriptlet to the correct package
251
252* Thu Nov 02 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-18
253- Fix typo in require
254
255* Wed Nov 01 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-17
256- Use correct require for OpenSSL
257
258* Wed Nov 01 2017 Merlin Mathesius <mmathesi@redhat.com> - 3.0.2-16
259- Correct typo in spec file conditional
260
261* Tue Oct 31 2017 Merlin Mathesius <mmathesi@redhat.com> - 3.0.2-15
262- Cleanup spec file conditionals
263
264* Tue Oct 31 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-14
265- Remove Requires for openssl. Managed by RPM.
266
267* Mon Oct 30 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-13
268- Update scriplet dealing with symlinks as Guidelines suggests
269  Related: #1501933
270
271* Thu Oct 26 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-12
272- Move library directly to libdir, don't create any symlinks to directories
273- Update scritplets, so they only check for old symlinks to directories
274  Related: #1501933
275- Add 'Conflicts' with mariadb package on F<28
276  Related: #1506441
277
278* Mon Oct 09 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-11
279- Fix ldconfig path
280
281* Wed Oct 04 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-10
282- Add scriptlets to handle errors in /usr/lib64/ created by older versions
283  of mariadb and mariadb-connector-c pakages
284
285* Wed Sep 20 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-9
286- Add symlinks so more packages will build succesfully
287- Change libdir from .../lib64/mariadb to mysql
288  Related: #1497234
289
290* Wed Sep 13 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-7
291- Move header files to the same location, as they would be in mariadb-server
292- Add provides "libmysqlclient.so"
293
294* Tue Sep 05 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-5
295- Remove a symlink /usr/lib64/mysql that conflicts with mariadb-libs
296
297* Mon Aug 14 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-4
298- Add compatibility symlinks
299
300* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3
301- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
302
303* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
304- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
305
306* Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-1
307- Rebase to version 3.0.2
308- Library libmariadb.so.3 introduced
309- Plugin Remote-IO enabled
310
311* Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.3-1
312- Rebase to version 2.3.3
313- Patch dropped, solved by upstream; https://jira.mariadb.org/browse/CONC-231
314
315* Tue Feb 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.2-2
316- Fix based on output from RPMLint in previous version
317
318* Tue Jan 24 2017 Michal Schorm <mschorm@redhat.com> - 2.3.2-1
319- Rebase to version 2.3.2, patch needed (fixed by upstream in later versions)
320- Plugin dir moved from /libdir/plugin to /libdir/mariadb/plugin
321
322* Thu Oct 27 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-3
323- Fixed ownership of {_libdir}/mariadb (this dir must me owned by package)
324- Fixed ownership of {_sysconfigdir}/ld.so.conf.d (this dir must me owned by package)
325- Fixed redundnace on lines with {_sysconfigdir}/ld.so.conf.d
326- Fixed ownership of {_bindir} (only one program is owned, so let's be accurate)
327- Some comments added, for me and future maintainers
328
329* Mon Oct 17 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-2
330- Fixed ownership of {_libdir}/mariadb directory and cosmetic specfile changes
331
332* Tue Sep 13 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-1
333- Rebase to version 2.3.1
334
335* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
336- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
337
338* Thu Jul 23 2015 Matej Mužila <mmuzila@redhat.com> - 2.1.0-1
339- Rebase to version 2.1.0
340
341* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3
342- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
343
344* Wed Sep 24 2014 Matej Mužila <mmuzila@redhat.com> - 2.0.0-2
345- Fixed html IDs in documentation
346
347* Tue Aug 26 2014 Matej Mužila <mmuzila@redhat.com> - 2.0.0-2
348- Initial version for 2.0.0
Note: See TracBrowser for help on using the repository browser.