source: projects/specs/trunk/lib/libk/libkkc/libkkc-vl.spec @ 9201

Revision 9201, 6.5 KB checked in by iwaim, 9 years ago (diff)

libkkc 0.3.5-1

Line 
1%define ver 0.3.5
2%define rel 1
3%define dataver 0.2.7
4%define datarel 5
5
6%define from_git 0
7%if %{from_git}
8%define githash ccfd5c6d
9%endif
10
11%if "%{?_dist_release}" == "vl6"
12%define with_vala 0
13%else
14%define with_vala 1
15%endif
16
17Summary: Japanese Kana Kanji conversion library (libkkc)
18Name: libkkc
19Version: %{ver}
20%if %{from_git}
21Release: %{rel}.git%{githash}%{_dist_release}
22%else
23Release: %{rel}%{_dist_release}
24%endif
25License: GPLv3+
26Group: System Environment/Libraries
27URL: https://bitbucket.org/libkkc/libkkc/
28%if %{from_git}
29Source0: libkkc-%{githash}.tar.gz
30%else
31Source0: https://github.com/ueno/libkkc/releases/download/v%{version}/%{name}-%{version}.tar.gz
32%endif
33Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
35BuildRequires: pkgconfig(gee-0.8)
36BuildRequires: json-glib-devel
37BuildRequires: marisa-trie-devel
38# for libkkc-data
39BuildRequires: marisa-trie-python
40%if %{with_vala}
41BuildRequires: vala-devel
42BuildRequires: vala-tools
43%endif
44
45Requires: libkkc-data = %{dataver}-%{datarel}%{_dist_release}
46Requires: libkkc-common = %{version}-%{release}
47
48Vendor: Project Vine
49Distribution: Vine Linux
50Packager: iwaim
51
52%description
53libkkc provides a converter from Kana-string to
54Kana-Kanji-mixed-string.  It was named after kkc.el in GNU Emacs, a
55simple Kana Kanji converter, while libkkc tries to convert sentences
56in a bit more complex way using N-gram language models.
57
58%package devel
59Summary: Header files and libraries for developing apps which will use libkkc
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62
63%description devel
64The libkkc-devel package contains the header files and libraries.
65
66%package tools
67Summary: Tools for %{name}
68Group: Applications/Accessories
69Requires: %{name} = %{version}-%{release}
70
71%description tools
72The %{name}-tools package contains tools for developing applications
73that use %{name}.
74
75%package common
76Summary: Common data files for %{name}
77
78%description common
79The %{name}-common package contains the arch-independent data that
80%{name} uses at run time.
81
82%package data
83Summary: Data files for %{name}
84Version: %{dataver}
85Release: %{datarel}%{_dist_release}
86
87%description data
88The %{name}-data package contains the language model data that %{name}
89uses at run time.
90
91%prep
92%if %{from_git}
93%setup -q -n %{name}-%{githash}
94%else
95%setup -q
96%endif
97
98# for libkkc-data
99tar xf %{SOURCE1}
100
101%build
102%if %{from_git}
103./autogen.sh
104%endif
105%configure --enable-shared \
106           --disable-silent-rules \
107%if %{with_vala}
108           --enable-vala=yes \
109%else
110           --enable-vala=no \
111%endif
112
113%__make
114
115# for libkkc-data
116pushd %{name}-data-%{dataver}
117%configure
118%__make
119popd
120
121%install
122%__rm -rf $RPM_BUILD_ROOT
123%makeinstall
124
125# for libkkc-data
126pushd %{name}-data-%{dataver}
127%makeinstall
128popd
129
130%find_lang %{name}
131
132# remove files
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
134
135%clean
136%__rm -rf $RPM_BUILD_ROOT
137
138%post -p /sbin/ldconfig
139
140%postun -p /sbin/ldconfig
141
142%files -f %{name}.lang
143%defattr(-,root,root,-)
144%doc README ChangeLog COPYING AUTHORS NEWS
145%doc data/rules/README.rules
146%{_libdir}/libkkc.so.*
147%{_libdir}/girepository-1.0/Kkc-1.0.typelib
148%dir %{_datadir}/libkkc
149%{_datadir}/libkkc/rules
150
151%files devel
152%defattr(-,root,root,-)
153%doc COPYING AUTHORS
154%dir %{_includedir}/libkkc
155%{_includedir}/libkkc/libkkc.h
156%{_libdir}/libkkc.so
157%{_libdir}/pkgconfig/kkc-1.0.pc
158%{_datadir}/gir-1.0/Kkc-1.0.gir
159%{_datadir}/vala/vapi/kkc-1.0.deps
160%{_datadir}/vala/vapi/kkc-1.0.vapi
161
162%files tools
163%defattr(-,root,root,-)
164%doc COPYING AUTHORS
165%{_bindir}/kkc
166%{_bindir}/kkc-package-data
167
168%files common
169%defattr(-,root,root,-)
170%doc COPYING AUTHORS
171%dir %{_datadir}/libkkc
172%dir %{_datadir}/libkkc/templates
173%{_datadir}/libkkc/templates/libkkc-data
174
175%files data
176%defattr(-,root,root,-)
177%doc COPYING AUTHORS
178%dir %{_libdir}/libkkc
179%dir %{_libdir}/libkkc/models
180%{_libdir}/libkkc/models/sorted3
181
182%changelog
183* Mon Dec 29 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-1
184- update to libkkc 0.3.5
185- switch upstream source location to GitHub
186
187* Mon Jul  7 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.4-1
188- update to libkkc 0.3.4
189- update BuildRequires for libgee
190
191* Sun Jun 15 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.3-1
192- update to libkkc 0.3.3
193
194* Wed Dec 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.2-1
195- update to libkkc 0.3.2
196
197* Thu Nov  7 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.1-1
198- update to libkkc 0.3.1
199- update to libkkc-data 0.2.7
200- fix changelog for 0.2.6-1
201
202* Sat Jul 27 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.6-1
203- update to libkkc 0.2.6
204- update to libkkc-data 0.2.5
205
206* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
207- update to libkkc 0.2.4
208- update to libkkc-data 0.2.0
209- add Version tag for libkkc-data sub package
210
211* Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
212- update to libkkc 0.1.10
213
214* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
215- update to libkkc 0.1.9
216
217* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
218- update to libkkc 0.1.8
219
220* Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
221- update to libkkc 0.1.7
222
223* Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
224- update to libkkc 0.1.6
225- update to libkkc-data 0.1.6
226
227* Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
228- update to libkkc 0.1.5
229
230* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
231- update to 0.1.3
232- update License value: GPLv3 -> GPLv3+
233- add BuildRequires: marisa-trie-python for libkkc-data
234- sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
235 - create tools sub package
236  - move %%{_bindir}/kkc
237  - add %%{_bindir}/kkc-package-data
238 - create common sub package
239  - add template for generating libkkc-data
240 - merge libkkc-data SRPM file
241  - add libkkc-data source file (Source1)
242  - create data sub package
243 - add '--disable-silent-rules' option for configure
244 - add Requires libkkc-data and libkkc-common
245 - add document: data/rules/README.rules
246
247* Wed Feb  6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
248- update to 0.1.2
249
250* Tue Feb  5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
251- update to 0.1.1
252
253* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
254- update to 0.1.0
255- rename libkkc.pc to kkc-1.0.pc by upstream
256
257* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
258- update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
259- add post and postun script
260- add translate file
261
262* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
263- support Vine Linux 6
264 - without Vala
265 - BR: libgee-devel
266
267* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
268- initial build for Vine Linux
269
Note: See TracBrowser for help on using the repository browser.