source: projects/specs/trunk/lib/libk/libkkc/libkkc-vl.spec @ 7615

Revision 7615, 5.6 KB checked in by iwaim, 11 years ago (diff)

libkkc 0.1.10-1

Line 
1%define ver 0.1.10
2%define rel 1
3%define dataver 0.1.6
4
5%define from_git 0
6%if %{from_git}
7%define githash ccfd5c6d
8%endif
9
10%if "%{?_dist_release}" == "vl6"
11%define with_vala 0
12%else
13%define with_vala 1
14%endif
15
16Summary: Japanese Kana Kanji conversion library (libkkc)
17Name: libkkc
18Version: %{ver}
19%if %{from_git}
20Release: %{rel}.git%{githash}%{_dist_release}
21%else
22Release: %{rel}%{_dist_release}
23%endif
24License: GPLv3+
25Group: System Environment/Libraries
26URL: https://bitbucket.org/libkkc/libkkc/
27%if %{from_git}
28Source0: libkkc-%{githash}.tar.gz
29%else
30Source0: https://bitbucket.org/libkkc/libkkc/downloads/%{name}-%{version}.tar.gz
31%endif
32Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
34%if "%{?_dist_release}" == "vl6"
35BuildRequires: libgee-devel
36%else
37BuildRequires: libgee06-devel
38%endif
39BuildRequires: json-glib-devel
40BuildRequires: marisa-trie-devel
41# for libkkc-data
42BuildRequires: marisa-trie-python
43%if %{with_vala}
44BuildRequires: vala-devel
45BuildRequires: vala-tools
46%endif
47
48Requires: libkkc-data = %{version}-%{release}
49Requires: libkkc-common = %{version}-%{release}
50
51Vendor: Project Vine
52Distribution: Vine Linux
53Packager: iwaim
54
55%description
56libkkc provides a converter from Kana-string to
57Kana-Kanji-mixed-string.  It was named after kkc.el in GNU Emacs, a
58simple Kana Kanji converter, while libkkc tries to convert sentences
59in a bit more complex way using N-gram language models.
60
61%package devel
62Summary: Header files and libraries for developing apps which will use libkkc
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description devel
67The libkkc-devel package contains the header files and libraries.
68
69%package tools
70Summary: Tools for %{name}
71Group: Applications/Accessories
72Requires: %{name} = %{version}-%{release}
73
74%description tools
75The %{name}-tools package contains tools for developing applications
76that use %{name}.
77
78%package common
79Summary: Common data files for %{name}
80
81%description common
82The %{name}-common package contains the arch-independent data that
83%{name} uses at run time.
84
85%package data
86Summary: Data files for %{name}
87
88%description data
89The %{name}-data package contains the language model data that %{name}
90uses at run time.
91
92%prep
93%if %{from_git}
94%setup -q -n %{name}-%{githash}
95%else
96%setup -q
97%endif
98
99# for libkkc-data
100tar xf %{SOURCE1}
101
102%build
103%if %{from_git}
104./autogen.sh
105%endif
106%configure --enable-shared \
107           --disable-silent-rules \
108%if %{with_vala}
109           --enable-vala=yes \
110%else
111           --enable-vala=no \
112%endif
113
114%__make
115
116# for libkkc-data
117pushd %{name}-data-%{dataver}
118%configure
119%__make
120popd
121
122%install
123%__rm -rf $RPM_BUILD_ROOT
124%makeinstall
125
126# for libkkc-data
127pushd %{name}-data-%{dataver}
128%makeinstall
129popd
130
131%find_lang %{name}
132
133# remove files
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
135
136%clean
137%__rm -rf $RPM_BUILD_ROOT
138
139%post -p /sbin/ldconfig
140
141%postun -p /sbin/ldconfig
142
143%files -f %{name}.lang
144%defattr(-,root,root,-)
145%doc README ChangeLog COPYING AUTHORS NEWS
146%doc data/rules/README.rules
147%{_libdir}/libkkc.so.*
148%{_libdir}/girepository-1.0/Kkc-1.0.typelib
149%dir %{_datadir}/libkkc
150%{_datadir}/libkkc/rules
151
152%files devel
153%defattr(-,root,root,-)
154%doc COPYING AUTHORS
155%dir %{_includedir}/libkkc
156%{_includedir}/libkkc/libkkc.h
157%{_libdir}/libkkc.so
158%{_libdir}/pkgconfig/kkc-1.0.pc
159%{_datadir}/gir-1.0/Kkc-1.0.gir
160%{_datadir}/vala/vapi/kkc-1.0.deps
161%{_datadir}/vala/vapi/kkc-1.0.vapi
162
163%files tools
164%defattr(-,root,root,-)
165%doc COPYING AUTHORS
166%{_bindir}/kkc
167%{_bindir}/kkc-package-data
168
169%files common
170%defattr(-,root,root,-)
171%doc COPYING AUTHORS
172%dir %{_datadir}/libkkc
173%dir %{_datadir}/libkkc/templates
174%{_datadir}/libkkc/templates/libkkc-data
175
176%files data
177%defattr(-,root,root,-)
178%doc COPYING AUTHORS
179%dir %{_libdir}/libkkc
180%dir %{_libdir}/libkkc/models
181%{_libdir}/libkkc/models/sorted3
182
183%changelog
184* Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
185- update to libkkc 0.1.10
186
187* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
188- update to libkkc 0.1.9
189
190* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
191- update to libkkc 0.1.8
192
193* Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
194- update to libkkc 0.1.7
195
196* Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
197- update to libkkc 0.1.6
198- update to libkkc-data 0.1.6
199
200* Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
201- update to libkkc 0.1.5
202
203* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
204- update to 0.1.3
205- update License value: GPLv3 -> GPLv3+
206- add BuildRequires: marisa-trie-python for libkkc-data
207- sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
208 - create tools sub package
209  - move %%{_bindir}/kkc
210  - add %%{_bindir}/kkc-package-data
211 - create common sub package
212  - add template for generating libkkc-data
213 - merge libkkc-data SRPM file
214  - add libkkc-data source file (Source1)
215  - create data sub package
216 - add '--disable-silent-rules' option for configure
217 - add Requires libkkc-data and libkkc-common
218 - add document: data/rules/README.rules
219
220* Wed Feb  6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
221- update to 0.1.2
222
223* Tue Feb  5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
224- update to 0.1.1
225
226* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
227- update to 0.1.0
228- rename libkkc.pc to kkc-1.0.pc by upstream
229
230* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
231- update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
232- add post and postun script
233- add translate file
234
235* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
236- support Vine Linux 6
237 - without Vala
238 - BR: libgee-devel
239
240* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
241- initial build for Vine Linux
242
Note: See TracBrowser for help on using the repository browser.