source: projects/specs/trunk/lib/libk/libkkc/libkkc-vl.spec @ 10227

Revision 10227, 7.0 KB checked in by iwaim, 8 years ago (diff)

libkkc 0.3.5-3

Line 
1%define ver 0.3.5
2%define rel 3
3%define dataver 0.2.7
4%define datarel 7
5
6%define from_git 0
7%if %{from_git}
8%define githash ccfd5c6d
9%endif
10
11%if "%{?_dist_release}" == "vl6"
12%define with_vala 0
13%else
14%define with_vala 1
15%endif
16
17Summary: Japanese Kana Kanji conversion library (libkkc)
18Name: libkkc
19Version: %{ver}
20%if %{from_git}
21Release: %{rel}.git%{githash}%{_dist_release}
22%else
23Release: %{rel}%{_dist_release}
24%endif
25License: GPLv3+
26Group: System Environment/Libraries
27URL: https://bitbucket.org/libkkc/libkkc/
28%if %{from_git}
29Source0: libkkc-%{githash}.tar.gz
30%else
31Source0: https://github.com/ueno/libkkc/releases/download/v%{version}/%{name}-%{version}.tar.gz
32%endif
33Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
34Patch0: https://github.com/ueno/libkkc/commit/1f512da81a71287b13eb0a1f9b31830b16db2107.patch
35Patch1: https://github.com/ueno/libkkc/commit/46b02adf1fe806e99f8d896f770591480165f90a.patch
36BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
37BuildRequires: pkgconfig(gee-0.8)
38BuildRequires: libgee-vala
39BuildRequires: json-glib-devel
40BuildRequires: marisa-trie-devel
41# for libkkc-data
42BuildRequires: marisa-trie-python
43%if %{with_vala}
44BuildRequires: vala-devel
45BuildRequires: vala-tools
46%endif
47
48Requires: libkkc-data = %{dataver}-%{datarel}%{_dist_release}
49Requires: libkkc-common = %{version}-%{release}
50
51Vendor: Project Vine
52Distribution: Vine Linux
53Packager: iwaim
54
55%description
56libkkc provides a converter from Kana-string to
57Kana-Kanji-mixed-string.  It was named after kkc.el in GNU Emacs, a
58simple Kana Kanji converter, while libkkc tries to convert sentences
59in a bit more complex way using N-gram language models.
60
61%package devel
62Summary: Header files and libraries for developing apps which will use libkkc
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description devel
67The libkkc-devel package contains the header files and libraries.
68
69%package tools
70Summary: Tools for %{name}
71Group: Applications/Accessories
72Requires: %{name} = %{version}-%{release}
73
74%description tools
75The %{name}-tools package contains tools for developing applications
76that use %{name}.
77
78%package common
79Summary: Common data files for %{name}
80
81%description common
82The %{name}-common package contains the arch-independent data that
83%{name} uses at run time.
84
85%package data
86Summary: Data files for %{name}
87Version: %{dataver}
88Release: %{datarel}%{_dist_release}
89
90%description data
91The %{name}-data package contains the language model data that %{name}
92uses at run time.
93
94%prep
95%if %{from_git}
96%setup -q -n %{name}-%{githash}
97%else
98%setup -q
99%endif
100%patch0 -p1
101
102# for libkkc-data
103tar xf %{SOURCE1}
104
105%build
106%if %{from_git}
107./autogen.sh
108%endif
109%configure --enable-shared --disable-static \
110           --disable-silent-rules \
111%if %{with_vala}
112           --enable-vala=yes \
113%else
114           --enable-vala=no \
115%endif
116
117%__make
118
119# for libkkc-data
120pushd %{name}-data-%{dataver}
121%configure
122%__make
123popd
124
125%install
126%__rm -rf $RPM_BUILD_ROOT
127%makeinstall
128
129# for libkkc-data
130pushd %{name}-data-%{dataver}
131%makeinstall
132popd
133
134%find_lang %{name}
135
136# remove files
137%__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
138
139%clean
140%__rm -rf $RPM_BUILD_ROOT
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%files -f %{name}.lang
147%defattr(-,root,root,-)
148%doc README ChangeLog COPYING AUTHORS NEWS
149%doc data/rules/README.rules
150%{_libdir}/libkkc.so.*
151%{_libdir}/girepository-1.0/Kkc-1.0.typelib
152%dir %{_datadir}/libkkc
153%{_datadir}/libkkc/rules
154
155%files devel
156%defattr(-,root,root,-)
157%doc COPYING AUTHORS
158%dir %{_includedir}/libkkc
159%{_includedir}/libkkc/libkkc.h
160%{_libdir}/libkkc.so
161%{_libdir}/pkgconfig/kkc-1.0.pc
162%{_datadir}/gir-1.0/Kkc-1.0.gir
163%{_datadir}/vala/vapi/kkc-1.0.deps
164%{_datadir}/vala/vapi/kkc-1.0.vapi
165
166%files tools
167%defattr(-,root,root,-)
168%doc COPYING AUTHORS
169%{_bindir}/kkc
170%{_bindir}/kkc-package-data
171
172%files common
173%defattr(-,root,root,-)
174%doc COPYING AUTHORS
175%dir %{_datadir}/libkkc
176%dir %{_datadir}/libkkc/templates
177%{_datadir}/libkkc/templates/libkkc-data
178
179%files data
180%defattr(-,root,root,-)
181%doc COPYING AUTHORS
182%dir %{_libdir}/libkkc
183%dir %{_libdir}/libkkc/models
184%{_libdir}/libkkc/models/sorted3
185
186%changelog
187* Fri Apr 29 2016 WAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
188- add 'Modify Kana rules for ignoring moored shift key.' patch (Patch1)
189
190* Thu Apr 30 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-2
191- add 'Try all possible okuri-gana combinations' patch (Patch0)
192- add BuildRequires: libgee-vala
193
194* Mon Dec 29 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-1
195- update to libkkc 0.3.5
196- switch upstream source location to GitHub
197
198* Mon Jul  7 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.4-1
199- update to libkkc 0.3.4
200- update BuildRequires for libgee
201
202* Sun Jun 15 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.3-1
203- update to libkkc 0.3.3
204
205* Wed Dec 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.2-1
206- update to libkkc 0.3.2
207
208* Thu Nov  7 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.1-1
209- update to libkkc 0.3.1
210- update to libkkc-data 0.2.7
211- fix changelog for 0.2.6-1
212
213* Sat Jul 27 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.6-1
214- update to libkkc 0.2.6
215- update to libkkc-data 0.2.5
216
217* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
218- update to libkkc 0.2.4
219- update to libkkc-data 0.2.0
220- add Version tag for libkkc-data sub package
221
222* Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
223- update to libkkc 0.1.10
224
225* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
226- update to libkkc 0.1.9
227
228* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
229- update to libkkc 0.1.8
230
231* Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
232- update to libkkc 0.1.7
233
234* Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
235- update to libkkc 0.1.6
236- update to libkkc-data 0.1.6
237
238* Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
239- update to libkkc 0.1.5
240
241* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
242- update to 0.1.3
243- update License value: GPLv3 -> GPLv3+
244- add BuildRequires: marisa-trie-python for libkkc-data
245- sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
246 - create tools sub package
247  - move %%{_bindir}/kkc
248  - add %%{_bindir}/kkc-package-data
249 - create common sub package
250  - add template for generating libkkc-data
251 - merge libkkc-data SRPM file
252  - add libkkc-data source file (Source1)
253  - create data sub package
254 - add '--disable-silent-rules' option for configure
255 - add Requires libkkc-data and libkkc-common
256 - add document: data/rules/README.rules
257
258* Wed Feb  6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
259- update to 0.1.2
260
261* Tue Feb  5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
262- update to 0.1.1
263
264* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
265- update to 0.1.0
266- rename libkkc.pc to kkc-1.0.pc by upstream
267
268* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
269- update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
270- add post and postun script
271- add translate file
272
273* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
274- support Vine Linux 6
275 - without Vala
276 - BR: libgee-devel
277
278* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
279- initial build for Vine Linux
280
Note: See TracBrowser for help on using the repository browser.