source: projects/specs/trunk/lib/libk/libkkc/libkkc-vl.spec @ 9534

Revision 9534, 6.8 KB checked in by iwaim, 9 years ago (diff)

libkkc-0.3.5-2

Line 
1%define ver 0.3.5
2%define rel 2
3%define dataver 0.2.7
4%define datarel 6
5
6%define from_git 0
7%if %{from_git}
8%define githash ccfd5c6d
9%endif
10
11%if "%{?_dist_release}" == "vl6"
12%define with_vala 0
13%else
14%define with_vala 1
15%endif
16
17Summary: Japanese Kana Kanji conversion library (libkkc)
18Name: libkkc
19Version: %{ver}
20%if %{from_git}
21Release: %{rel}.git%{githash}%{_dist_release}
22%else
23Release: %{rel}%{_dist_release}
24%endif
25License: GPLv3+
26Group: System Environment/Libraries
27URL: https://bitbucket.org/libkkc/libkkc/
28%if %{from_git}
29Source0: libkkc-%{githash}.tar.gz
30%else
31Source0: https://github.com/ueno/libkkc/releases/download/v%{version}/%{name}-%{version}.tar.gz
32%endif
33Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
34Patch0: https://github.com/ueno/libkkc/commit/1f512da81a71287b13eb0a1f9b31830b16db2107.patch
35BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
36BuildRequires: pkgconfig(gee-0.8)
37BuildRequires: libgee-vala
38BuildRequires: json-glib-devel
39BuildRequires: marisa-trie-devel
40# for libkkc-data
41BuildRequires: marisa-trie-python
42%if %{with_vala}
43BuildRequires: vala-devel
44BuildRequires: vala-tools
45%endif
46
47Requires: libkkc-data = %{dataver}-%{datarel}%{_dist_release}
48Requires: libkkc-common = %{version}-%{release}
49
50Vendor: Project Vine
51Distribution: Vine Linux
52Packager: iwaim
53
54%description
55libkkc provides a converter from Kana-string to
56Kana-Kanji-mixed-string.  It was named after kkc.el in GNU Emacs, a
57simple Kana Kanji converter, while libkkc tries to convert sentences
58in a bit more complex way using N-gram language models.
59
60%package devel
61Summary: Header files and libraries for developing apps which will use libkkc
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description devel
66The libkkc-devel package contains the header files and libraries.
67
68%package tools
69Summary: Tools for %{name}
70Group: Applications/Accessories
71Requires: %{name} = %{version}-%{release}
72
73%description tools
74The %{name}-tools package contains tools for developing applications
75that use %{name}.
76
77%package common
78Summary: Common data files for %{name}
79
80%description common
81The %{name}-common package contains the arch-independent data that
82%{name} uses at run time.
83
84%package data
85Summary: Data files for %{name}
86Version: %{dataver}
87Release: %{datarel}%{_dist_release}
88
89%description data
90The %{name}-data package contains the language model data that %{name}
91uses at run time.
92
93%prep
94%if %{from_git}
95%setup -q -n %{name}-%{githash}
96%else
97%setup -q
98%endif
99%patch0 -p1
100
101# for libkkc-data
102tar xf %{SOURCE1}
103
104%build
105%if %{from_git}
106./autogen.sh
107%endif
108%configure --enable-shared --disable-static \
109           --disable-silent-rules \
110%if %{with_vala}
111           --enable-vala=yes \
112%else
113           --enable-vala=no \
114%endif
115
116%__make
117
118# for libkkc-data
119pushd %{name}-data-%{dataver}
120%configure
121%__make
122popd
123
124%install
125%__rm -rf $RPM_BUILD_ROOT
126%makeinstall
127
128# for libkkc-data
129pushd %{name}-data-%{dataver}
130%makeinstall
131popd
132
133%find_lang %{name}
134
135# remove files
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
137
138%clean
139%__rm -rf $RPM_BUILD_ROOT
140
141%post -p /sbin/ldconfig
142
143%postun -p /sbin/ldconfig
144
145%files -f %{name}.lang
146%defattr(-,root,root,-)
147%doc README ChangeLog COPYING AUTHORS NEWS
148%doc data/rules/README.rules
149%{_libdir}/libkkc.so.*
150%{_libdir}/girepository-1.0/Kkc-1.0.typelib
151%dir %{_datadir}/libkkc
152%{_datadir}/libkkc/rules
153
154%files devel
155%defattr(-,root,root,-)
156%doc COPYING AUTHORS
157%dir %{_includedir}/libkkc
158%{_includedir}/libkkc/libkkc.h
159%{_libdir}/libkkc.so
160%{_libdir}/pkgconfig/kkc-1.0.pc
161%{_datadir}/gir-1.0/Kkc-1.0.gir
162%{_datadir}/vala/vapi/kkc-1.0.deps
163%{_datadir}/vala/vapi/kkc-1.0.vapi
164
165%files tools
166%defattr(-,root,root,-)
167%doc COPYING AUTHORS
168%{_bindir}/kkc
169%{_bindir}/kkc-package-data
170
171%files common
172%defattr(-,root,root,-)
173%doc COPYING AUTHORS
174%dir %{_datadir}/libkkc
175%dir %{_datadir}/libkkc/templates
176%{_datadir}/libkkc/templates/libkkc-data
177
178%files data
179%defattr(-,root,root,-)
180%doc COPYING AUTHORS
181%dir %{_libdir}/libkkc
182%dir %{_libdir}/libkkc/models
183%{_libdir}/libkkc/models/sorted3
184
185%changelog
186* Thu Apr 30 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-2
187- add 'Try all possible okuri-gana combinations' patch (Patch0)
188- add BuildRequires: libgee-vala
189
190* Mon Dec 29 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-1
191- update to libkkc 0.3.5
192- switch upstream source location to GitHub
193
194* Mon Jul  7 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.4-1
195- update to libkkc 0.3.4
196- update BuildRequires for libgee
197
198* Sun Jun 15 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.3-1
199- update to libkkc 0.3.3
200
201* Wed Dec 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.2-1
202- update to libkkc 0.3.2
203
204* Thu Nov  7 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.1-1
205- update to libkkc 0.3.1
206- update to libkkc-data 0.2.7
207- fix changelog for 0.2.6-1
208
209* Sat Jul 27 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.6-1
210- update to libkkc 0.2.6
211- update to libkkc-data 0.2.5
212
213* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
214- update to libkkc 0.2.4
215- update to libkkc-data 0.2.0
216- add Version tag for libkkc-data sub package
217
218* Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
219- update to libkkc 0.1.10
220
221* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
222- update to libkkc 0.1.9
223
224* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
225- update to libkkc 0.1.8
226
227* Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
228- update to libkkc 0.1.7
229
230* Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
231- update to libkkc 0.1.6
232- update to libkkc-data 0.1.6
233
234* Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
235- update to libkkc 0.1.5
236
237* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
238- update to 0.1.3
239- update License value: GPLv3 -> GPLv3+
240- add BuildRequires: marisa-trie-python for libkkc-data
241- sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
242 - create tools sub package
243  - move %%{_bindir}/kkc
244  - add %%{_bindir}/kkc-package-data
245 - create common sub package
246  - add template for generating libkkc-data
247 - merge libkkc-data SRPM file
248  - add libkkc-data source file (Source1)
249  - create data sub package
250 - add '--disable-silent-rules' option for configure
251 - add Requires libkkc-data and libkkc-common
252 - add document: data/rules/README.rules
253
254* Wed Feb  6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
255- update to 0.1.2
256
257* Tue Feb  5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
258- update to 0.1.1
259
260* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
261- update to 0.1.0
262- rename libkkc.pc to kkc-1.0.pc by upstream
263
264* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
265- update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
266- add post and postun script
267- add translate file
268
269* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
270- support Vine Linux 6
271 - without Vala
272 - BR: libgee-devel
273
274* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
275- initial build for Vine Linux
276
Note: See TracBrowser for help on using the repository browser.