source: projects/specs/trunk/lib/libk/libkkc/libkkc-vl.spec @ 8822

Revision 8822, 6.3 KB checked in by iwaim, 10 years ago (diff)

libkkc 0.3.4-1

RevLine 
[8822]1%define ver 0.3.4
[7412]2%define rel 1
[8047]3%define dataver 0.2.7
[8822]4%define datarel 4
[7380]5
[7412]6%define from_git 0
[7393]7%if %{from_git}
8%define githash ccfd5c6d
9%endif
10
[7390]11%if "%{?_dist_release}" == "vl6"
12%define with_vala 0
13%else
14%define with_vala 1
15%endif
16
[7380]17Summary: Japanese Kana Kanji conversion library (libkkc)
18Name: libkkc
19Version: %{ver}
[7393]20%if %{from_git}
21Release: %{rel}.git%{githash}%{_dist_release}
22%else
[7380]23Release: %{rel}%{_dist_release}
[7393]24%endif
[7453]25License: GPLv3+
[7380]26Group: System Environment/Libraries
27URL: https://bitbucket.org/libkkc/libkkc/
[7393]28%if %{from_git}
29Source0: libkkc-%{githash}.tar.gz
30%else
[7380]31Source0: https://bitbucket.org/libkkc/libkkc/downloads/%{name}-%{version}.tar.gz
[7393]32%endif
[7453]33Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
[7380]34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
[8822]35BuildRequires: pkgconfig(gee-0.8)
[7380]36BuildRequires: json-glib-devel
37BuildRequires: marisa-trie-devel
[7453]38# for libkkc-data
39BuildRequires: marisa-trie-python
[7390]40%if %{with_vala}
[7380]41BuildRequires: vala-devel
42BuildRequires: vala-tools
[7390]43%endif
[7380]44
[8051]45Requires: libkkc-data = %{dataver}-%{datarel}%{_dist_release}
[7453]46Requires: libkkc-common = %{version}-%{release}
47
[7380]48Vendor: Project Vine
49Distribution: Vine Linux
50Packager: iwaim
51
52%description
53libkkc provides a converter from Kana-string to
54Kana-Kanji-mixed-string.  It was named after kkc.el in GNU Emacs, a
55simple Kana Kanji converter, while libkkc tries to convert sentences
56in a bit more complex way using N-gram language models.
57
58%package devel
59Summary: Header files and libraries for developing apps which will use libkkc
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62
63%description devel
64The libkkc-devel package contains the header files and libraries.
65
[7453]66%package tools
67Summary: Tools for %{name}
68Group: Applications/Accessories
69Requires: %{name} = %{version}-%{release}
70
71%description tools
72The %{name}-tools package contains tools for developing applications
73that use %{name}.
74
75%package common
76Summary: Common data files for %{name}
77
78%description common
79The %{name}-common package contains the arch-independent data that
80%{name} uses at run time.
81
82%package data
83Summary: Data files for %{name}
[7737]84Version: %{dataver}
[8051]85Release: %{datarel}%{_dist_release}
[7453]86
87%description data
88The %{name}-data package contains the language model data that %{name}
89uses at run time.
90
[7380]91%prep
[7393]92%if %{from_git}
93%setup -q -n %{name}-%{githash}
94%else
[7380]95%setup -q
[7393]96%endif
[7380]97
[7453]98# for libkkc-data
99tar xf %{SOURCE1}
100
[7380]101%build
[7393]102%if %{from_git}
103./autogen.sh
104%endif
[7390]105%configure --enable-shared \
[7453]106           --disable-silent-rules \
[7390]107%if %{with_vala}
108           --enable-vala=yes \
109%else
110           --enable-vala=no \
111%endif
112
[7380]113%__make
114
[7453]115# for libkkc-data
116pushd %{name}-data-%{dataver}
117%configure
118%__make
119popd
120
[7380]121%install
122%__rm -rf $RPM_BUILD_ROOT
123%makeinstall
124
[7453]125# for libkkc-data
126pushd %{name}-data-%{dataver}
127%makeinstall
128popd
129
[7393]130%find_lang %{name}
131
[7380]132# remove files
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
134
135%clean
136%__rm -rf $RPM_BUILD_ROOT
137
[7393]138%post -p /sbin/ldconfig
139
140%postun -p /sbin/ldconfig
141
142%files -f %{name}.lang
[7380]143%defattr(-,root,root,-)
144%doc README ChangeLog COPYING AUTHORS NEWS
[7453]145%doc data/rules/README.rules
[7380]146%{_libdir}/libkkc.so.*
147%{_libdir}/girepository-1.0/Kkc-1.0.typelib
148%dir %{_datadir}/libkkc
149%{_datadir}/libkkc/rules
150
151%files devel
152%defattr(-,root,root,-)
153%doc COPYING AUTHORS
154%dir %{_includedir}/libkkc
155%{_includedir}/libkkc/libkkc.h
156%{_libdir}/libkkc.so
[7412]157%{_libdir}/pkgconfig/kkc-1.0.pc
[7380]158%{_datadir}/gir-1.0/Kkc-1.0.gir
159%{_datadir}/vala/vapi/kkc-1.0.deps
160%{_datadir}/vala/vapi/kkc-1.0.vapi
161
[7453]162%files tools
163%defattr(-,root,root,-)
164%doc COPYING AUTHORS
165%{_bindir}/kkc
166%{_bindir}/kkc-package-data
167
168%files common
169%defattr(-,root,root,-)
170%doc COPYING AUTHORS
171%dir %{_datadir}/libkkc
172%dir %{_datadir}/libkkc/templates
173%{_datadir}/libkkc/templates/libkkc-data
174
175%files data
176%defattr(-,root,root,-)
177%doc COPYING AUTHORS
178%dir %{_libdir}/libkkc
179%dir %{_libdir}/libkkc/models
180%{_libdir}/libkkc/models/sorted3
181
[7380]182%changelog
[8822]183* Mon Jul  7 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.4-1
184- update to libkkc 0.3.4
185- update BuildRequires for libgee
186
[8565]187* Sun Jun 15 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.3-1
188- update to libkkc 0.3.3
189
[8051]190* Wed Dec 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.2-1
191- update to libkkc 0.3.2
192
[8047]193* Thu Nov  7 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.1-1
194- update to libkkc 0.3.1
195- update to libkkc-data 0.2.7
196- fix changelog for 0.2.6-1
197
[7967]198* Sat Jul 27 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.6-1
199- update to libkkc 0.2.6
[8047]200- update to libkkc-data 0.2.5
[7967]201
[7737]202* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
203- update to libkkc 0.2.4
204- update to libkkc-data 0.2.0
205- add Version tag for libkkc-data sub package
206
[7615]207* Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
208- update to libkkc 0.1.10
209
[7593]210* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
211- update to libkkc 0.1.9
212
[7552]213* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
214- update to libkkc 0.1.8
215
[7509]216* Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
217- update to libkkc 0.1.7
218
[7481]219* Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
220- update to libkkc 0.1.6
221- update to libkkc-data 0.1.6
222
[7468]223* Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
224- update to libkkc 0.1.5
225
[7453]226* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
227- update to 0.1.3
228- update License value: GPLv3 -> GPLv3+
229- add BuildRequires: marisa-trie-python for libkkc-data
230- sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
231 - create tools sub package
232  - move %%{_bindir}/kkc
233  - add %%{_bindir}/kkc-package-data
234 - create common sub package
235  - add template for generating libkkc-data
236 - merge libkkc-data SRPM file
237  - add libkkc-data source file (Source1)
238  - create data sub package
239 - add '--disable-silent-rules' option for configure
240 - add Requires libkkc-data and libkkc-common
241 - add document: data/rules/README.rules
242
[7441]243* Wed Feb  6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
244- update to 0.1.2
245
[7434]246* Tue Feb  5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
247- update to 0.1.1
248
[7412]249* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
250- update to 0.1.0
251- rename libkkc.pc to kkc-1.0.pc by upstream
252
[7393]253* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
254- update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
255- add post and postun script
256- add translate file
257
[7390]258* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
259- support Vine Linux 6
260 - without Vala
261 - BR: libgee-devel
262
[7380]263* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
264- initial build for Vine Linux
265
Note: See TracBrowser for help on using the repository browser.