source: projects/specs/trunk/lib/libk/libkkc/libkkc-vl.spec @ 10874

Revision 10874, 7.2 KB checked in by iwaim, 7 years ago (diff)

libkkc 0.3.5-4

RevLine 
[9201]1%define ver 0.3.5
[10874]2%define rel 4
[8047]3%define dataver 0.2.7
[10874]4%define datarel 8
[7380]5
[7412]6%define from_git 0
[7393]7%if %{from_git}
8%define githash ccfd5c6d
9%endif
10
[7390]11%if "%{?_dist_release}" == "vl6"
12%define with_vala 0
13%else
14%define with_vala 1
15%endif
16
[7380]17Summary: Japanese Kana Kanji conversion library (libkkc)
18Name: libkkc
19Version: %{ver}
[7393]20%if %{from_git}
21Release: %{rel}.git%{githash}%{_dist_release}
22%else
[7380]23Release: %{rel}%{_dist_release}
[7393]24%endif
[7453]25License: GPLv3+
[7380]26Group: System Environment/Libraries
27URL: https://bitbucket.org/libkkc/libkkc/
[7393]28%if %{from_git}
29Source0: libkkc-%{githash}.tar.gz
30%else
[9201]31Source0: https://github.com/ueno/libkkc/releases/download/v%{version}/%{name}-%{version}.tar.gz
[7393]32%endif
[7453]33Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
[9534]34Patch0: https://github.com/ueno/libkkc/commit/1f512da81a71287b13eb0a1f9b31830b16db2107.patch
[10227]35Patch1: https://github.com/ueno/libkkc/commit/46b02adf1fe806e99f8d896f770591480165f90a.patch
[10874]36Patch2: https://github.com/ueno/libkkc/commit/5bdbec71a1879e75e64b8cfd6cc6913411219067.patch
[7380]37BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
[8822]38BuildRequires: pkgconfig(gee-0.8)
[9534]39BuildRequires: libgee-vala
[7380]40BuildRequires: json-glib-devel
41BuildRequires: marisa-trie-devel
[7453]42# for libkkc-data
43BuildRequires: marisa-trie-python
[7390]44%if %{with_vala}
[7380]45BuildRequires: vala-devel
46BuildRequires: vala-tools
[7390]47%endif
[7380]48
[8051]49Requires: libkkc-data = %{dataver}-%{datarel}%{_dist_release}
[7453]50Requires: libkkc-common = %{version}-%{release}
51
[7380]52Vendor: Project Vine
53Distribution: Vine Linux
54Packager: iwaim
55
56%description
57libkkc provides a converter from Kana-string to
58Kana-Kanji-mixed-string.  It was named after kkc.el in GNU Emacs, a
59simple Kana Kanji converter, while libkkc tries to convert sentences
60in a bit more complex way using N-gram language models.
61
62%package devel
63Summary: Header files and libraries for developing apps which will use libkkc
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description devel
68The libkkc-devel package contains the header files and libraries.
69
[7453]70%package tools
71Summary: Tools for %{name}
72Group: Applications/Accessories
73Requires: %{name} = %{version}-%{release}
74
75%description tools
76The %{name}-tools package contains tools for developing applications
77that use %{name}.
78
79%package common
80Summary: Common data files for %{name}
81
82%description common
83The %{name}-common package contains the arch-independent data that
84%{name} uses at run time.
85
86%package data
87Summary: Data files for %{name}
[7737]88Version: %{dataver}
[8051]89Release: %{datarel}%{_dist_release}
[7453]90
91%description data
92The %{name}-data package contains the language model data that %{name}
93uses at run time.
94
[7380]95%prep
[7393]96%if %{from_git}
97%setup -q -n %{name}-%{githash}
98%else
[7380]99%setup -q
[7393]100%endif
[9534]101%patch0 -p1
[10873]102%patch1 -p1
[10874]103%patch2 -p1
[7380]104
[7453]105# for libkkc-data
106tar xf %{SOURCE1}
107
[7380]108%build
[7393]109%if %{from_git}
110./autogen.sh
111%endif
[9534]112%configure --enable-shared --disable-static \
[7453]113           --disable-silent-rules \
[7390]114%if %{with_vala}
115           --enable-vala=yes \
116%else
117           --enable-vala=no \
118%endif
119
[7380]120%__make
121
[7453]122# for libkkc-data
123pushd %{name}-data-%{dataver}
124%configure
125%__make
126popd
127
[7380]128%install
129%__rm -rf $RPM_BUILD_ROOT
130%makeinstall
131
[7453]132# for libkkc-data
133pushd %{name}-data-%{dataver}
134%makeinstall
135popd
136
[7393]137%find_lang %{name}
138
[7380]139# remove files
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
141
142%clean
143%__rm -rf $RPM_BUILD_ROOT
144
[7393]145%post -p /sbin/ldconfig
146
147%postun -p /sbin/ldconfig
148
149%files -f %{name}.lang
[7380]150%defattr(-,root,root,-)
151%doc README ChangeLog COPYING AUTHORS NEWS
[7453]152%doc data/rules/README.rules
[7380]153%{_libdir}/libkkc.so.*
154%{_libdir}/girepository-1.0/Kkc-1.0.typelib
155%dir %{_datadir}/libkkc
156%{_datadir}/libkkc/rules
157
158%files devel
159%defattr(-,root,root,-)
160%doc COPYING AUTHORS
161%dir %{_includedir}/libkkc
162%{_includedir}/libkkc/libkkc.h
163%{_libdir}/libkkc.so
[7412]164%{_libdir}/pkgconfig/kkc-1.0.pc
[7380]165%{_datadir}/gir-1.0/Kkc-1.0.gir
166%{_datadir}/vala/vapi/kkc-1.0.deps
167%{_datadir}/vala/vapi/kkc-1.0.vapi
168
[7453]169%files tools
170%defattr(-,root,root,-)
171%doc COPYING AUTHORS
172%{_bindir}/kkc
173%{_bindir}/kkc-package-data
174
175%files common
176%defattr(-,root,root,-)
177%doc COPYING AUTHORS
178%dir %{_datadir}/libkkc
179%dir %{_datadir}/libkkc/templates
180%{_datadir}/libkkc/templates/libkkc-data
181
182%files data
183%defattr(-,root,root,-)
184%doc COPYING AUTHORS
185%dir %{_libdir}/libkkc
186%dir %{_libdir}/libkkc/models
187%{_libdir}/libkkc/models/sorted3
188
[7380]189%changelog
[10874]190* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-4
191- add 'rom-kana: Fix range check in is_valid()' patch (Patch2)
192
193* Fri Apr 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
[10227]194- add 'Modify Kana rules for ignoring moored shift key.' patch (Patch1)
195
[9534]196* Thu Apr 30 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-2
197- add 'Try all possible okuri-gana combinations' patch (Patch0)
198- add BuildRequires: libgee-vala
199
[9201]200* Mon Dec 29 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-1
201- update to libkkc 0.3.5
202- switch upstream source location to GitHub
203
[8822]204* Mon Jul  7 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.4-1
205- update to libkkc 0.3.4
206- update BuildRequires for libgee
207
[8565]208* Sun Jun 15 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.3-1
209- update to libkkc 0.3.3
210
[8051]211* Wed Dec 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.2-1
212- update to libkkc 0.3.2
213
[8047]214* Thu Nov  7 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.1-1
215- update to libkkc 0.3.1
216- update to libkkc-data 0.2.7
217- fix changelog for 0.2.6-1
218
[7967]219* Sat Jul 27 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.6-1
220- update to libkkc 0.2.6
[8047]221- update to libkkc-data 0.2.5
[7967]222
[7737]223* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
224- update to libkkc 0.2.4
225- update to libkkc-data 0.2.0
226- add Version tag for libkkc-data sub package
227
[7615]228* Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
229- update to libkkc 0.1.10
230
[7593]231* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
232- update to libkkc 0.1.9
233
[7552]234* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
235- update to libkkc 0.1.8
236
[7509]237* Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
238- update to libkkc 0.1.7
239
[7481]240* Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
241- update to libkkc 0.1.6
242- update to libkkc-data 0.1.6
243
[7468]244* Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
245- update to libkkc 0.1.5
246
[7453]247* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
248- update to 0.1.3
249- update License value: GPLv3 -> GPLv3+
250- add BuildRequires: marisa-trie-python for libkkc-data
251- sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
252 - create tools sub package
253  - move %%{_bindir}/kkc
254  - add %%{_bindir}/kkc-package-data
255 - create common sub package
256  - add template for generating libkkc-data
257 - merge libkkc-data SRPM file
258  - add libkkc-data source file (Source1)
259  - create data sub package
260 - add '--disable-silent-rules' option for configure
261 - add Requires libkkc-data and libkkc-common
262 - add document: data/rules/README.rules
263
[7441]264* Wed Feb  6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
265- update to 0.1.2
266
[7434]267* Tue Feb  5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
268- update to 0.1.1
269
[7412]270* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
271- update to 0.1.0
272- rename libkkc.pc to kkc-1.0.pc by upstream
273
[7393]274* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
275- update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
276- add post and postun script
277- add translate file
278
[7390]279* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
280- support Vine Linux 6
281 - without Vala
282 - BR: libgee-devel
283
[7380]284* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
285- initial build for Vine Linux
286
Note: See TracBrowser for help on using the repository browser.