source: projects/specs/trunk/lib/libk/libkipi/libkipi-vl.spec @ 10548

Revision 10548, 4.4 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:    libkipi
2Summary: Common plugin infrastructure for KDE image applications
3Summary(ja): KDE 画像アプリケーション向けの共通プラグインインフラストラクチャ
4Version: 4.14.3
5Release: 2%{?_dist_release}
6
7License: GPLv2+
8Group:   System Environment/Libraries
9URL:     https://projects.kde.org/projects/kde/kdegraphics/libs/libkexiv2
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: kdelibs-devel >= %{version}
15BuildRequires: soprano-devel
16
17Requires: kdelibs >= %{version}
18
19# when split occurred
20Conflicts: kdegraphics-libs < 4.6.95-10
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26Kipi (KDE Image Plugin Interface) is an effort to develop a common plugin
27structure (for Digikam, Gwenview, etc.). Its aim is to share
28image plugins among graphic applications.
29
30%package devel
31Summary:  Development files for %{name}
32Summary(ja): %{name} の開発用ファイル
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35Requires: kdelibs-devel
36
37%description devel
38%{summary}.
39
40
41%prep
42%setup -q
43
44%build
45mkdir -p %{_target_platform}
46pushd %{_target_platform}
47%cmake \
48    -DCMAKE_BUILD_TYPE=release \
49    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
50    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
51    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
52    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
53    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
54    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
55    ..
56popd
57
58make %{?_smp_mflags} -C %{_target_platform}
59
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
65
66
67%check
68export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_datadir}/pkgconfig:$RPM_BUILD_ROOT%{_libdir}/pkgconfig
69pkg-config --modversion libkipi
70
71
72%post
73/sbin/ldconfig
74touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
75
76%posttrans
77gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
78
79%postun
80/sbin/ldconfig
81if [ $1 -eq 0 ] ; then
82    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
83    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
84fi
85
86
87%files
88%doc AUTHORS COPYING NEWS README
89%{_bindir}/kxmlkipicmd
90%{_libdir}/libkipi.so.*
91%{_libdir}/kde4/kipiplugin_kxmlhelloworld.so
92%{_datadir}/kde4/apps/kipi/
93%{_datadir}/kde4/apps/kxmlkipicmd/
94%{_datadir}/icons/hicolor/*/*/*
95%{_datadir}/kde4/servicetypes/kipiplugin.desktop
96%{_datadir}/kde4/services/kipiplugin_kxmlhelloworld.desktop
97
98%files devel
99%{_libdir}/libkipi.so
100%{_libdir}/pkgconfig/libkipi.pc
101%{_includedir}/kde4/libkipi/
102
103
104%changelog
105* Wed Jul 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
106- rebuild with gcc-5.4.0
107
108* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
109- new upstream release
110
111* Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
112- new upstream release
113
114* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
115- new upstream release
116
117* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
118- new upstream release
119
120* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
121- new upstream release
122
123* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
124- new upstream release
125
126* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
127- new upstream release
128
129* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
130- new upstream release
131
132* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
133- new upstream release
134
135* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
136- new upstream release
137
138* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
139- new upstream release
140
141* Sun Dec 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
142- new upstream release
143
144* Sat Oct 15 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
145- new upstream release
146
147* Mon Aug  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
148- Initial build for Vine Linux
149
150* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
151- 4.7.0
152
153* Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
154- 4.6.95
155- fix URL
156
157* Wed Jul 06 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-3
158- Conflicts: kdegraphics < 7:4.6.90
159
160* Wed Jul 06 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-2
161- License: GPLv2+
162- fix scriptlets
163- %%doc: +NEWS, -TODO
164- fix Source0 URL
165
166* Tue Jul 05 2011 Rex Dieter <rdieter@fedoraproject.org>  4.6.90-1
167- first try
168
169
Note: See TracBrowser for help on using the repository browser.