source: projects/specs/trunk/lib/libk/libkgapi/libkgapi-vl.spec @ 6725

Revision 6725, 2.5 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.0

Line 
1Name:    libkgapi
2Summary: Google APIs for KDE
3Summary(ja): KDE 向け Google API 集
4Version: 0.4.1
5Release: 1%{?_dist_release}
6
7License: GPLv2+
8Group:   System Environment/Libraries
9URL:     https://projects.kde.org/projects/extragear/libs/libkgapi
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/%{name}/%{version}/src/%{name}-%{version}.tar.bz2
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: kdelibs-devel >= 4.7.0
15BuildRequires: kdepimlibs-devel >= 4.6
16BuildRequires: libkipi-devel
17BuildRequires: qjson-devel
18BuildRequires: soprano-devel
19BuildRequires: libboost-devel
20
21Requires: kdelibs4 >= 4.7.0
22
23
24%description
25LibKGAPI (previously called LibKGoogle) is a C++ library that implements APIs for
26various Google services.
27
28Currently supported APIs:
29  - Calendar API v3 (https://developers.google.com/google-apps/calendar)
30  - Contacts API v3 (https://developers.google.com/google-apps/contacts/v3/)
31  - Tasks API v1 (https://developers.google.com/google-apps/tasks)
32
33
34%package devel
35Summary:  Development files for %{name}
36Summary(ja): %{name} の開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: kdelibs4-devel
40
41%description devel
42%{summary}.
43
44
45%prep
46%setup -q
47
48%build
49mkdir -p %{_target_platform}
50pushd %{_target_platform}
51%cmake \
52    -DCMAKE_BUILD_TYPE=release \
53    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
54    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
55    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
56    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
57    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
58    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
59    ..
60popd
61
62make %{?_smp_mflags} -C %{_target_platform}
63
64
65%install
66rm -rf $RPM_BUILD_ROOT
67
68make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
69
70
71%check
72export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_datadir}/pkgconfig:$RPM_BUILD_ROOT%{_libdir}/pkgconfig
73pkg-config --modversion libkipi
74
75
76%post
77/sbin/ldconfig
78touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
79
80%posttrans
81gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
82
83%postun
84/sbin/ldconfig
85if [ $1 -eq 0 ] ; then
86    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
87    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
88fi
89
90
91%files
92%defattr(-,root,root,-)
93%doc LICENSE README
94%{_libdir}/libkgapi.so.*
95
96%files devel
97%defattr(-,root,root,-)
98%{_includedir}/kde4/%{name}
99%{_libdir}/libkgapi.so
100%{_libdir}/cmake/LibKGAPI
101%{_libdir}/pkgconfig/%{name}.pc
102
103
104%changelog
105* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-1
106- initial build
Note: See TracBrowser for help on using the repository browser.